Metadata updating failed when trying to update ID3 tags on mp3 files

Bug #509643 reported by Pétur Ingi Egilsson on 2010-01-19
90
This bug affects 19 people
Affects Status Importance Assigned to Milestone
audacious (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: audacious

I installed Audacious from the official repos.

1. Select any mp3 file from the playlist.
2. Press alt+i to open the "Track Information" dialog.
3. I try edit the title and press Save.

An error message appears at the bottom of the dialog "Metadata updating failed", and then disappears after a few seconds.

I have full permission to the mp3 files in question.
Changing the ID3 tag using other programs such as EasyTAG (found in the official repos) seams to work ok.

ProblemType: Bug
Architecture: i386
Date: Tue Jan 19 14:58:17 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/audacious2
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: nvidia
Package: audacious 2.1-1ubuntu1
ProcEnviron:
 LANG=en_DK.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
SourcePackage: audacious
Uname: Linux 2.6.31-17-generic i686

Pétur Ingi Egilsson (petur) wrote :
Bram (bramt) wrote :

When running Audacious from the command line and changing an ID3 tag, this is what shows up:

(audacious2:2287): GLib-GIO-CRITICAL **: g_output_stream_write: assertion `G_IS_OUTPUT_STREAM (stream)' failed

Benjamin Drung (bdrung) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner.
There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test Audacious 2.3 from the latest stable Ubuntu version (10.04) or the current Ubuntu development version (10.10). If you can test it, and it is still an issue, we would appreciate if you could upload updated logs by running apport-collect #509643, and any other logs that are relevant for this particular issue.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

Changed in audacious (Ubuntu):
status: New → Incomplete
Dennis van Beek (dvbeek) wrote :

I also had this problem...
Now, on Ubuntu 10.04 and Audacious 2.3 the problems is gone!

Benjamin Drung (bdrung) on 2010-06-19
Changed in audacious (Ubuntu):
status: Incomplete → Invalid
nick (tectp) wrote :

I cannot edit the metadata at all in audacious2 let alone save it. i'm on lucid 10.04

giffel (xgiffel) wrote :

Issue still persist in Ubuntu Maverick 10.10 with Audacious 2.4.0. I investigate a bit (with "eyed3" ID3 command-line utility) and find out that problem affect only mp3s with ID3 tag version 1.0, 1.1 and 2.2. Versions 2.3 and 2.4 are not affected.

giffel (xgiffel) on 2010-11-22
Changed in audacious (Ubuntu):
status: Invalid → New
Seb Bonnard (sebmansfeld) wrote :

I also can't update ID3 tags with Audacious v2.1-1 on Karmic.
I'll check on on newer Ubuntu distributions.

Changed in audacious (Ubuntu):
status: New → Confirmed
summary: - Metadata updaing failed when trying to update ID3 tags on mp3 files
+ Metadata updating failed when trying to update ID3 tags on mp3 files
Seb Bonnard (sebmansfeld) wrote :

BTW, I found out that audacious log is available in the file ~/.config/audacious/log.
Who knows, it may help.

mahdi (desgo) wrote :

I had same problem with web streams, walk around for this was to edit /home/username/.config/audacious/playlist.xspf
e.g if want to edit artist change <creator>artist name</creator> in track section and so on

Vova U (uwl) wrote :

this bug is still there (12.04 + audacious 3.2.1)

Andreas Wesik (ezel) wrote :

Stil a bug. Some songs one can change the info for, some songs you can't.
My gutfeeling says it's related to id3v1 / id3v2 conflict.

Sale (alexandarzaric) wrote :

And still same bug here.
Ubuntu 12.04 - Kernel Linux 3.2.0-31-generic
Audacious 3.2.1

Peyre (lordpeyre) wrote :

I'm still having this issue, four years later. What gives?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers