Ubuntu

Please merge audacious 1.5.1-3 (universe) from Debian unstable (main).

Reported by Bhavani Shankar on 2008-08-10
6
Affects Status Importance Assigned to Milestone
audacious (Ubuntu)
Wishlist
Unassigned

Bug Description

Debian has a new version which has to be merged.

Daniel Holbach (dholbach) wrote :

Can you please explain why debian/patches/004-change-default-output-plugin.dpatch can also be dropped?

Changed in audacious:
status: New → Incomplete
Bhavani Shankar (bhavi) wrote :

yes daniel, I m in my university caampus right now. when I go home I ll explain.

Changed in audacious:
assignee: nobody → bhavi
status: Incomplete → In Progress
Bhavani Shankar (bhavi) wrote :

audacious (1.5.1-3ubuntu1) intrepid; urgency=low

  * Merge from debian unstable, remaining changes:
    - debian/control: Change dependency relations to make the package
      installable.
    + debian/patches/004-change-default-output-plugin.dpatch:
    - Change the default output plugin to pulseaudio. (LP: #175536)
    + debian/patches/00list: Add change-default-output-plugin to list.
  * Bump standards version to 3.8.0.

 -- Bhavani Shankar <email address hidden> Wed, 13 Aug 2008 18:42:18 +0530

Bhavani Shankar (bhavi) wrote :
Changed in audacious:
status: In Progress → Confirmed
Bhavani Shankar (bhavi) on 2008-08-13
Changed in audacious:
assignee: bhavi → nobody
status: Confirmed → New
Daniel Holbach (dholbach) wrote :

Can you please remove all the index.html files in the diff? I don't think they belong there.

Bhavani Shankar (bhavi) wrote :
Bhavani Shankar (bhavi) wrote :

Done daniel.

Daniel Holbach (dholbach) wrote :

The Debian -> Ubuntu debdiff does not apply to 1.5.1-3.

Also it makes sense not to re-iterate the "Change dependency reations to make the package installable." change in your entry. It's nothing we had in Ubuntu before, so it's not a "remaining change".

Bhavani Shankar (bhavi) wrote :
Download full text (15.8 KiB)

okay! daniel.. Here is the regenerated debdiff

and I verified it on my system

bhavani@intrepid:~/audacious-1.5.1$ patch -p1 < ../debian.debdiff
patching file debian/control
patching file debian/changelog
patching file 'man/index.html?C=S;O=D'
patching file 'man/index.html?C=S;O=A'
patching file 'man/index.html?C=N;O=D'
patching file 'man/index.html?C=M;O=A'
patching file 'man/index.html?C=N;O=A'
patching file 'man/index.html?C=M;O=D'
patching file man/index.html
patching file 'man/index.html?C=D;O=A'
patching file 'man/index.html?C=D;O=D'
patching file 'index.html?C=S;O=D'
patching file 'scripts/index.html?C=S;O=D'
patching file 'scripts/index.html?C=S;O=A'
patching file 'scripts/index.html?C=N;O=D'
patching file 'scripts/index.html?C=M;O=A'
patching file 'scripts/index.html?C=N;O=A'
patching file 'scripts/index.html?C=M;O=D'
patching file scripts/index.html
patching file 'scripts/index.html?C=D;O=A'
patching file 'scripts/index.html?C=D;O=D'
patching file po/pt_BR.po
patching file po/ja.po
patching file po/sr.po
patching file po/hr.po
patching file 'po/index.html?C=S;O=D'
patching file po/br.po
patching file po/ru.po
patching file po/zh_TW.po
patching file po/cy.po
patching file po/et.po
patching file 'po/index.html?C=S;O=A'
patching file 'po/index.html?C=N;O=D'
patching file po/tr.po
patching file po/de.po
patching file 'po/index.html?C=M;O=A'
patching file po/lt.po
patching file <email address hidden>
patching file po/sk.po
patching file po/cs.po
patching file po/hu.po
patching file 'po/index.html?C=N;O=A'
patching file 'po/index.html?C=M;O=D'
patching file po/it.po
patching file po/ro.po
patching file po/audacious.pot
patching file po/es.po
patching file po/fr.po
patching file po/ka.po
patching file po/el.po
patching file po/ko.po
patching file po/mk.po
patching file po/pl.po
patching file po/bg.po
patching file po/index.html
patching file po/zh_CN.po
patching file po/nl.po
patching file 'po/index.html?C=D;O=A'
patching file po/sv.po
patching file po/hi.po
patching file po/ca.po
patching file 'po/index.html?C=D;O=D'
patching file po/uk.po
patching file po/fi.po
patching file 'index.html?C=S;O=A'
patching file 'index.html?C=N;O=D'
patching file 'index.html?C=M;O=A'
patching file 'Skins/Ivory/index.html?C=S;O=D'
patching file 'Skins/Ivory/index.html?C=S;O=A'
patching file 'Skins/Ivory/index.html?C=N;O=D'
patching file 'Skins/Ivory/index.html?C=M;O=A'
patching file 'Skins/Ivory/index.html?C=N;O=A'
patching file 'Skins/Ivory/index.html?C=M;O=D'
patching file Skins/Ivory/index.html
patching file 'Skins/Ivory/index.html?C=D;O=A'
patching file 'Skins/Ivory/index.html?C=D;O=D'
patching file 'Skins/index.html?C=S;O=D'
patching file 'Skins/Classic/index.html?C=S;O=D'
patching file 'Skins/Classic/index.html?C=S;O=A'
patching file 'Skins/Classic/index.html?C=N;O=D'
patching file 'Skins/Classic/index.html?C=M;O=A'
patching file 'Skins/Classic/index.html?C=N;O=A'
patching file 'Skins/Classic/index.html?C=M;O=D'
patching file Skins/Classic/index.html
patching file 'Skins/Classic/index.html?C=D;O=A'
patching file 'Skins/Classic/index.html?C=D;O=D'
patching file 'Skins/index.html?C=S;O=A'
patching file 'Skins/index.html?C=N;O=D'
patching file 'Skins/Default/ind...

Changed in audacious:
status: New → Confirmed
description: updated
Bhavani Shankar (bhavi) wrote :

If I hand edit the debdiff as in the earlier case it doesnt work on my system.

Bhavani Shankar (bhavi) wrote :

Further explanation sir:

Output of modified patch:
bhavani@intrepid:~/audacious-1.5.1$ patch -p1 < ../debian.debdiff
patching file debian/control
Hunk #1 FAILED at 1.
Hunk #2 FAILED at 10.
2 out of 2 hunks FAILED -- saving rejects to file debian/control.rej
patching file debian/changelog
patching file po/pt_BR.po
Hunk #1 FAILED at 173.
Hunk #2 FAILED at 3026.
2 out of 2 hunks FAILED -- saving rejects to file po/pt_BR.po.rej
patching file po/ja.po
Hunk #1 FAILED at 185.
Hunk #2 FAILED at 3022.
2 out of 2 hunks FAILED -- saving rejects to file po/ja.po.rej
patching file po/sr.po
Hunk #2 FAILED at 1714.
Hunk #3 FAILED at 2268.
Hunk #4 FAILED at 2480.
Hunk #5 FAILED at 2660.
Hunk #6 FAILED at 2988.
Hunk #7 FAILED at 3023.
6 out of 7 hunks FAILED -- saving rejects to file po/sr.po.rej
patching file po/hr.po
Hunk #1 FAILED at 3051.
1 out of 1 hunk FAILED -- saving rejects to file po/hr.po.rej
patching file po/br.po
Reversed (or previously applied) patch detected! Assume -R? [n] n
Apply anyway? [n] y
Hunk #1 succeeded at 3084 with fuzz 1 (offset 9 lines).
patching file po/ru.po
Reversed (or previously applied) patch detected! Assume -R? [n] n
Apply anyway? [n] y
Hunk #1 FAILED at 21.
Hunk #2 FAILED at 49.
Hunk #3 FAILED at 180.
Hunk #4 FAILED at 219.
Hunk #5 FAILED at 250.
Hunk #6 FAILED at 279.
Hunk #7 FAILED at 1070.
Hunk #8 FAILED at 1152.
Hunk #9 FAILED at 1181.
Hunk #10 FAILED at 1214.
Hunk #11 FAILED at 1247.
Hunk #12 FAILED at 1288.
Hunk #13 FAILED at 1312.
Hunk #14 FAILED at 1322.
Hunk #15 FAILED at 1404.
Hunk #16 FAILED at 1468.
Hunk #17 FAILED at 1488.
Hunk #18 FAILED at 1545.
Hunk #19 FAILED at 1573.
Hunk #20 FAILED at 1633.
Hunk #21 FAILED at 1719.
Hunk #22 FAILED at 1778.
Hunk #23 FAILED at 1787.
Hunk #24 FAILED at 1796.
Hunk #25 FAILED at 1841.
Hunk #26 FAILED at 1901.
Hunk #27 FAILED at 1945.
Hunk #28 FAILED at 1985.
Hunk #29 FAILED at 1994.
Hunk #30 FAILED at 2003.
Hunk #31 FAILED at 2084.
Hunk #32 FAILED at 2249.
Hunk #33 FAILED at 2285.
Hunk #34 FAILED at 2320.
Hunk #35 FAILED at 2354.
Hunk #36 FAILED at 2370.
Hunk #37 FAILED at 2402.
Hunk #38 FAILED at 2412.
Hunk #39 FAILED at 2436.
Hunk #40 FAILED at 2449.
Hunk #41 FAILED at 2491.
Hunk #42 FAILED at 2501.
Hunk #43 FAILED at 2527.
Hunk #44 FAILED at 2571.
Hunk #45 FAILED at 2599.
Hunk #46 FAILED at 2640.
Hunk #47 FAILED at 2673.
Hunk #48 FAILED at 2688.
Hunk #49 FAILED at 2757.
Hunk #50 FAILED at 2780.
Hunk #51 FAILED at 2879.
Hunk #52 FAILED at 3012.
Hunk #53 FAILED at 3048.
53 out of 53 hunks FAILED -- saving rejects to file po/ru.po.rej
patching file po/zh_TW.po
Hunk #1 FAILED at 3066.
1 out of 1 hunk FAILED -- saving rejects to file po/zh_TW.po.rej
patching file po/cy.po
Reversed (or previously applied) patch detected! Assume -R? [n]

Daniel Holbach (dholbach) wrote :

That means the patch can't be applied or used for sponsoring. Hum, what do you expect me to sponsor right now?

Bhavani Shankar (bhavi) wrote :

Ok sir I ll make it work..

Benjamin Drung (bdrung) wrote :

There are some other issues (e.g. 004-change-default-output-plugin.dpatch not applied). I will cleanup the Ubuntu changes and add the fix for bug #258797 tomorrow.

Changed in audacious:
assignee: nobody → bdrung
status: Confirmed → In Progress
Benjamin Drung (bdrung) wrote :

change-default-output-plugin.patch needs to be rebased. Instead of hacking the source files it would be better to split the audacious-plugins package into single package for each plugin and only install pulse plugin by default.

audacious (1.5.1-3ubuntu1) intrepid; urgency=low

  * Merge from Debian unstable, remaining changes:
    + debian/control:
      - Change maintainer to Ubuntu MOTU.
      - Change the audacious dependencies on libaudid3tag1 and libaudclient1
        to be >= ${binary:Version} to fix package uninstallability.
    + debian/patches/change-default-output-plugin.patch: Change the
      default output plugin to pulseaudio. (LP: #175536). It is not added to
      debian/patches/series, because it needs to be rebased.
  * Dropped Ubuntu changes:
    - *index.html*: Removed (probably a packaging mistake).
    - debian/patches/00list: Removed, because the Debian package use quilt
      (series) instead of dpatch (00list) as patch system.
    - Removed all changes to the translation files, because they only affect
      the file structure and not the content.
  * Add bugzilla-42.patch to resolve a playlist bug where entry->tuple is NULL
    but we try to access it. This results in huge log file (LP: #258797). This
    patch will be in the next upstream release.
  * debian/rules: Do not disable SSE2 on x86_64, because all x86_64 CPUs
    support SSE2.

 -- Benjamin Drung <email address hidden> Tue, 19 Aug 2008 16:02:12 +0200

Changed in audacious:
assignee: bdrung → nobody
status: In Progress → Fix Committed
Daniel Holbach (dholbach) wrote :

Is the Ubuntu change
      - Change the audacious dependencies on libaudid3tag1 and libaudclient1
        to be >= ${binary:Version} to fix package uninstallability.
still necessary after this change?

 audacious (1.5.1-3) unstable; urgency=medium

   * Change dependency relations to make the package installable.

Benjamin Drung (bdrung) wrote :

Daniel, you are right. The Ubuntu change is not longer needed.

audacious (1.5.1-3ubuntu1) intrepid; urgency=low

  * Merge from Debian unstable (LP: #256574), remaining changes:
    + debian/control: Change maintainer to Ubuntu MOTU.
    + debian/patches/change-default-output-plugin.patch: Change the default
      output plugin to pulseaudio.
    + debian/patches/series: Add change-default-output-plugin to list.
  * Dropped Ubuntu changes:
    - *index.html*: Removed (probably a packaging mistake).
    - debian/patches/00list: Removed, because the Debian package use quilt
      (series) instead of dpatch (00list) as patch system.
    - Removed all changes to the translation files, because they only affect
      the file structure and not the content.
    - debian/control: Change the audacious dependencies on libaudid3tag1
      and libaudclient1 to be >= ${source:Upstream-Version}, to fix package
      uninstallability.
  * Add bugzilla-42.patch to resolve a playlist bug where entry->tuple is NULL
    but we try to access it. This results in huge log file (LP: #258797). This
    patch will be in the next upstream release.
  * debian/rules: Do not disable SSE2 on x86_64, because all x86_64 CPUs
    support SSE2.
  * debian/patches/change-default-output-plugin.patch: Rebased.

 -- Benjamin Drung <email address hidden> Fri, 22 Aug 2008 20:01:37 +0200

Benjamin Drung (bdrung) wrote :

change-default-output-plugin did not work. Now I have solved this problem using an easier way.

There is one open question: Which skin should we use as default? Upstream uses "Default" (a black skin) as default. Debian uses a patch to set the default skin back to "Classic1.3" (a white skin). If the default intrepid theme will be dark, we should use the black "Default" skin. What do you think?

audacious (1.5.1-3ubuntu1) intrepid; urgency=low

  * Merge from Debian unstable (LP: #256574), remaining changes:
    + debian/control: Change maintainer to Ubuntu MOTU.
    + debian/patches/004-change-default-outputplugin.patch: Change the default
      output plugin to pulseaudio.
    + debian/patches/series: Add 004-change-default-outputplugin.patch to list.
  * Dropped Ubuntu changes:
    - *index.html*: Removed (probably a packaging mistake).
    - debian/patches/00list: Removed, because the Debian package use quilt
      (series) instead of dpatch (00list) as patch system.
    - Removed all changes to the translation files, because they only affect
      the file structure and not the content.
    - debian/control: Change the audacious dependencies on libaudid3tag1
      and libaudclient1 to be >= ${source:Upstream-Version}, to fix package
      uninstallability.
  * Add bugzilla-42.patch to resolve a playlist bug where entry->tuple is NULL
    but we try to access it. This results in huge log file (LP: #258797). This
    patch will be in the next upstream release.
  * debian/rules: Do not disable SSE2 on x86_64, because all x86_64 CPUs
    support SSE2.
  * debian/patches/004-change-default-outputplugin.patch: Completely changed.
    Now the patch set pulseaudio as output plugin in the default config
    structure.
  * debian/patches/003-change-default-skin.patch: Corrected path
    (skins -> Skins).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package audacious - 1.5.1-3ubuntu1

---------------
audacious (1.5.1-3ubuntu1) intrepid; urgency=low

  * Merge from Debian unstable (LP: #256574), remaining changes:
    + debian/control: Change maintainer to Ubuntu MOTU.
    + debian/patches/004-change-default-outputplugin.patch: Change the default
      output plugin to pulseaudio.
    + debian/patches/series: Add 004-change-default-outputplugin.patch to list.
  * Dropped Ubuntu changes:
    - *index.html*: Removed (probably a packaging mistake).
    - debian/patches/00list: Removed, because the Debian package use quilt
      (series) instead of dpatch (00list) as patch system.
    - Removed all changes to the translation files, because they only affect
      the file structure and not the content.
    - debian/control: Change the audacious dependencies on libaudid3tag1
      and libaudclient1 to be >= ${source:Upstream-Version}, to fix package
      uninstallability.
  * Add bugzilla-42.patch to resolve a playlist bug where entry->tuple is NULL
    but we try to access it. This results in huge log file (LP: #258797). This
    patch will be in the next upstream release.
  * debian/rules: Do not disable SSE2 on x86_64, because all x86_64 CPUs
    support SSE2.
  * debian/patches/004-change-default-outputplugin.patch: Completely changed.
    Now the patch set pulseaudio as output plugin in the default config
    structure.
  * debian/patches/003-change-default-skin.patch: Corrected path
    (skins -> Skins).

audacious (1.5.1-3) unstable; urgency=medium

  * Change dependency relations to make the package installable.
    (Closes: #491699, #491910).

 -- Benjamin Drung <email address hidden> Fri, 22 Aug 2008 23:56:27 +0200

Changed in audacious:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers