[FFe] Please sync audacious 1.5.0-2 from Debian(Unstable)

Bug #202518 reported by Stefan Ebner
6
Affects Status Importance Assigned to Milestone
audacious (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: audacious

Please grant this FFe for audacious. Great 1.5 release :)
Explanation of the Ubuntu delta and why it can be dropped:
Pulseaudio-by-default is broken so we should sync it

Debian Changelog:

 audacious (1.5.0-2) unstable; urgency=low

   * Configure without SSE2 support (Closes: #471061).

 -- Adam Cécile (Le_Vert) <email address hidden> Wed, 26 Mar 2008 09:45:26 +0100

 audacious (1.5.0-1) unstable; urgency=low

   * New upstream release, highlights include:
     - Provide the correct location for skins and configuration in
       documentation.
       (Closes: #430905)
   * debian/control:
     - Correct Build-Depends so that it won't try to incorrectly build on Etch.
       (Closes: #466518)
     - Bump Depends to force dependency on audacious-plugins 1.5.
   * debian/copyright: major updates

 -- William Pitcock <email address hidden> Thu, 13 Mar 2008 21:19:05 -0500

Upstream Changelog:

Audacious 1.5.0 (2008-03-13)

Enhancements:
* Everything between 1.4.1 and 1.4.7. (duh)
* Ability to disable GTK+ theme suggestions provided by skins.
* Entirely from scratch audio engine (libSAD) which supports:
  - 16-bit audio
  - 24-bit audio
  - 32-bit audio
  - IEEE floating point audio
  - 28-bit fractional audio
  - many weird obscure "audiophile" formats
  and:
  - high quality dithering/conversion/resampling to produce as
    high quality audio as possible for your sound system.
  - bit-exact passthrough of decoded audio (compare to
    "kernel streaming" in foobar2000)
  As a result, support for oldschool 8-bit soundcards has been
  _dropped_. It's 2008, they haven't made such hardware since the
  early 90's.
  Additionally, codecs now send audio to audacious using their
  native format; removing the need for costly implementation-specific
  conversion functionality.
* New unified metadata editing for most formats. Ability to see
  "raw metadata"; the metadata which can be used in tuplez scripts.
* Removal of the XMMS audio conversion engine in it's entirety.
* Support for "virtual plugins"; the ability for a single module to
  export up to thousands of plugins. This will be used more in Audacious2.
* Many adjustments to the winamp2 skinengine.
* Faster jump-to-file.
* Implement support for session management.

Bugfixes:
* playlist_compare_artist(): Avoid NULL dereferences.
  (Bugzilla #172, Bugzilla #168, Bugzilla #35).
* Tons of memory leaks fixed.

Notes from us (the audacious developers):
This is the last branch of Audacious that will support in Winamp2 skins
in core. We are working on a new default UI for Audacious2 which provides
a more metadata rich environment (while still be lightweight and fast).
However, it is planned to implement support for Winamp2 skins as a plugin in
the next version. No promises, though.

It has been fun being seen as "rescuing XMMS" by the community; but this
has never been our goal. Our goal has always been to develop the best
possible player on Linux. This means that we are audiophiles, and we want
our audio to sound as nice as possible. This has been our primary goal;
not maintaining a Winamp2 skinned player. When we determined that the current
UI implementation was getting in our way, we decided to rip it out. As such,
the future of Winamp2 skins in Audacious is undefined, but they will probably
be supported via a plugin.

Revision history for this message
Stefan Ebner (sebner) wrote :
Changed in audacious:
assignee: nobody → hellboy195
status: New → In Progress
Revision history for this message
Stefan Ebner (sebner) wrote :
Revision history for this message
Stefan Ebner (sebner) wrote :

I can't show an install log because therefore I have to merge audacious-plugins by hand (needs audacious-dev 1.5).
If you grant it you'll have a FFe request for audacious plugins in *less than 1 hour* as well :)

Changed in audacious:
assignee: hellboy195 → nobody
status: In Progress → Confirmed
Revision history for this message
StefanPotyra (sistpoty) wrote :

setting back to new (confirmed means green lights from motu-release)

Changed in audacious:
status: Confirmed → New
Revision history for this message
StefanPotyra (sistpoty) wrote :

Hm... some rdepends:
  libaudacious4
  wmauda
  upse-audacious
  ubuntustudio-audio
  tunapie
  pidgin-mpris
  pidgin-audacious
  libaudid3tag1
  audtty
  audacious-plugins-extra
  audacious-plugins
  audacious-dumb
  audacious-crossfade

can you attach a symbol diff of libaudclient1 and libaudid3tag1?
also, I guess I'd like to look over a plain diff of audacious-dev, to roughly see the API changes.

Also I'd like to have an ACK from someone from ubuntustudio, Luke?

Thanks.

Revision history for this message
William Pitcock (nenolod) wrote : Re: [Bug 202518] Re: [FFe] Merge audacious 1.5.0-1 from Debian(Unstable)

Hi,

On Sat, 2008-03-15 at 13:53 +0000, Stefan Ebner wrote:
> I can't show an install log because therefore I have to merge
> audacious-plugins by hand (needs audacious-dev 1.5).
> If you grant it you'll have a FFe request for audacious plugins in
> *less than 1 hour* as well :)

Actually, 1.4 plugins can be loaded in 1.5, just not the other way
around. We can do this because of PAPI.

William

Revision history for this message
William Pitcock (nenolod) wrote :

Hi,

On Sat, 2008-03-15 at 15:15 +0000, StefanPotyra wrote:
> can you attach a symbol diff of libaudclient1 and libaudid3tag1?

There are no API changes.

William

Revision history for this message
StefanPotyra (sistpoty) wrote : Re: [FFe] Merge audacious 1.5.0-1 from Debian(Unstable)

Thanks William (I assume you mean no ABI changes). I guess then I don't necessarily need to take a look at the headers.

Personally, I don't see a problem bringing this in, but I still would like someone from ubuntustudio give an ACK first.

Revision history for this message
Stefan Ebner (sebner) wrote :

Two things.

1) Sure that you can use the Plugins with 1.5 because audacious depends (debian/control) on audacious-plugins (>= 1.5)

2) Stefan, maybe subscribe someone from Ubuntustudio (Luke(?)), or did you talk to him via mail,irc ?

Revision history for this message
StefanPotyra (sistpoty) wrote : Re: [Bug 202518] Re: [FFe] Merge audacious 1.5.0-1 from Debian(Unstable)

Hi,

On Monday 17 March 2008 10:38:11 Stefan Ebner wrote:
[..]
> 2) Stefan, maybe subscribe someone from Ubuntustudio (Luke(?)), or did
> you talk to him via mail,irc ?

already subscribed via motu-release, but feel free to also ping him on irc (or
subscribe s.o. else from ubuntustudio).

Cheers,
     Stefan.

Revision history for this message
William Pitcock (nenolod) wrote : Re: [Bug 202518] Re: [FFe] Merge audacious 1.5.0-1 from Debian(Unstable)

On Mon, 2008-03-17 at 09:38 +0000, Stefan Ebner wrote:
> 1) Sure that you can use the Plugins with 1.5 because audacious
> depends
> (debian/control) on audacious-plugins (>= 1.5)

The audacious package depends on plugins 1.5 to keep the branch of
audacious and plugins in sync. That doesn't change the fact that
audacious is capable of loading in external plugins built against 1.4.

Yes, you need to sync both. This FFE should be about syncing
audacious_1.5.0-1 and audacious-plugins_1.5.0-1 (two packages); not just
audacious itself.

It _should_ go into hardy; but 1.4 is a lot better than 1.3, so at least
users won't be screwed over like they were with gutsy.

William

Revision history for this message
Stefan Ebner (sebner) wrote : Re: [FFe] Merge audacious 1.5.0-1 from Debian(Unstable)

Ah thanks for this.
In fact it's not a sync. But for now it would be easier to sync both and then rebuild to use pulseaudio.
Should I edit this bug to your suggested audacious + audacious-plugin sync?

Stefan

Revision history for this message
William Pitcock (nenolod) wrote : Re: [Bug 202518] Re: [FFe] Merge audacious 1.5.0-1 from Debian(Unstable)

On Mon, 2008-03-17 at 20:01 +0000, Stefan Ebner wrote:
> In fact it's not a sync. But for now it would be easier to sync both
> and then rebuild to use pulseaudio.
> Should I edit this bug to your suggested audacious + audacious-plugin
> sync?

You know what I meant by 'sync'. However, someone said my patch
(1.4.6-2ubuntu1) for pulseaudio-by-default is broken. So perhaps just an
outright sync would be better, as AFAIK there's no other ubuntu-specific
patches.

William

Revision history for this message
Stefan Ebner (sebner) wrote : Re: [FFe] Merge audacious 1.5.0-1 from Debian(Unstable)

True.
Can it be confirmed that it's broken? If so I'll change this merge to a sync

Revision history for this message
Stefan Ebner (sebner) wrote : Re: [FFe] Please sync audacious 1.5.0-1 from Debian(Unstable)

changing to a sync :)

description: updated
Revision history for this message
Stefan Ebner (sebner) wrote :

Audacious-Plugins are located at (LP: #203919)

Install log:

hellboy@ubuntu:~$ sudo apt-get install audacious
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  audacious-plugins libcddb2 libneon27-gnutls
Recommended packages:
  audacious-plugins-extra
The following NEW packages will be installed
  audacious audacious-plugins libcddb2 libneon27-gnutls
0 upgraded, 4 newly installed, 0 to remove and 7 not upgraded.
1 not fully installed or removed.
Need to get 1570kB/1719kB of archives.
After this operation, 5190kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
  audacious-plugins audacious
Install these packages without verification [y/N]? y
Get: 1 http://ppa.launchpad.net hardy/main audacious-plugins 1.5.0-1ubuntu1 [424kB]
Get: 2 http://ppa.launchpad.net hardy/main audacious 1.5.0-1ubuntu1 [1146kB]
Fetched 1570kB in 2s (698kB/s)
Selecting previously deselected package libcddb2.
(Reading database ... 386549 files and directories currently installed.)
Unpacking libcddb2 (from .../libcddb2_1.2.1-1_i386.deb) ...
Selecting previously deselected package libneon27-gnutls.
Unpacking libneon27-gnutls (from .../libneon27-gnutls_0.27.2-1_i386.deb) ...
Selecting previously deselected package audacious-plugins.
Unpacking audacious-plugins (from .../audacious-plugins_1.5.0-1ubuntu1_i386.deb) ...
Selecting previously deselected package audacious.
Unpacking audacious (from .../audacious_1.5.0-1ubuntu1_i386.deb) ...

Setting up libcddb2 (1.2.1-1) ...

Setting up libneon27-gnutls (0.27.2-1) ...

Setting up audacious-plugins (1.5.0-1ubuntu1) ...
Setting up audacious (1.5.0-1ubuntu1) ...

Revision history for this message
C.Kontros (coryisatm) wrote :

Sure. Ubuntu Studio can give this a +1.

Revision history for this message
StefanPotyra (sistpoty) wrote :

ACK #1 from me then.

Revision history for this message
Scott Kitterman (kitterman) wrote :

N'ack from me for the moment.

[09:20] <ScottK> sebner: "Pulseaudio-by-default is broken so we should sync it" isn't really a good reason.
[09:21] <ScottK> sebner: I think you need to go look at the impact of dropping the Ubuntu changes and explain it better. I'd also like to see a description of the testing you've done.
[09:23] <ScottK> sebner: From reading the bug, all I know is "Someone said pulse-audio-by-default is broken."

Revision history for this message
Stefan Ebner (sebner) wrote :

Sorry for the bad documenting.

As you can see above I installed audacious without problems.
Looking into the Audio Preferences showed me that audacious doesn't select pulse-audio by default but alsa.
Furthermore I tried to reinstall audacious but with the same result. So I have to draw the conclusion that it's really broken.
Because of that I changed the merge to a sync. In addition I can say that audacious 1.5 is working without problems here.

Revision history for this message
Scott Kitterman (kitterman) wrote :

Ack from me. Approved by motu-release.

Changed in audacious:
importance: Undecided → Wishlist
status: New → Confirmed
Revision history for this message
Christian Becker (c-becker-88) wrote :

Would be nice to see 1.5, because after I added my Music Libary (around 80.000 Files) Version 1.4.3 is a bit laggy... hope its fixed in 1.5.0...

Revision history for this message
StefanPotyra (sistpoty) wrote :

sponsors ack for audacious, please subscribe ubuntu-archive, thanks.

Revision history for this message
Stefan Ebner (sebner) wrote :

Waiting for audacious 1.5.0-2 :)

Changed in audacious:
status: Confirmed → Invalid
Revision history for this message
Stefan Ebner (sebner) wrote :

Edited bug report. Now we are syncing audacious 1.5.0-2 :)

description: updated
Changed in audacious:
status: Invalid → Confirmed
Revision history for this message
Martin Pitt (pitti) wrote :

Getting binaries for hardy...
[Updating] audacious (1.4.6-2ubuntu1 [Ubuntu] < 1.5.0-2 [Debian])
 * Trying to add audacious...
  - <audacious_1.5.0-2.diff.gz: downloading from http://ftp.debian.org/debian/>
  - <audacious_1.5.0.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
  - <audacious_1.5.0-2.dsc: downloading from http://ftp.debian.org/debian/>
I: audacious [universe] -> audacious_1.4.6-2ubuntu1 [universe].
I: audacious [universe] -> libaudid3tag1_1.4.6-2ubuntu1 [universe].
I: audacious [universe] -> libaudclient1_1.4.6-2ubuntu1 [universe].
I: audacious [universe] -> audacious-dev_1.4.6-2ubuntu1 [universe].

Changed in audacious:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers