Can't install audacious in Xenial depends not the right version

Bug #1676092 reported by Mélodie
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
audacious (Ubuntu)
Undecided
Unassigned
gtk+2.0 (Ubuntu)
Undecided
Unassigned

Bug Description

When trying to install Audacious I need to install it's dependancy gtk2-engines-pixbuf which can't be installed, because it needs "libgtk2.0-0 (= 2.24.30-1ubuntu1)" but " 2.24.30-1ubuntu1.16.04.1" is installed. (is it the same version with a different name? )

Therefore, no Audacious… :-/

Revision history for this message
Hans Joachim Desserud (hjd) wrote :

Thanks for taking your time to report this issue and help making Ubuntu better.

I don't get an error message like this when attempting to install audacious on Ubuntu 16.04.

>(is it the same version with a different name? )

It's two different versions. Though from what I can see (https://launchpad.net/ubuntu/+source/gtk+2.0), is version "2.24.30-1ubuntu1.16.04.1" so far only available in the -proposed archive. In other words, it hasn't gone through all the steps to be pushed out as an official update. Have you installed packages from -proposed? If that is the case, there might be additional rebuilds of libraries like gtk2-engines-pixbuf needed before it can be released. I've taken the liberty of marking gtk2.0 as also affected just in case.

Could you please add the whole error message you got when attempting to install adacious?

tags: added: xenial
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in audacious (Ubuntu):
status: New → Confirmed
Changed in gtk+2.0 (Ubuntu):
status: New → Confirmed
Revision history for this message
^rooker (rooker) wrote :

I just ran into the exact same error message trying to install "gresolver":

"libgail18 : Depends: libgtk2.0-0 (= 2.24.30-1ubuntu1) but 2.24.30-1ubuntu1.16.04.1 is to be installed"

When I enable "xenial-updates main" the dependency error disappears and I can install the required libgtk packages.

My distro is Xubuntu 16.04.3.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers