Firefox "Open Containing Folder" opens Audacious instead of File Manager

Bug #1196339 reported by David Bolton on 2013-06-30
84
This bug affects 17 people
Affects Status Importance Assigned to Milestone
audacious (Ubuntu)
Undecided
Unassigned
desktop-file-utils (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:

1. Open Firefox web browser
2. Click on Downloads arrow (to right of search box by default)
3. Click on Show All Downloads
4. Click on the "Open Containing Folder" icon next to a file you have already downloaded

Actual behavior: The containing folder doesn't open. Instead Audacious opens.

Expected behavior: The containing folder should open in the File Manager.

This bug is present in a clean install of Ubuntu Studio 13.04

Len Ovens (len-ovenwerks) wrote :

/usr/share/applications/audacious.desktop in the MimeType= line includes inode/directory. While Audacious may be able to deal with "opening" directories, it is questionable that the user would ever expect Audacious to do so in a context situation like this. On the other hand Firefox could use default file manager rather than mime type.

affects: ubuntustudio → audacious (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in audacious (Ubuntu):
status: New → Confirmed
Maxime Bochon (maxime-bochon) wrote :

I used 'strace' on Firefox to trace 'read' and 'open' system calls during the downloaded file's directory opening step. Actually, Firefox tries a lot of paths to find how to open the directory, and eventually reaches 'audacious.desktop'. Here are these files:

/home/maxime/.local/share/applications/nautilus.desktop
/usr/share/ubuntustudio/applications/nautilus.desktop
/usr/local/share/applications/nautilus.desktop
/usr/share/applications/nautilus.desktop
/usr/share/applications/nautilus.desktop
/home/maxime/.local/share/applications/nautilus.desktop
/usr/share/ubuntustudio/applications/nautilus.desktop
/usr/local/share/applications/nautilus.desktop
/usr/share/applications/nautilus.desktop
/usr/share/applications/nautilus.desktop
/home/maxime/.local/share/applications/nautilus-folder-handler.desktop
/home/maxime/.local/share/applications/nautilus/folder-handler.desktop
/home/maxime/.local/share/applications/nautilus-folder/handler.desktop
/usr/share/ubuntustudio/applications/nautilus-folder-handler.desktop
/usr/share/ubuntustudio/applications/nautilus/folder-handler.desktop
/usr/share/ubuntustudio/applications/nautilus-folder/handler.desktop
/usr/local/share/applications/nautilus-folder-handler.desktop
/usr/local/share/applications/nautilus/folder-handler.desktop
/usr/local/share/applications/nautilus-folder/handler.desktop
/usr/share/applications/nautilus-folder-handler.desktop
/usr/share/applications/nautilus/folder-handler.desktop
/usr/share/applications/nautilus-folder/handler.desktop
/usr/share/applications/nautilus-folder-handler.desktop
/usr/share/applications/nautilus/folder-handler.desktop
/usr/share/applications/nautilus-folder/handler.desktop
/home/maxime/.local/share/applications/audacious.desktop
/usr/share/ubuntustudio/applications/audacious.desktop
/usr/local/share/applications/audacious.desktop

It comes out that Firefox looks at several variants of GNOME Nautilus's desktop file, instead of asking to the OS which program to use to open a directory (maybe this mechanism does not actually exist). So this is more a Firefox's bug than an Audacious's one.

My OS is Ubuntu Studio 13.10, which uses Xfce. GNOME Nautilus is not installed by default. It is Thunar that is used instead to browse file systems. So as a temporary workaround, I did this:
mkdir -p ~/.local/share/applications
ln -s /usr/share/applications/Thunar-folder-handler.desktop ~/.local/share/applications/nautilus-folder-handler.desktop

Maxime Bochon (maxime-bochon) wrote :

I'm not familiar enough with LaunchPad to do this, but this bug should be linked with the following pages:
 - Ubuntu Studio: https://bugs.launchpad.net/ubuntustudio
 - Xubuntu (probably): https://launchpad.net/xubuntu-desktop
 - Equivalent Firefox's bug on Bugzilla : https://bugzilla.mozilla.org/show_bug.cgi?id=893799

linuxball (linuxball) wrote :

This bug shows up in Ubuntu Studio 14.04 amd64 (final release), too.

tags: added: trusty
linuxball (linuxball) wrote :

Addition:

I already have the new firefox 29.0 (Build identifier: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0) installed. I also used strace to find out wich locations firefox 29.0 is searching for the folder handler (I only listed those files existing on my system in firefox's search order):

/home/wreimer/.local/share/applications/mimeapps.list
/usr/share/ubuntustudio/applications/defaults.list
/usr/share/xfce4/applications/defaults.list
/usr/share/applications/mimeinfo.cache
/usr/share/applications/defaults.list
/home/wreimer/.local/share//mime/mime.cache
/usr/share//mime/mime.cache

Applying "grep inode/directory" to these files yields:

/usr/share/ubuntustudio/applications/defaults.list:inode/directory=nautilus.desktop
/usr/share/applications/mimeinfo.cache:inode/directory=audacious.desktop;Thunar-folder-handler.desktop;
/usr/share/applications/defaults.list:inode/directory=nautilus-folder-handler.desktop
Binary file /usr/share//mime/mime.cache matches

So the files /usr/share/ubuntustudio/applications/defaults.list (from package ubuntustudio-default-settings) and /usr/share/applications/defaults.list (from package desktop-file-utils) specify Nautilus as default folder handler. However, in Ubuntu Studio Nautilus is not installed by default so firefox uses the first entry in /usr/share/applications/mimeinfo.cache which is Audacious.

The attached patch will resolve this issue on Ubuntu Studio 14.04 (trusty) globally (for all users). IMHO the bug is NOT in audacious or firefox. In my case the bug is in the package ubuntustudio-default-settings (the patch can be used to fix the package).

The attachment "Make Thunar the default folder handler for Ubuntu Studio" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
frakc (frakc) wrote :

This bug allso present in Deluge, Transmission, Chrome, Opera. I think its fair to say it present in every application, which has "open in folder" option

Olof Bjarnason (objarni) wrote :

Also present in Sublime Text (Browse Packages is an "open folder" command).

Olof Bjarnason (objarni) wrote :

The "workaround" for me was to remove the audacious package, which I didn't use anyway:

    sudo apt-get remove audacious

Set Hallstrom (sakrecoer) wrote :

I've had this bug since 13.04. After upgrading to 14.04, and still having it, i made a clean install of 14.04 and it was gone.
I looked at th patch in #7, and while my fresh install isn't having this problem, i noticed that my

/usr/share/ubuntustudio/applications/defaults.list has
indoe/directory=nautlius-folder-handler.desktop

/usr/share/applications/defaults.list has
inode/directory=nautilius.desktop

What i am trying to say is, my fresh install is now working, but in my case it doesn't seem to have much to do with /usr/share/ubuntustudio/applications/defaults.list nor /usr/share/applications/defaults.list

Nautilius is not installed on this machine.

PoxyPig (poxypig) wrote :

I have this issue and am using Lubuntu Trusty with the default file manager PCManFM.
If "Open Containing Folder" or "Show in File Manager" is clicked in any application with those options, I find Audacious opens rather than the file manager.
After Audacious is uninstalled, I find that Google Chrome opens instead. The issue is therefore not one with Audacious. It would appear to be a problem with the opening of folders. I suspect that the first application capable of that feat is being used rather than the file manager.

PoxyPig (poxypig) wrote :

After reading again Set Hallstrom's post I looked at my

      /usr/share/applications/defaults.list and found it had
      inode/directory=nautilus-folder-handler.desktop

As I do not have Nautilus on my system I changed the inode/directory entry to point to PCManFM but that change had no effect.
I then investigated the default applications using lxsession-default-apps and found the default file manager unset so set it to PCManFM. That appears to have resolved my issue, now when I click "Show in File Manager" the folder opens in PCManFM.
So perhaps the cause of this problem is the uninstallation of Nautilus which leaves the system with no default file manager set.

zen0ne (j-patriarche) wrote :

I was able to solve this bug rather quickly on my system (ubuntu mate 14.10) by following suggested in this forum: https://bbs.archlinux.org/viewtopic.php?id=126302

I installed the package " libfile-mimeinfo-perl " and Chrome and firefox now open downloaded files correctly.

rmoorman (rico-moorman) wrote :

I am running into the same issues using kubuntu 15.04 right now. The problem there is that FF opens gwenview instead of dolphin.

It seems (as also already pointed out on the mozilla bug tracker) that the /usr/local/applications/mimeinfo.cache contains the wrong preference for inode/directory

$ cat /usr/share/applications/mimeinfo.cache | grep directory
inode/directory=gwenview.desktop;kde4-dolphin.desktop;

If I switch the order of gwenview.desktop and kde4-dolphin.desktop within the cache file, FF immediately does not open the wrong application any more.
But when I run the mimecache update script like this:

sudo update-desktop-database /usr/share/applications/

the wrong order gets written again and FF shows the same behaviour as before.

The strange thing is that the Preference seems to be alright...

$ cd /usr/share/applications/
$ grep InitialPreference -A 2 kde4/dolphin.desktop gwenview.desktop
kde4/dolphin.desktop:InitialPreference=10
--
gwenview.desktop:# InitialPreference should be greater than Okular so that Gwenview is the
gwenview.desktop-# primary application associated with images, but less than Konqueror or Dolphin
gwenview.desktop-# so that Gwenview is not the primary applications for folders.
gwenview.desktop:InitialPreference=8

So even though a higher preference is given to dolphin, gwenview is what ends up first in the list.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in desktop-file-utils (Ubuntu):
status: New → Confirmed

It is affecting me too.. It is very awkward feeling when a folder opens up in Audacious.

LucMorizur (lucmorizur) wrote :

Hi;

I'm bored also with this bug. The workaround proposed by rmoorman in #16 works, but indeed is reset when running update-desktop-database -- which I never used before as a matter of facts and without any obvious trouble; I don't know if it is something ran automatically sometimes?

Thus I created an alias mainly to remember how to correct this if it comes back. But of course a real fix would be better.

Thanks!

--
Luc

Pignanelli (johnpinion) wrote :

Simply install Nautilus (file manager).

I had this bug with the "open containing folder" contextual menu in Transmission, and this is what fixed it for me. Good luck!

Very anoying. Same thing in Lubuntu / Xubuntu 16.04, qbittorrent and pcmanfm.
Whenever I reinstall audacious the problema comes up. I have all kinds of browsers and file manager installed, except nautilus. Does audacious need to register itself like that?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.