[FFe] Please merge audacious-plugins 1.5.0-1 from Debian(Unstable)

Bug #203919 reported by Stefan Ebner
4
Affects Status Importance Assigned to Milestone
audacious-plugins (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: audacious-plugins

Refering to the audacious FFe sync (LP: #202518) here are the plugins :)
Please grant this FFe. Great 1.5 release :)

Explanation of the Ubuntu delta and why it can be dropped:
Pulseaudio-by-default is broken so we should sync it.

Debian Changelog:

 audacious-plugins (1.5.0-1) unstable; urgency=low

   * New upstream release. Highlights include:
     - Usage of libsndfile for WAV playback. (Closes: #452563)
     - Fixed FTBFS with gcc 4.3. (Closes: #455291)
     - More tolerant FLAC plugin. (Closes: #437362)
     - Improved support for pulse audio. (Closes: #459211)
     - Corrected discid calculation with cdaudio-ng. (Closes: #464612)
     - New from-scratch Monkey's Audio codec. (Closes: #463247)
     - Rewritten scrobbler plugin. (Closes: #444095)
   * debian/audacious-plugins.install: Add demac.so to the target list.

 -- William Pitcock <email address hidden> Thu, 13 Mar 2008 21:42:39 -0500

Stefan Ebner (sebner)
Changed in audacious-plugins:
assignee: nobody → sebner
status: New → In Progress
Revision history for this message
Stefan Ebner (sebner) wrote :
Revision history for this message
Stefan Ebner (sebner) wrote :
Revision history for this message
Stefan Ebner (sebner) wrote :

hellboy@ubuntu:~$ sudo apt-get install audacious
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  audacious-plugins libcddb2 libneon27-gnutls
Recommended packages:
  audacious-plugins-extra
The following NEW packages will be installed
  audacious audacious-plugins libcddb2 libneon27-gnutls
0 upgraded, 4 newly installed, 0 to remove and 7 not upgraded.
1 not fully installed or removed.
Need to get 1570kB/1719kB of archives.
After this operation, 5190kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
  audacious-plugins audacious
Install these packages without verification [y/N]? y
Get: 1 http://ppa.launchpad.net hardy/main audacious-plugins 1.5.0-1ubuntu1 [424kB]
Get: 2 http://ppa.launchpad.net hardy/main audacious 1.5.0-1ubuntu1 [1146kB]
Fetched 1570kB in 2s (698kB/s)
Selecting previously deselected package libcddb2.
(Reading database ... 386549 files and directories currently installed.)
Unpacking libcddb2 (from .../libcddb2_1.2.1-1_i386.deb) ...
Selecting previously deselected package libneon27-gnutls.
Unpacking libneon27-gnutls (from .../libneon27-gnutls_0.27.2-1_i386.deb) ...
Selecting previously deselected package audacious-plugins.
Unpacking audacious-plugins (from .../audacious-plugins_1.5.0-1ubuntu1_i386.deb) ...
Selecting previously deselected package audacious.
Unpacking audacious (from .../audacious_1.5.0-1ubuntu1_i386.deb) ...

Setting up libcddb2 (1.2.1-1) ...

Setting up libneon27-gnutls (0.27.2-1) ...

Setting up audacious-plugins (1.5.0-1ubuntu1) ...
Setting up audacious (1.5.0-1ubuntu1) ...

Changed in audacious-plugins:
assignee: sebner → nobody
status: In Progress → New
Changed in audacious-plugins:
importance: Undecided → Wishlist
status: New → Confirmed
Revision history for this message
Stefan Ebner (sebner) wrote :

Setting back to "New".
Only the Motu-release team is allowed to set it to "Confirmed" what means green lights for the sync.

Changed in audacious-plugins:
status: Confirmed → New
Revision history for this message
StefanPotyra (sistpoty) wrote :

Seems good to me, however I'd also like to get an ACK from ubuntu-studio.

Revision history for this message
C.Kontros (coryisatm) wrote :

Sure. Ubuntu Studio can give this a +1.

Revision history for this message
StefanPotyra (sistpoty) wrote :

ACK #1 from me then.

Revision history for this message
Stefan Ebner (sebner) wrote :

Sorry for the bad documenting.

As you can see above I installed audacious and audacious-plugins without problems.
Looking into the Audio Preferences showed me that audacious doesn't select pulse-audio by default but alsa.
Furthermore I tried to reinstall audacious but with the same result. So I have to draw the conclusion that it's really broken.
Because of that I changed the merge to a sync. In addition I can say that audacious 1.5 is working without problems here.
I also tried to play music files with various file formats and evertime is working fine so I'm sure that the audacious-plugins are worked well.

Revision history for this message
Scott Kitterman (kitterman) wrote :

Ack from me then. Approved by motu-release.

Changed in audacious-plugins:
status: New → Confirmed
Revision history for this message
StefanPotyra (sistpoty) wrote :

sponsors comment: the delta is s.th. different than described here, please reevaluate if it can be dropped (especially the conflicts entries).

Revision history for this message
Stefan Ebner (sebner) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package audacious-plugins - 1.5.0-1ubuntu1

---------------
audacious-plugins (1.5.0-1ubuntu1) hardy; urgency=low

  * Merge from Debian unstable. (LP: #203919) Remaining Ubuntu changes:
  + debian/control:
    - Add versioned conflicts/replaces against audacious-plugins-extra to
      audacious-plugins, since the libpulse output plugin used to live in
      audacious-plugins-extra
    - Suggests timidiy since midi files won't be played without it
    - Modify Maintainer value to match Debian-Maintainer-Field Spec
    - PulseAudio plugin movement from extra package to main
      because of the switchover to PulseAudio in hardy

audacious-plugins (1.5.0-1) unstable; urgency=low

  * New upstream release. Highlights include:
    - Usage of libsndfile for WAV playback. (Closes: #452563)
    - Fixed FTBFS with gcc 4.3. (Closes: #455291)
    - More tolerant FLAC plugin. (Closes: #437362)
    - Improved support for pulse audio. (Closes: #459211)
    - Corrected discid calculation with cdaudio-ng. (Closes: #464612)
    - New from-scratch Monkey's Audio codec. (Closes: #463247)
    - Rewritten scrobbler plugin. (Closes: #444095)
  * debian/audacious-plugins.install: Add demac.so to the target list.

 -- Stefan Ebner <email address hidden> Mon, 24 Mar 2008 16:31:50 +0100

Changed in audacious-plugins:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers