Ubuntu

ffaudio plugin is not being built

Reported by Doug McMahon on 2012-11-17
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
audacious-plugins (Ubuntu)
Medium
Unassigned

Bug Description

The latest audacious-plugins build does not include the ffaudio plugin
from build log
"checking for FFMPEG... no"
.........
"Input Plugins
  -------------
  MPEG-1 Layer I/II/III (mpg123): yes
  MPEG-2/4 AAC (aac): yes
  FFaudio (ffaudio): no"

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: audacious-plugins 3.3.1-1
ProcVersionSignature: Ubuntu 3.7.0-0.5-generic 3.7.0-rc4
Uname: Linux 3.7.0-0-generic x86_64
ApportVersion: 2.6.2-0ubuntu3
Architecture: amd64
Date: Sat Nov 17 07:56:14 2012
InstallationDate: Installed on 2012-10-23 (24 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: audacious-plugins
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) wrote :

A quick ck. & it doesn't seem to have any issue with the current libavcodec >= 53.35.0 in use so if libav isn't going to libavcodec >= 53.40.0 then patching configure.ac should be considered
(additionally the build-dep on jack should be on libjack-jackd2-dev not libjack-dev

Doug McMahon (mc3man) wrote :

If there isn't going to be a new libav build till plain 9 then it would seem reasonable to do another audacious-plugins build ((3.3.3-2
& adjust the configure.ac
Better than a repeat of 11.10...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in audacious-plugins (Ubuntu):
status: New → Confirmed
Doug McMahon (mc3man) wrote :

In lieu of a move in 13.04 to libav9 attached diff

The attachment "audacious-plugins_3.3.4-1ubuntu1.debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in audacious-plugins (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Benjamin Drung (bdrung) wrote :

Thanks for your patch. I have adjusted it slightly:
* Change target series from UNRELEASED to raring
* Close this bug by adding " (LP: #1080059)" to your changelog entry
* Fill out template patch header (see DEP-3 for details)

Changed in audacious-plugins (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package audacious-plugins - 3.3.4-1ubuntu1

---------------
audacious-plugins (3.3.4-1ubuntu1) raring; urgency=low

  * Adjust configure.ac to build ffaudio.so (LP: #1080059)
 -- Doug McMahon <email address hidden> Wed, 20 Mar 2013 19:16:14 +0100

Changed in audacious-plugins (Ubuntu):
status: Fix Committed → Fix Released
Alessio Treglia (quadrispro) wrote :

This bug has been fixed in Debian too:

audacious-plugins (3.4-2) unstable; urgency=low

  * Add patch taken from Ubuntu to build ffaudio plugin. (LP: #1080059)
  * Enable autoreconf.

 -- Alessio Treglia <email address hidden> Fri, 16 Aug 2013 11:02:35 +0100

Cheers.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers