Please merge atlas 3.8.3-22 (universe) from Debian unstable (main)

Bug #586760 reported by Felix Geyer on 2010-05-28
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
atlas (Ubuntu)
Undecided
Unassigned

Bug Description

Please merge atlas 3.8.3-22 (universe) from Debian unstable (main).

Changelog entries since current maverick version 3.6.0-24ubuntu1:

atlas (3.8.3-22) unstable; urgency=low

  * sse3 & core2sse3 packages removed for hurd
  * Fix a build issue under mips & mipsel (patch 21_mips2.diff)
  * Fix a custom build issue. Thanks to Adrian Benson for the patch
    (Closes: #576987, #579990)

 -- Sylvestre Ledru <email address hidden> Tue, 11 May 2010 11:39:10 +0200

atlas (3.8.3-21) unstable; urgency=low

  * Maintainer changed to the Debian Science Team
  * Simplification of the s390 detection
  * armel detection added (Closes: #243447, #355355)
  * Revert the sse and sse2 for ia64 (introduced in 3.8.3-18) since these
    extensions do not exist on this CPU.

 -- Sylvestre Ledru <email address hidden> Thu, 29 Apr 2010 18:03:14 +0200

atlas (3.8.3-20) unstable; urgency=low

  * Fix a problem on the custom build (Closes: #576755)
  * Some patches renamed to make sure of their order
  * Fix a FTBFS under mips, hppa & alpha (Closes: #576891)
  * Add conflicts on libblas{-dev} (<1.2-5) and liblapack{-dev} (<3.2.1-4)
    to make sure that the update-alternatives mecanism can be used
    (Closes: #576855)
  * Fix a priority with 2.0 packages

 -- Sylvestre Ledru <email address hidden> Thu, 08 Apr 2010 17:51:05 +0200

atlas (3.8.3-19) unstable; urgency=low

  * Upload to unstable (Closes: #536686, #561299, #521056, #569397, #571108
    #344091, #450692, #517826, #571108, #504586, #552464, #524459)
    (LP: #458202, #376739, #406520, #505339, #523365, #363510)

 -- Sylvestre Ledru <email address hidden> Sun, 28 Mar 2010 01:05:53 +0100

atlas (3.8.3-18) experimental; urgency=low

  * Youpi, it is working!
  * Fix a build error with ia64. It also deserves sse & sse2 packages.
    Could not find if sse3 is well supported for such arch.
  * NEWS.Debian added
  * README.Debian added with "how to switch between blas/lapack
    implementation"
  * Probably the last upload in experimental before unstable.

 -- Sylvestre Ledru <email address hidden> Thu, 25 Mar 2010 23:39:26 +0100

atlas (3.8.3-17) experimental; urgency=low

  * Was it failing because I removed this stupid target ?!

 -- Sylvestre Ledru <email address hidden> Wed, 24 Mar 2010 08:44:01 +0100

atlas (3.8.3-16) experimental; urgency=low

  * Put back randomCrashOnBuild.diff. It was not the reason
  * Disable modification introduced in 3.8.3-14 about DEB_SHLIBDEPS_INCLUDE
    and put back LD_LIBRARY_PATH=$(CURDIR)/debian/tmp/usr/lib/atlas-base/
    (Closes: #574999)

 -- Sylvestre Ledru <email address hidden> Tue, 23 Mar 2010 15:11:12 +0100

atlas (3.8.3-15) experimental; urgency=low

  * randomCrashOnBuild.diff was crashing many builds

 -- Sylvestre Ledru <email address hidden> Mon, 22 Mar 2010 16:18:59 +0000

atlas (3.8.3-14) experimental; urgency=low

  * Might fix the random compilation bug. Thanks to R. Clint Whaley (upstream)
    for the fix (randomCrashOnBuild.diff)
  * Fix a useless dep on libatlas3gf-base from all optimized packages
    (not necessary)
  * Explicit link against -lpthread added

 -- Sylvestre Ledru <email address hidden> Sat, 20 Mar 2010 10:16:38 +0100

atlas (3.8.3-13) experimental; urgency=low

  * Support of hurd (hurd.diff)

 -- Sylvestre Ledru <email address hidden> Wed, 10 Mar 2010 13:16:42 +0100

atlas (3.8.3-12) experimental; urgency=low

  * Don't make the assumption that /proc/cpuinfo is available everywhere.
    Should fix the build issue on hurd-i386

 -- Sylvestre Ledru <email address hidden> Sun, 07 Mar 2010 12:14:38 +0100

atlas (3.8.3-11) experimental; urgency=low

  * Explicit link against lgfortran & libgcc_s
  * Old useless / non sense conflicts removed

 -- Sylvestre Ledru <email address hidden> Sat, 06 Mar 2010 00:29:33 +0100

atlas (3.8.3-10) experimental; urgency=low

  * postinst & prerm added for each packages to manage update-alternatives
    See: http://wiki.debian.org/DebianScience/LinearAlgebraLibraries
  * Now, custom built version of Atlas has now incrementing version number
    Thanks to Adrian Benson for the idea and the implementation
  * Check that CPU frequencies are correctly set. Thanks to Adrian Benson.
    (Closes: #571322)
  * Some old Conflicts: removed
  * Vcs-Browser & Vcs-Svn updated (packaged moved to Debian Science)
  * Maintainer updated
  * Standards-Version updated to version 3.8.4

 -- Sylvestre Ledru <email address hidden> Tue, 02 Mar 2010 19:48:55 +0100

atlas (3.8.3-9) experimental; urgency=low

  * Fixes kfreebsd* build error (melf.diff added)
  * Standards-Version updated to version 3.8.4
  * -lc added back. The problem was due to -melf_i386 which was failing
    under kfreebsd. (10_remove-lc.diff removed)

 -- Sylvestre Ledru <email address hidden> Sun, 14 Feb 2010 12:07:56 +0100

atlas (3.8.3-8) experimental; urgency=low

  * README.Debian updated with the information relative to ld.so.conf.d/
  * if Make.inc cannot be found after the configure, fail debian/rules
  * Port on s390
  * Patch check-exists.diff added to avoid error when rebuilding
  * Do not perform the check of CPU extensions under kfreebsd-i386
    (Closes: #565852)
  * -lc removed from build process which was failing under kfreebsd-amd64
    (Closes: #566942)

 -- Sylvestre Ledru <email address hidden> Wed, 10 Feb 2010 16:39:09 +0100

atlas (3.8.3-7) experimental; urgency=low

  * Bad dependencies libatlas3gf-{sse,sse2,sse3,core2sse3} depend on
    libatlas3gf-base. (Closes: #551689)

 -- Sylvestre Ledru <email address hidden> Thu, 26 Nov 2009 12:02:23 +0100

atlas (3.8.3-6) experimental; urgency=low

  * Fix a bad typo in the libatlas3-amd64sse3-dev package.
    Thanks to Ryo IGARASHI for spotting it (Closes: #555301)
  * libatlas3gf-core2sse3 package declaration was missing in debian/control
    Thanks to Ryo IGARASHI for spotting it (Closes: #551689)
  * Ondrej has been removed from uploaders (since 3.8.3-1) (Closes: #550412)

 -- Sylvestre Ledru <email address hidden> Mon, 09 Nov 2009 11:37:09 +0100

atlas (3.8.3-5) experimental; urgency=low

  * Add (= ${binary:Version}) on -dev packages
    (Lintian: weak-library-dev-dependency)

 -- Sylvestre Ledru <email address hidden> Mon, 26 Oct 2009 06:52:05 +0100

atlas (3.8.3-4) experimental; urgency=low

  * Fix some descriptions issues
  * libatlas3gf-amd64sse3-dev and libatlas-corei7sse3-dev erroneously depend
    on libatlas-core2sse3. Thanks to Adrian Benson to point out this silly
    issue (Closes: #551689)

 -- Sylvestre Ledru <email address hidden> Sat, 24 Oct 2009 22:44:30 +0200

atlas (3.8.3-3) experimental; urgency=low

  * Missing dependency against ghostscript (Closes: #548646)
  * cblas.h & catlas.h are now installed into /usr/include/atlas
    (Closes: #432860, #481217, #548539)

 -- Sylvestre Ledru <email address hidden> Sun, 27 Sep 2009 23:51:49 +0200

atlas (3.8.3-2) experimental; urgency=low

  * Improve CPU extension check

 -- Sylvestre Ledru <email address hidden> Sat, 26 Sep 2009 02:39:07 +0200

atlas (3.8.3-1) experimental; urgency=low

  * New upstream version (Closes: #382880)
  * debian/rules rewritten from scratch
  * Provides more documentation in the libatlas-doc packages
  * debian/copyright updated
  * Add myself to the uploader
  * Vcs-Browser & Vcs-Svn added
  * packages libatlas-3dnow-dev & libatlas3gf-3dnow obsoletes
  * packages libatlas-sse3-dev and libatlas3-sse3 added
  * libatlas-headers renamed to libatlas-dev
  * libatlas-dev is now in section libdevel
  * fakeroot debian/rules custom will generated a package called
    ../libatlas3gf-base_*.deb which will contain an optimized version of
    Atlas just for the current arch.
  * README.Debian updated to reflect the different changes
  * README.source added to explain where sources of the PDF are
  * Standards-Version updated to 3.8.3
  * compat updated to version 7
  * Camm & Ondrej removed as uploaders
  * Use of David Cournapeau's patches (many thanks for this great work)
  * Change of my email address since I am now DD

 -- Sylvestre Ledru <email address hidden> Thu, 17 Sep 2009 23:31:54 +0200

Related branches

Felix Geyer (debfx) wrote :

atlas (3.8.3-22ubuntu1) maverick; urgency=low

  * Merge from Debian unstable, remaining changes:
    - Explicitely fail the build on armel; the build doesn't terminate
      on the buildds and keeps the buildd busy until an admin does kill
      the build manually.
  * Drop all other changes as they are not needed anymore. The package builds
    fine without them and uses the default compilers.

 -- Felix Geyer <email address hidden> Fri, 28 May 2010 12:27:19 +0200

Felix Geyer (debfx) wrote :
Changed in atlas (Ubuntu):
assignee: nobody → Fabrice Coutadeur (fabricesp)
status: New → In Progress
Fabrice Coutadeur (fabricesp) wrote :

Uploaded. Thanks for your work !
I'll check if it still needs to fail on armel for Ubuntu, and may reupload a new version.

Thanks anyway,

Fabrice

Changed in atlas (Ubuntu):
assignee: Fabrice Coutadeur (fabricesp) → nobody
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package atlas - 3.8.3-22ubuntu1

---------------
atlas (3.8.3-22ubuntu1) maverick; urgency=low

  * Merge from Debian unstable (LP: #586760), remaining changes:
    - Explicitely fail the build on armel; the build doesn't terminate
      on the buildds and keeps the buildd busy until an admin does kill
      the build manually.
  * Drop all other changes as they are not needed anymore. The package builds
    fine without them and uses the default compilers.
 -- Felix Geyer <email address hidden> Fri, 28 May 2010 12:27:19 +0200

Changed in atlas (Ubuntu):
status: Fix Committed → Fix Released
Sylvestre Ledru (sylvestre) wrote :

Which changes are you referring to here ?
" * Drop all other changes as they are not needed anymore. The package builds
    fine without them and uses the default compilers."

And armel builds are successful under Debian. Do you have the logs available ?
thanks

Fabrice Coutadeur (fabricesp) wrote :

Hi,

Ubuntu had specific changes to use gcc instead of gcc-4.3 in several files that are not required anymore as the package now uses gcc (and f77 also).

About armel, I had a small conversation in irc about that:
"<tumbleweed> fabrice_sp: ran atlas on armel all night. It still loops"
The problem is that the build loops in ubuntu armel buildds.

Stefano will check later on if he can see something in the compilation options that explains the loop.

Fabrice

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers