libatlas3gf-base should be build with sse2 support on amd64

Bug #333964 reported by Gert Wollny on 2009-02-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
atlas (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libatlas-base-dev

Currently, the on AMD64 the ATLAS generic build forces -fpmath=387, even though all processors that belong to this architecture support at least SSE2. This makes execution very slow, worse then using the standard implementation of blas from the package libblas, which is compiled using standard C flags that enable sse2 by default on AMD64.

ProblemType: Bug
Architecture: amd64
Dependencies:
 libgcc1 1:4.3.2-1ubuntu12
 gcc-4.3-base 4.3.2-1ubuntu12
 libgfortran3 4.3.2-1ubuntu12
 findutils 4.4.0-2ubuntu3
 libc6 2.8~20080505-0ubuntu9
DistroRelease: Ubuntu 8.10
NonfreeKernelModules: nvidia
Package: libatlas3gf-base 3.6.0-22ubuntu1
ProcEnviron:
 PATH=/usr/lib/icecc/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin:/home/wollny/testbed/bin
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: atlas
Uname: Linux 2.6.27-11-server x86_64

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers