package libatlas3-base (not installed) failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

Bug #1095380 reported by John Joergensen on 2013-01-02
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
atlas (Ubuntu)
Undecided
Unassigned

Bug Description

Gimp no work in Quantal. libatlas failures.

ProblemType: Package
DistroRelease: Ubuntu 12.10
Package: libatlas3-base (not installed)
ProcVersionSignature: Ubuntu 3.5.0-21.32-generic 3.5.7.1
Uname: Linux 3.5.0-21-generic x86_64
NonfreeKernelModules: fglrx wl
ApportVersion: 2.6.1-0ubuntu9
Architecture: amd64
Date: Wed Jan 2 10:11:07 2013
DpkgTerminalLog:
 Unpacking libatlas3-base (from .../libatlas3-base_3.8.4-8ubuntu1_amd64.deb) ...
 Setting up libatlas3-base (3.8.4-8ubuntu1) ...
 update-alternatives: error: alternative libblas.so.3gf can't be slave of libblas.so.3: it is a master alternative
 dpkg: error processing libatlas3-base (--configure):
  subprocess installed post-installation script returned error exit status 2
DuplicateSignature:
 Setting up libatlas3-base (3.8.4-8ubuntu1) ...
 update-alternatives: error: alternative libblas.so.3gf can't be slave of libblas.so.3: it is a master alternative
 dpkg: error processing libatlas3-base (--configure):
  subprocess installed post-installation script returned error exit status 2
ErrorMessage: subprocess installed post-installation script returned error exit status 2
InstallationDate: Installed on 2012-04-27 (250 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MarkForUpload: True
SourcePackage: atlas
Title: package libatlas3-base (not installed) failed to install/upgrade: subprocess installed post-installation script returned error exit status 2
UpgradeStatus: Upgraded to quantal on 2012-12-11 (21 days ago)

John Joergensen (jjoerg-n) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in atlas (Ubuntu):
status: New → Confirmed

FWIW, I hacked some of the dpkg files to fix this. This is just a workaround.

I removed the update-alternative lines from /var/lib/dpkg/info/libblas3.postinst, libblas3.preinst, libatlas3-base.postinst, libatlas3-base.preinst and liblapack3.postinst

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers