package libatk1.0-dev 1.29.92-0ubuntu1 failed to install/upgrade: trying to overwrite '/usr/share/gir-1.0/Atk-1.0.gir', which is also in package gobject-introspection-repository 0:0.6.5-0ubuntu1

Bug #547244 reported by Philip Muškovac on 2010-03-25
64
This bug affects 14 people
Affects Status Importance Assigned to Milestone
atk1.0 (Ubuntu)
Low
Unassigned
Lucid
High
Luke Yelavich

Bug Description

Updating libatk1.0-dev in karmic to the version of libatk1.0-dev in lucid causes an error, due to libatk1.0-dev in lucid containing the same file as the gobject-introspection-repository package from karmic. libatk1.0-dev contains the file in question due to the deprecation of the gobject-introspection-repository package.

Whilst most users do not have libatk1.0-dev installed, there is a good chance that developers updating from karmic will hit this packaging error. Whilst slightly outside the standard upgrade use case, the libatk1.0-dev package in its current form will break the release upgrade process.

There is no chance of regression potential, as the updated libatk1.0-dev package replaces gobject-introspection-repository, thereby taking ownership of the file file that causes the conflict error.

Test case:
This bug, and the proposed fix, are best tested in a karmic chroot, with all karmic updates applied. The tester will also require libatk1.0-0 and libatk1.0-dev packages for both lucid, and lucid-proposed, either by downloading the .deb files directly, or adding lucid-proposed as a package source in sources.list. If a karmic chroot is not available, an up to date karmic install should be sufficient for testing. If you wish to update your system completely from akrmic to lucid, skip step 2 below, and perform the instructions in step 3, ensuring you also have lucid-proposed in sources.list. The chroot method is preferred however, as it prevents the installation of other packages from lucid-proposed, which may interfear with testing the fix for this bug.

1. Enter the karmic chroot, and install libatk1.0-dev and gobject-introspection-repository from the karmic repos.
2. Either from .deb files, or by adding lucid in sources.list, install libatk1.0-0 and libatk1.0-dev packages. Notice the package error, due to two packages claiming to own /usr/share/gir-1.0/Atk-1.0.gir.
3. Again either from .deb files, or by adding lucid-proposed to sources.list, install libatk1.0-0 and libatk1.0-dev packages, making sure they are version 1.30.0-0ubuntu2.1. These packages should now install successfully.

NOTE: This bug is not present when upgrading from lucid to maverick, so no fix is required in maverick.

Original bug description follows:
error while updating.

ProblemType: Package
Architecture: amd64
Date: Wed Mar 24 23:51:39 2010
DistroRelease: Ubuntu 10.04
ErrorMessage: trying to overwrite '/usr/share/gir-1.0/Atk-1.0.gir', which is also in package gobject-introspection-repository 0:0.6.5-0ubuntu1
NonfreeKernelModules: nvidia
Package: libatk1.0-dev 1.29.92-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.32-16.25-server
SourcePackage: atk1.0
Title: package libatk1.0-dev 1.29.92-0ubuntu1 failed to install/upgrade: trying to overwrite '/usr/share/gir-1.0/Atk-1.0.gir', which is also in package gobject-introspection-repository 0:0.6.5-0ubuntu1
Uname: Linux 2.6.32-16-server x86_64

Philip Muškovac (yofel) wrote :
Philip Muškovac (yofel) wrote :

$ apt-cache policy gobject-introspection-repository
gobject-introspection-repository:
  Installed: 0.6.5-0ubuntu1
  Candidate: 0.6.5-0ubuntu1
  Version table:
 *** 0.6.5-0ubuntu1 0
         50 http://de.archive.ubuntu.com/ubuntu/ karmic/main Packages
        100 /var/lib/dpkg/status

karmic leftover I guess.

Changed in atk1.0 (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package atk1.0 - 1.30.0-0ubuntu2

---------------
atk1.0 (1.30.0-0ubuntu2) lucid; urgency=low

  * debian/control.in:
    - replaces gobject-introspection-repository too (lp: #547244)
 -- Sebastien Bacher <email address hidden> Thu, 01 Apr 2010 00:39:42 +0200

Changed in atk1.0 (Ubuntu):
status: New → Fix Released

Hrm. I'm still getting an error from this:

Preparing to replace libatk1.0-dev 1.28.0-0ubuntu1 (using .../libatk1.0-dev_1.30.0-0ubuntu2_i386.deb) ...
Unpacking replacement libatk1.0-dev ...
dpkg: error processing /var/cache/apt/archives/libatk1.0-dev_1.30.0-0ubuntu2_i386.deb (--unpack):
 trying to overwrite '/usr/share/gir-1.0/Atk-1.0.gir', which is also in package gobject-introspection-repository 0:0.6.5-0ubuntu1
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libatk1.0-dev_1.30.0-0ubuntu2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Am I mis-{read,understand}ing this error?

Changed in atk1.0 (Ubuntu):
status: Fix Released → New
Francois (xbgmsharp) wrote :

I am also impact with this bug.
The problem is that packages gobject-introspection-repository does not exist anymore in Lucid.
The source package need to be update in debian/control.in, the maintainer need to add gobject-introspection-repository into the replace line.
As i did not want to compile it, here is a work around.

laptop:$ sudo apt-get update

laptop:$ sudo apt-get dist-upgrade
Preparing to replace libatk1.0-dev 1.28.0-0ubuntu1 (using .../libatk1.0-dev_1.30.0-0ubuntu2_i386.deb) ...
Unpacking replacement libatk1.0-dev ...
dpkg: error processing /var/cache/apt/archives/libatk1.0-dev_1.30.0-0ubuntu2_i386.deb (--unpack):
 trying to overwrite '/usr/share/gir-1.0/Atk-1.0.gir', which is also in package gobject-introspection-repository 0:0.6.5-0ubuntu1
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libatk1.0-dev_1.30.0-0ubuntu2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

laptop:$ mkdir atk1.0-1.30.0/

laptop:$ cd atk1.0-1.30.0/

laptop:~/atk1.0-1.30.0$ ar vx /var/cache/apt/archives/libatk1.0-dev_1.30.0-0ubuntu2_i386.deb
x - debian-binary
x - control.tar.gz
x - data.tar.gz

laptop:~/atk1.0-1.30.0$ tar zxvf control.tar.gz
./
./md5sums
./control

laptop:~/atk1.0-1.30.0$ nano ./control

In Package "Package: libatk1.0-dev"
Add "gobject-introspection-repository" to "Replaces:.."

laptop:$ ar -r ../libatk1.0-dev_1.30.0-0ubuntu3_i386.deb debian-binary control.tar.gz data.tar.gz

laptop:$ sudo dpkg -i ../libatk1.0-dev_1.30.0-0ubuntu3_i386.deb
[sudo] password for kaya:
(Reading database ... 231624 files and directories currently installed.)
Preparing to replace libatk1.0-dev 1.28.0-0ubuntu1 (using .../libatk1.0-dev_1.30.0-0ubuntu3_i386.deb) ...
Unpacking replacement libatk1.0-dev ...
Replacing files in old package gobject-introspection-repository ...
dpkg: dependency problems prevent configuration of libatk1.0-dev:
 libatk1.0-dev depends on libatk1.0-0 (= 1.30.0-0ubuntu2); however:
  Package libatk1.0-0 is not configured yet.
 libatk1.0-dev depends on pkg-config; however:
  Package pkg-config is not configured yet.
 libatk1.0-dev depends on libglib2.0-dev (>= 2.4.1-2); however:
  Package libglib2.0-dev is not configured yet.
dpkg: error processing libatk1.0-dev (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libatk1.0-dev

laptop:$ sudo apt-get dist-upgrade

You will need to do the same for libgtk2.0-dev_2.20.0-0ubuntu4

loketak (karel-jelinek) wrote :

thank you for your procedure Francois, you only forget write after editing of ./control again create control.tar.gz file

laptop:~/atk1.0-1.30.0$ tar -zcvf control.tar.gz control md5sums

Sebastien Bacher (seb128) wrote :

it's not an issue when upgrading from lucid so closing this task

Changed in atk1.0 (Ubuntu):
status: New → Invalid
Sebastien Bacher (seb128) wrote :

Luke, could you get atk updated to the current stable version and fixes that issue in the same upload? libatk1.0-dev needs a Replaces on gobject-introspection-repository. Would be nice to get this uploaded next week if you can to make sure we are on time to get the update in lucid .1

Changed in atk1.0 (Ubuntu Lucid):
assignee: nobody → Luke Yelavich (themuso)
importance: Undecided → High
milestone: none → ubuntu-10.04.1
status: New → Confirmed
status: Confirmed → Triaged
Luke Yelavich (themuso) wrote :

Lucid already has the latest stable atk version, 1.30.0, so I'll SRU this bug.

Changed in atk1.0 (Ubuntu Lucid):
status: Triaged → In Progress
Luke Yelavich (themuso) wrote :

Debdiff with the proposed fix for this bug.

description: updated
Luke Yelavich (themuso) on 2010-06-28
Changed in atk1.0 (Ubuntu Lucid):
status: In Progress → Fix Committed

Accepted atk1.0 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Luke Yelavich (themuso) on 2010-07-02
description: updated
Luke Yelavich (themuso) wrote :

I can verify that installing libatk1.0-dev and gobject-introspection-repository into a karmic system, and upgrading libatk1.0-dev to the package version found in lucid, that package installation fails. I can also verify that once lucid-proposed was added to sources.list, the upgrade to the package version in lucid-proposed succeeds, with libatk1.0-dev successfully replacing gobject-introspection-repository.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package atk1.0 - 1.30.0-0ubuntu2.1

---------------
atk1.0 (1.30.0-0ubuntu2.1) lucid-proposed; urgency=low

  * debian/control.in: libatk1.0-dev should replace
    gobject-introspection-repository (LP: #547244)
 -- Luke Yelavich <email address hidden> Mon, 28 Jun 2010 10:26:28 +1000

Changed in atk1.0 (Ubuntu Lucid):
status: Fix Committed → Fix Released
arturm (arturm) on 2010-08-17
Changed in atk1.0 (Ubuntu Lucid):
status: Fix Released → Fix Committed
Steve Langasek (vorlon) on 2010-08-17
Changed in atk1.0 (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers