WARNING: Couldn't register with accessibility bus: Did not receive a reply.

Bug #1222356 reported by Paul Ortyl on 2013-09-08
134
This bug affects 30 people
Affects Status Importance Assigned to Milestone
at-spi2-core (Debian)
Fix Released
Unknown
at-spi2-core (Ubuntu)
Undecided
Unassigned

Bug Description

The following warnings/errors appear after calling ubuntu-bug

** (apport-gtk:3020): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(process:4192): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: apport-gtk 2.12.1-0ubuntu3
ProcVersionSignature: Ubuntu 3.11.0-4.9-generic 3.11.0-rc7
Uname: Linux 3.11.0-4-generic x86_64
ApportVersion: 2.12.1-0ubuntu3
Architecture: amd64
Date: Sun Sep 8 10:54:01 2013
EcryptfsInUse: Yes
InstallationDate: Installed on 2012-09-01 (371 days ago)
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: apport
UpgradeStatus: Upgraded to saucy on 2013-09-05 (2 days ago)

Paul Ortyl (ortylp) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
pedro (peterpan2000355) wrote :

Affects me when I use rhythmbox and gedit (bug knowledge , unresolved)

Augustus Wong (angrygermankids) wrote :

im on 14.04 and have this bug

gaara (yoggic) wrote :

It's affect me using zenity, in 14.04. For example:
zenity --info --text try

WinEunuchs2Unix (ricklee518) wrote :

I get the bug in terminal mode with "gedit /etc/network/interfaces" (read only mode).

I do NOT get the bug with "sudo gedit /etc/network/interfaces" or "gksudo gedit /etc/network/interfaces" (full permissions)

Anders Hall (a.hall) wrote :

Get this warning when running command "nautilus" in terminal as non root user.

3.13.0-30-generic #54-Ubuntu SMP Mon Jun 9 22:45:01 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Anders Hall (a.hall) wrote :

http://debbugs.gnu.org/cgi/bugreport.cgi?bug=15154#16 (comment 16 since allot of these warnings exist)

How to suppress the message

"I believe this message comes rather from atk (but gtk):

As Tim Van Holder has found out, one could suppress this with
"export NO_AT_BRIDGE=1". See <http://debbugs.gnu.org/cgi/bugreport.cgi?bug=15154#11>."

Beat (beat-c) wrote :

Affected me too on Ubuntu 14.04 with liferea RSS-reader, after an apport-crash on wakeup from sleep on laptop (macbook pro 17" with external 30" Dell-display connected on sleep and wake-up).

Running export NO_AT_BRIDGE=1 before invoking liferea worked around this condition. Probably rebooting the laptop will fix it too.

Don't know if it is linked or not, so wrting it here in case it helps:
When waking from sleep external monitor is recognized but not waken up. Unplugging and repluging it was enough with Ubuntu 13.10, but not with 14.04 anymore. However unplugging then replugging and then just starting Settings application resolves the issue. (but just starting Settings without unplugging and replugging external monitor is not enough).

Martin Spacek (mspacek) wrote :

Is this perhaps a duplicate of bug #1347272 (Several XFCE applications appear unresponsive after communicating with a daemon)?

I have this issue too. It occured when I ran the command `apport-collect 1353913`, see below:

$ apport-collect 1353913

** (apport-gtk:7970): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
dpkg-query: no packages found matching linux

How can I fix this?

Mathew Hodson (mathew-hodson) wrote :

This seems related to or a duplicate of bug #1193236.

affects: apport (Ubuntu) → at-spi2-core (Ubuntu)
summary: - ** (apport-gtk:3020): WARNING **: Couldn't register with accessibility
- bus: Did not receive a reply. Possible causes include: the remote
- application did not send a reply, the message bus security policy
- blocked the reply, the reply timeout expired, or the network connection
- was broken.
+ Couldn't register with accessibility bus: Did not receive a reply.
summary: - Couldn't register with accessibility bus: Did not receive a reply.
+ WARNING: Couldn't register with accessibility bus: Did not receive a
+ reply.
Changed in at-spi2-core (Debian):
status: Unknown → Fix Released

According to the Debian bug report this bug seems to be fixed.

Changed in at-spi2-core (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.