Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-*

Bug #1193236 reported by dino99 on 2013-06-21
302
This bug affects 72 people
Affects Status Importance Assigned to Milestone
at-spi
Invalid
Undecided
Unassigned
at-spi2-core (Debian)
Invalid
Undecided
Unassigned
at-spi2-core (Ubuntu)
Low
Unassigned
gnome-session (Ubuntu)
Undecided
Unassigned

Bug Description

Since a few days, xsession-errors is fullfilled by that kind of errors:

** (nautilus:22621): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-uUkE07qdBK: Connection refused

** (gedit:22640): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-uUkE07qdBK: Connection refused

Similar errors are reported all over the net, but Debian have tried to fix it already:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=702517

But some other devs seems to blame an atk-bridge:
https://groups.google.com/forum/#!topic/yad-common/nYP0RutlxNA

And some others suggest a dbus/gdbus race; the good thing is that seems not disturbing that much the system.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: libgdk-pixbuf2.0-0 2.28.1-1ubuntu2
ProcVersionSignature: Ubuntu 3.9.0-6.14-generic 3.9.6
Uname: Linux 3.9.0-6-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.10.2-0ubuntu1
Architecture: i386
Date: Fri Jun 21 08:35:40 2013
MarkForUpload: True
SourcePackage: gdk-pixbuf
UpgradeStatus: No upgrade log present (probably fresh install)

dino99 (9d9) wrote :
description: updated
dino99 (9d9) on 2013-06-21
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdk-pixbuf (Ubuntu):
status: New → Confirmed
Changed in gdk-pixbuf (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
status: Triaged → Incomplete
status: Incomplete → Fix Committed
Changed in gdk-pixbuf:
importance: Unknown → Critical
status: Unknown → Fix Released
Changed in gdk-pixbuf (Ubuntu):
status: Fix Committed → Fix Released
Martin Spacek (mspacek) wrote :

I still get this error in Xubuntu 14.04 when I run "sudo gnome-disks", and possibly other commands that I can't recall at the moment:

$ sudo gnome-disks
[sudo] password for mspacek:

** (gnome-disks:474): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-xW1zTsGFKW: Connection refused

Bug #1314782 suggests there's a dbus race condition affecting lots of packages in Ubuntu.

@ Martin Spacek:

I have just triaged the bugs you mentioned.

Please do the following:

 1. Being in Xubuntu 14.04, into the Terminal, enter "ubuntu-bug dbus" and follow steps for reporting this same bug for the Trusty release.

 2. Mention the bug number you just reported in every related report you know, including this.

Then I will triage your report as critical and report it to the XFCE developers.

Martin Spacek (mspacek) wrote :

Thanks Alberto! OK, I've submitted a new bug report against dbus:

Bug #1347272 (DBus communication problems affecting multiple packages)

affects: gdk-pixbuf (Ubuntu) → at-spi2-core (Ubuntu)
affects: gdk-pixbuf → at-spi
Changed in at-spi:
importance: Critical → Unknown
status: Fix Released → Unknown

This mailing list entry explains why a warning message may appear when an application is run as root:

https://mail.gnome.org/archives/gnome-accessibility-devel/2011-June/msg00006.html

Changed in at-spi:
importance: Unknown → Medium
status: Unknown → New
Changed in at-spi2-core (Debian):
status: Unknown → Confirmed
Changed in at-spi2-core (Ubuntu):
status: Fix Released → Confirmed

I would like to also confir this bug in a 14.04.1 system. I would live to report this using apport-bug but it is that very command that is failing! Here is the terminal output seen when attempting to run this commad:

------------------------------------------------------------------------------------
3-> apport-bug smbclient

** (apport-gtk:7235): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-J9CVMJHXEs: Connection refused
4->
(process:7727): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

(firefox:7727): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::sm-connect after class was initialised

(firefox:7727): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::show-crash-dialog after class was initialised

(firefox:7727): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::display after class was initialised

(firefox:7727): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::default-icon after class was initialised
------------------------------------------------------------------------------------

After answering various question and getting to the place where it is supposed to write the html file, the browser reports that the file is unavailable (i.e., doesn't exist).

I have used apport-bug a couple of times in the past. This just started today. I rebotted the machine and the problem persisted.

Any known workaround would be appreciated.

gouri (stephane-gourichon-lpad) wrote :

The error message:
* is reproducible always,
* on trusty
* with zenity, abiword, gitg, gnome-calculator, probably with other or even all gtk3-apps, too. I have tested only a handful and all exhibit this behavior. Zenity is mentioned in bug #1326099 .

For example:

** (zenity:10455): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-isvBHBGV9Q: Connexion refusée

It seems to have no other side effect as the applications work fine. But this noise in stderr causes troubles, for example in cron jobs.

eris23 (jdkatz23) wrote :

Affects Xubuntu 14.10 amd64 when launching ubuntu-tweak.

dino99 (9d9) wrote :

Feedback

Since that reported issue, i've made three fresh installations: utopic 32, utopic 64, trusty 32
they all run gnome-shell.

 As a result, the error reported here has not been seen on these installations: one use its own 'home' folder, the 2 others share a /home partition (the same one used when that report has been opened).

So it seems that some config paramaters/symlinks or package/folder rights (on the system itself, not those inside /home) are wrong or left behind after upgrading.

Severin Wünsch (sk1d) wrote :

I am getting the error on fresh installation of lubuntu 14.10 amd64 when I try to use zenity.

tags: added: utopic
ERRATI Younes (errati) wrote :

same on Ubuntu 14.04.1 when runing light-locker.

Problem still visible in Xubuntu 14.10, for all Gtk applications.

thedward (thedward) wrote :

If I add the following to my .bashrc, the message stops appearing:

export NO_AT_BRIDGE=1

mkoniecz (matkoniecz) wrote :

Triggered by baobab on Ubuntu 14.04. If I add the following to my .bashrc, the message stops appearing:

export NO_AT_BRIDGE=1

Fresh install 14.04.02. export NO_AT_BRIDGE=1 works as a workaround.

dino99 (9d9) on 2015-04-22
tags: removed: saucy
dino99 (9d9) wrote :

This is no more an issue on my system (but cant tell why)

Changed in at-spi2-core (Ubuntu):
status: Confirmed → Invalid
Changed in at-spi2-core (Debian):
importance: Unknown → Undecided
status: Confirmed → New
status: New → Invalid
Changed in at-spi:
importance: Medium → Undecided
status: New → Invalid
teledyn (garym-teledyn) wrote :

seen in 15.04 running Cheese.

dino99 (9d9) wrote :

Please open your own report if you are affected.

Changed in gnome-session (Ubuntu):
status: New → Invalid

I got this error on 14.04 when opening Emacs and Gedit from the terminal. The NO_AT_BRIDGE worked for me.

Ilya G. Ryabinkin (ileyka) wrote :

Same for me, 14.04.05 fully updated. Noticed only today, there was no such an issue before (couple of days at least). Showing up with emacs and evince.

taur (taur) wrote :

Still present running meld on Xubuntu 16.04.2

Damian Yerrick (tepples) wrote :

Comment #20 appears to recommend filing a deliberate duplicate:

> Please open your own report if you are affected.

One such duplicate is Bug #1617630.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.