Ubuntu

package libatk-adaptor-schemas (not installed) failed to install/upgrade: trying to overwrite '/usr/share/glib-2.0/schemas/org.a11y.atspi.gschema.xml', which is also in package libatk-adaptor 2.2.1-0ubuntu1

Reported by cuco on 2012-04-13
256
This bug affects 38 people
Affects Status Importance Assigned to Milestone
at-spi2-atk (Ubuntu)
Undecided
Unassigned

Bug Description

Was just upgrading ubuntu-desktop using Synaptic Package Manager and this message popped up to report a problem

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: libatk-adaptor-schemas (not installed)
ProcVersionSignature: Ubuntu 3.0.0-17.30-generic 3.0.22
Uname: Linux 3.0.0-17-generic i686
ApportVersion: 2.0.1-0ubuntu2
Architecture: i386
Date: Fri Apr 13 13:24:39 2012
DuplicateSignature:
 Unpacking libatk-adaptor-schemas (from .../libatk-adaptor-schemas_2.4.0-1ubuntu2_i386.deb) ...
 dpkg: error processing /var/cache/apt/archives/libatk-adaptor-schemas_2.4.0-1ubuntu2_i386.deb (--unpack):
  trying to overwrite '/usr/share/glib-2.0/schemas/org.a11y.atspi.gschema.xml', which is also in package libatk-adaptor 2.2.1-0ubuntu1
ErrorMessage: trying to overwrite '/usr/share/glib-2.0/schemas/org.a11y.atspi.gschema.xml', which is also in package libatk-adaptor 2.2.1-0ubuntu1
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
SourcePackage: at-spi2-atk
Title: package libatk-adaptor-schemas (not installed) failed to install/upgrade: trying to overwrite '/usr/share/glib-2.0/schemas/org.a11y.atspi.gschema.xml', which is also in package libatk-adaptor 2.2.1-0ubuntu1
UpgradeStatus: No upgrade log present (probably fresh install)

cuco (jrvillalobos) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in at-spi2-atk (Ubuntu):
status: New → Confirmed
tags: added: amd64 dist-upgrade distribution-upgrade oneiric2precise rls-mgr-p-tracking
tags: added: bugpattern-needed
Philippe (philippe-rast) wrote :

I had the same problem. I resolved it with

sudo dpkg --remove libatk*
sudo apt-get -f install

Cheers,
hope it helps

Luke Yelavich (themuso) wrote :

Could anybody still affected by this bug please add my PPA, ppa:themuso/ppa, and try updating your system? Please let me know whether the proposed libatk-adaptor and libatk-adaptor-schemas packages worked, or not.

Thanks.

reanimator (emerg-reanimator) wrote :

Here is the update for this issue.

Not sure what happened for one week, but the issue is gone apparently.

Terminal log
====================================================================
sudo apt-get install libatk-adaptor
[sudo] password for anfas:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  libatk-adaptor-schemas
The following NEW packages will be installed:
  libatk-adaptor-schemas
The following packages will be upgraded:
  libatk-adaptor
1 upgraded, 1 newly installed, 0 to remove and 77 not upgraded.
Need to get 0 B/123 kB of archives.
After this operation, 32.8 kB of additional disk space will be used.
Do you want to continue [Y/n]?
(Reading database ... 254057 files and directories currently installed.)
Preparing to replace libatk-adaptor 2.2.1-0ubuntu1 (using .../libatk-adaptor_2.4.0-1ubuntu2_i386.deb) ...
Unpacking replacement libatk-adaptor ...
Unpacking libatk-adaptor-schemas (from .../libatk-adaptor-schemas_2.4.0-1ubuntu2_i386.deb) ...
Processing triggers for libglib2.0-0 ...
Setting up libatk-adaptor (2.4.0-1ubuntu2) ...
Setting up libatk-adaptor-schemas (2.4.0-1ubuntu2) ...

Piotr Machowski (pmachowski) wrote :

Hello,

My problem with libatk-adaptor also has gone away after

sudo dpkg --remove libatk*
sudo apt-get -f install

Philippe, thanks for sharing this magic ;-)

Brgds,
pm

Ivan Feofilaktov (ivan-t) wrote :

Thanx to Philippe, those two lines resolved problem!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers