Eclipse does not close (window disappears, process keeps running)

Bug #68714 reported by claudio@ubuntu on 2006-10-27
112
This bug affects 15 people
Affects Status Importance Assigned to Milestone
at-spi
Invalid
Critical
at-spi (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Martin Knudsen

Bug Description

=============
BUG
=============
Eclipse does not close when closing the application (File-Exit or windows closing cross). The eclipse window disappears, but the process keeps running:

25524 pts/3 S+ 0:00 /usr/lib/eclipse/eclipse -vm /usr/lib/jvm/java-1.5.0-sun/bin/java -install /usr/lib/eclipse -startup /usr

This problem also occur with the upstream 3.2.1 package. I have this problem on my x86 box, not on my amd64 box.

=============
WORKAROUND
=============
Disable assistive technologies:
System > Preferences > Assistive Technology Preferences > "Enable assistive technologies"

claudio@ubuntu (claudio.ubuntu) wrote :

Using an other vm (gcj):

claudio@sydney:~$ eclipse -vm /usr/lib/jvm/java-1.4.2-gcj-4.1-1.4.2.0/bin/java

runs fine and mysteriously eclipse exists fine now.

Albrecht Mühlenschulte (a7p) wrote :

Same here, the sunjavavm locks up and is only killable via kill -9. I think this problem is related to gtk-accessibilty (during the pre-betaphase, I removed some packages and suddenly quiting the VM worked - sorry, I do not remember which package it was).

I have the same problem with Sun Java.

In terminal, when I have executed eclipse, showed "GTK Accessibility Module initialized". Now, it not showed more and the problem NOT occurs more.

PS: Sorry for my little english.

I removed "at-spi" - now everything seems fine.

a7p, I have at-spi installed and Eclipse works fine.

Albrecht Mühlenschulte (a7p) wrote :

Did you disable the "GTK Accessibility Module" in some way?

a7p, I don't know... I saw that other aplications with Java doesn't close (at-spi problem), but Eclipse work fine.

Ryan (crumley) wrote :

I have this same problem. It only occurs when I run eclipse with the sun jdk. If I use the ibm jdk it closes just fine (and terminates!).

Albrecht Mühlenschulte (a7p) wrote :

I suspect this beeing an incanation of #71365. But don't think it can be marked as a duplicate yet.

Albrecht Mühlenschulte (a7p) wrote :

The problem still exists with a custom installed jre6.

TJ (tj) wrote :

I am experiencing the same issue with Edgy, kernel 2.6.17.14, Eclipse 3.2 and Sun Java JRE 1.5.0_08-b03.

As other reporters have said, this is caused by a problem with Accessibility support provided by at-spi.

Disabling

System > Preferences > Assistive Technology Preferences > "Enable assistive technologies"

works around the issue, but is obviously not a fix.

It appears there is a problem with the Java Access Bridge. I've posted a bug against the Gnome at-spi package and referred it to the this bug:

http://bugzilla.gnome.org/show_bug.cgi?id=405368

Changed in at-spi:
status: Unknown → Unconfirmed
Albrecht Mühlenschulte (a7p) wrote :

It is reproducible, there is a workaround solving the problem by disabling the accessiblity stuff -> confirmed.

Changed in at-spi:
status: Unconfirmed → Confirmed
Changed in at-spi:
status: Unconfirmed → In Progress
Changed in at-spi:
status: In Progress → Rejected
Albrecht Mühlenschulte (a7p) wrote :

The problem is no longer present in Feisty.

Changed in at-spi:
status: Confirmed → Fix Released
Allan (allan-stokes) wrote :

I've just confirmed that this problem still exists in my JJ AMD64 system. After removing at-spi and rebooting, for the first time in months, Eclipse fully shut down the Sun JVM without me having to do a manual kill -9. I've been running Eclipse Galileo 3.5, and just upgraded to 3.5.1. This happened in both versions.

My present system information:

/usr/bin/java -version
java version "1.6.0_16"
Java(TM) SE Runtime Environment (build 1.6.0_16-b01)
Java HotSpot(TM) 64-Bit Server VM (build 14.2-b01, mixed mode)

uname -a
Linux krumm 2.6.28-15-generic #52-Ubuntu SMP Wed Sep 9 10:48:52 UTC 2009 x86_64 GNU/Linux

Changed in at-spi (Ubuntu):
status: Fix Released → Incomplete
Benjamin Drung (bdrung) on 2009-10-28
Changed in at-spi (Ubuntu):
status: Incomplete → Confirmed

Confirming for Karmic 32 bit.

description: updated

What to do about this? Gnome says NOTABUG in at-spi.
This a serious problem the hung process consumes lots of memory.

I've the same problem running eclipse 3.6-m4 under karmic 64-bit.

Take a look at https://bugs.eclipse.org/bugs/show_bug.cgi?id=229071

Bruno Girin (brunogirin) wrote :

I can confirm this issue with Eclipse Galileo on Lucid beta 2.

Martin Knudsen (brainwashed) wrote :

I can confirm this on just-installed Lucid Lynx RC. Affects Eclipse as well as RSSOwl (which uses the Eclipse Toolkit AFAIK). Removing the package at-spi fixed the issue for me.

Java Installation is Open-JDK 6 from standard repo.

I've the same problem running eclipse 3.6-m7 under 10.04 64-bit.
Interestingly, the eclipse and java VM still running and I have to kill the java VM.

If after I exit eclipse, I kill the process at-spi-registryd, the eclipse ends.

Changed in at-spi:
importance: Unknown → Critical

The bug is not present if I use jdk from ibm instead of jdk from sun.
Even if accessibility is enabled.

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in at-spi (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.