Crash on login with accessibility enabled

Bug #551860 reported by Paul Larson
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
at-spi (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

Binary package hint: metacity

Apport could not report this bug because it claimed it was due to an assertion error and could not handle that.

After enabling accessibility support under preferences->assistive technologies, I logged out and logged back in. Immediately, I was dumped back to the graphical login prompt. Enabling accessibility seems to add the following lines to ~/.gconf/desktop/gnome/interface/%gconf.xml a1.bak2/.gconf/desktop/gnome/interface/%gconf.xml:

<?xml version="1.0"?>
<gconf>
 <entry name="accessibility" mtime="1269967253" type="bool" value="true"/>
</gconf>

Removing those lines allows me to log in again.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: metacity 1:2.28.1-0ubuntu7
ProcVersionSignature: Ubuntu 2.6.32-202.14-hostname
Uname: Linux 2.6.32-202-dove armv7l
Architecture: armel
Date: Tue Mar 30 11:46:43 2010
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Beta armel+dove (20100317)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: metacity

Related branches

Revision history for this message
Paul Larson (pwlars) wrote :
Revision history for this message
Dave Morley (davmor2) wrote :

Affect i386 version too.

On login it goes to a black screen and then back out to gdm

Changed in metacity (Ubuntu):
status: New → Confirmed
Paul Larson (pwlars)
tags: removed: armel
Paul Larson (pwlars)
Changed in metacity (Ubuntu Lucid):
importance: Undecided → High
milestone: none → ubuntu-10.04
Revision history for this message
Alexander Sack (asac) wrote :

this feels worth having on release team radar ... as it seems to be arch independent.

Didier Roche (didrocks)
Changed in metacity (Ubuntu Lucid):
assignee: nobody → Didier Roche (didrocks)
Revision history for this message
Didier Roche (didrocks) wrote :

As told to Dave on IRC, I can't reproduce it on i386 with latest metacity (2.30.1). Can you try to get a stacktrace?

I just enabled accessibility support under preferences->assistive technologies and have the same diff in ~/.gconf

Changed in metacity (Ubuntu Lucid):
status: Confirmed → Incomplete
Revision history for this message
Sebastien Bacher (seb128) wrote :

gnome-session crashes in libatspi because libgail-common is not installed

affects: metacity (Ubuntu Lucid) → at-spi (Ubuntu Lucid)
Changed in at-spi (Ubuntu Lucid):
status: Incomplete → Fix Committed
assignee: Didier Roche (didrocks) → nobody
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package at-spi - 1.30.0-0ubuntu2

---------------
at-spi (1.30.0-0ubuntu2) lucid; urgency=low

  * debian/control.in: depends on libgail-common since the schemas lists
    it as a required component to load (lp: #551860)
 -- Sebastien Bacher <email address hidden> Fri, 16 Apr 2010 16:43:23 +0200

Changed in at-spi (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers