at-spi-registryd crashed with SIGSEGV in gconf_client_get_default()

Bug #508156 reported by Monkey on 2010-01-15
320
This bug affects 71 people
Affects Status Importance Assigned to Milestone
at-spi
Expired
Medium
at-spi (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: at-spi

I only know that I´ve got a report. Sorry I hope that be useful.

ProblemType: Crash
Architecture: i386
Date: Fri Jan 15 23:48:04 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/lib/at-spi/at-spi-registryd
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100113)
Package: at-spi 1.29.5-0ubuntu3
ProcAttrCurrent: unconfined (enforce)
ProcCmdline: /usr/lib/at-spi/at-spi-registryd --oaf-activate-iid=OAFIID:Accessibility_Registry:1.0 --oaf-ior-fd=18
ProcEnviron:
 LANG=es_ES.UTF-8
 PATH=(custom, no user)
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-10.14-generic
SegvAnalysis:
 Segfault happened at: 0x5ab031: mov 0xc(%eax),%eax
 PC (0x005ab031) ok
 source "0xc(%eax)" (0x0000000c) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: at-spi
StacktraceTop:
 ?? () from /usr/lib/libgconf-2.so.4
 gconf_client_get_default () from /usr/lib/libgconf-2.so.4
 ?? ()
 __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
 ?? ()
Tags: lucid
Title: at-spi-registryd crashed with SIGSEGV in gconf_client_get_default()
Uname: Linux 2.6.32-10-generic i686
UserGroups:

Monkey (monkey-libre) wrote :

StacktraceTop:
 set_engine (client=0x0, engine=0x85fc030) at gconf-client.c:268
 gconf_client_get_default () at gconf-client.c:447
 main (argc=3, argv=0xbf9a4d34) at registry-main.c:187

Changed in at-spi (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Monkey (monkey-libre) on 2010-01-16
visibility: private → public
Monkey (monkey-libre) wrote :

** (.:3055): WARNING **: AT_SPI_REGISTRY was not started at session startup.

** (.:3055): WARNING **: Could not locate registry

(.:3055): Bonobo-CRITICAL **: bonobo_unknown_ping: assertion `object != NULL' failed

** (.:3055): WARNING **: AT_SPI_REGISTRY was not started at session startup.

** (.:3055): WARNING **: Could not locate registry

(.:3055): Bonobo-CRITICAL **: bonobo_unknown_ping: assertion `object != NULL' failed

** (.:3055): WARNING **: AT_SPI_REGISTRY was not started at session startup.

** (.:3055): WARNING **: Could not locate registry

robertsandrock (robertsandrock) wrote :

28MAR10

Changed in at-spi:
status: Unknown → New

This bug exists in 10.10 x32 Beta release too, but sadly I don't know what caused it.

Changed in at-spi:
importance: Unknown → Medium
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

tags: added: a11y
Changed in at-spi (Ubuntu):
status: New → Triaged
dazza5000 (darran-kelinske) wrote :

this is happening to me on 11.10 nightlies

Charlie Kravetz (charlie-tca) wrote :

If it is happening with Ubuntu 11.10, it is probably bug #810839, which is the current release crashes. There have been many changes in libraries and applications in Ubuntu 11.10, including GTK3, which may cause a similar crash for different reasons.

arnaud (arnaud-jaspart) wrote :

seems to be a bug dupplicated of bug #810839

miked (miked11) wrote :
Changed in at-spi:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.