No module named pyatspi

Bug #491327 reported by arky on 2009-12-02
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
at-spi (Ubuntu)
Critical
Luke Yelavich

Bug Description

Binary package hint: at-spi

Might be the caused of path changes in the last upstream release.

$ python -c 'import pyatspi'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named pyatspi

$ apt-cache policy at-spi
at-spi:
  Installed: 1.29.2-0ubuntu1
  Candidate: 1.29.2-0ubuntu1
  Version table:
 *** 1.29.2-0ubuntu1 0
        500 http://archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

$ apt-cache policy python-pyatspi
python-pyatspi:
  Installed: 1.29.2-0ubuntu1
  Candidate: 1.29.2-0ubuntu1
  Version table:
 *** 1.29.2-0ubuntu1 0
        500 http://archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

Related branches

arky (arky) on 2009-12-09
Changed in at-spi (Ubuntu):
importance: Undecided → Critical
tags: added: iso-testing
WaywardGeek (waywardgeek) wrote :

This is caused by a stale reference to site-packages in /usr/lib/python2.6/dist-packages/pyatspi-cobra.pth. It refers to the old 'site-packages' instead of 'dist-packages'. The contents should look like:

import commands, sys; a = commands.getoutput('gconftool-2 --get /desktop/gnome/interface/at-spi-corba'); (a == 'true') and sys.path.insert(0, '/usr/lib/python2.6/dist-packages/pyatspi-corba')

Bill

arky (arky) wrote :

Thanks WaywardGeek that patch works !

Changed in at-spi (Ubuntu):
status: New → Confirmed

Hy Arki and all,

Little this is off, but if I do the change, pyatspi is imported, but if
I try run orca -v command, Orca doesn't import orca.orca module.
This is normal?
Possible my upgraded system is bugy (I do the upgrade with oldest time).
I download actual daily live cd and try the change if I have sighted
assistance.

Attila

arky (arky) wrote :

Attila it might be unrelated problem. Can post the error you are getting when you launch orca.

Attila Hammer (hammera) wrote :

Arki, unfortunately I am not possible help found what the error message
now absolute sure.
The problem is following:
Yesterday evening I downloaded actual daily live cd. When I booted the
live cd and the Desktop is present, my wife says me my display is blank.
After we try the live cd, I chrooted my actual Lucid system with another
system after I do the patch, and I run orca -v command.
I see this error:
Traceback (most recent call last):
   File "<string>", line 1, in <module>
ImportError: No module named orca.orca

Possible my prewious upgrade Lucid system is bugy, but I am can not
confirm this now because my display is blank when I booting the live cd.
Unfortunately I have'nt got a braille display. I am sorry if this
information is not help you. :-(:-(

Attila

Luke Yelavich (themuso) on 2009-12-14
Changed in at-spi (Ubuntu):
assignee: nobody → Luke Yelavich (themuso)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package at-spi - 1.29.3-0ubuntu1

---------------
at-spi (1.29.3-0ubuntu1) lucid; urgency=low

  * New upstream release
  * debian/patches/02_python_path.patch: Patch the hard-coded python module
    path to refer to dist-packages for python 2.6. (LP: #491327)
 -- Luke Yelavich <email address hidden> Tue, 15 Dec 2009 09:29:16 +1100

Changed in at-spi (Ubuntu):
status: In Progress → Fix Released
Attila Hammer (hammera) wrote :

Thank you Luke the fix, works very well if the
/desktop/gnome/interface/at-spi-corba gconf value setted up true .
I have a question:
need run the gconftool-2 --set /desktop/gnome/interface/at-spi-corba
--type bool true command when next daily live cd is publicated?
I ask this, because I downloaded the 2009-02-14 daily live cd (now this
morning this is avaylable with current directory with
cdimage.ubuntu.com/day-live location), extracted the squashfs
filesystem, and installed the latest updates. If I not configure this
gconf value, Orca does'nt import pyatspi module. If this gconf value is
true, Orca correct import the pyatspi module after the updates
installed, shows the version number (2.29.2) if I using the -v option.
Or if the user choosing accessible profile with screen reader support,
this value will be configured automaticaly with next daily live cd?

Attila

WaywardGeek (waywardgeek) wrote :

I forgot about this. Willie (the Orca guy) had me do:

    $ gconftool-2 --set /desktop/gnome/interface/at-spi-corba --type bool true

It's probably also required to get Orca working in Lucid.

Bill

On Tue, Dec 15, 2009 at 1:48 AM, Attila Hammer <email address hidden> wrote:
> Thank you Luke the fix, works very well if the
> /desktop/gnome/interface/at-spi-corba gconf value setted up true .
> I have a question:
> need run the gconftool-2 --set /desktop/gnome/interface/at-spi-corba
> --type bool true command when next daily live cd is publicated?
> I ask this, because I downloaded the 2009-02-14 daily live cd (now this
> morning this is avaylable with current directory with
> cdimage.ubuntu.com/day-live location), extracted the squashfs
> filesystem, and installed the latest updates. If I not configure this
> gconf value, Orca does'nt import pyatspi module. If this gconf value is
> true, Orca correct import the pyatspi module after the updates
> installed, shows the version number (2.29.2) if I using the -v option.
> Or if the user choosing accessible profile with screen reader support,
> this value will be configured automaticaly with next daily live cd?
>
> Attila
>
> --
> No module named pyatspi
> https://bugs.launchpad.net/bugs/491327
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “at-spi” package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: at-spi
>
> Might be the caused of path changes in the last upstream release.
>
> $ python -c 'import pyatspi'
> Traceback (most recent call last):
>  File "<string>", line 1, in <module>
> ImportError: No module named pyatspi
>
> $ apt-cache policy at-spi
> at-spi:
>  Installed: 1.29.2-0ubuntu1
>  Candidate: 1.29.2-0ubuntu1
>  Version table:
>  *** 1.29.2-0ubuntu1 0
>        500 http://archive.ubuntu.com lucid/main Packages
>        100 /var/lib/dpkg/status
>
> $ apt-cache policy python-pyatspi
> python-pyatspi:
>  Installed: 1.29.2-0ubuntu1
>  Candidate: 1.29.2-0ubuntu1
>  Version table:
>  *** 1.29.2-0ubuntu1 0
>        500 http://archive.ubuntu.com lucid/main Packages
>        100 /var/lib/dpkg/status
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/at-spi/+bug/491327/+subscribe
>

Luke Yelavich (themuso) wrote :

On Tue, Dec 15, 2009 at 09:19:29PM EST, WaywardGeek wrote:
> I forgot about this. Willie (the Orca guy) had me do:
>
> $ gconftool-2 --set /desktop/gnome/interface/at-spi-corba --type
> bool true
>
> It's probably also required to get Orca working in Lucid.

RIght, I thought that the at-spi package took appropriate action to set this gconf key. WIll upload a new update to fix this, and set that key by default.

 affects ubuntu/at-spi
 status inprogress
 assignee themuso

Changed in at-spi (Ubuntu):
status: Fix Released → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package at-spi - 1.29.3-0ubuntu2

---------------
at-spi (1.29.3-0ubuntu2) lucid; urgency=low

  * Set /desktop/gnome/interface/at-spi-corba to true, which will really allow
    the pyatspi module to be imported. Really fixes LP: #491327
 -- Luke Yelavich <email address hidden> Wed, 16 Dec 2009 12:14:27 +1100

Changed in at-spi (Ubuntu):
status: In Progress → Fix Released
Attila Hammer (hammera) on 2010-01-21
Changed in at-spi (Ubuntu):
status: Fix Released → New
Attila Hammer (hammera) wrote :

Luke, unfortunately latest current daily live cd Orca is not talking when I tryed.
The problem is possible related with this bug (oldest time you fixed this bug).
When I booted the current available downloaded Lucid daily live cd with screen reader support, Orca is not talking. I look /desktop/gnome/interface/at-spi-corba gconf value, the value is false. When I setted up with this value to true again, Orca is talking fine when I launched Orca again.
Possible not setted up default true value when the maintainers upgraded with At-Spi package with new version with this gconf key?

My machine this problem is not happen, because I setted up my home folder with this gconf key default with true, and if an at-spi update is happening, don't disturb Orca working my installed system.
But, my system are installed with since Alpha1.

Attila

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package at-spi - 1.29.5-0ubuntu4

---------------
at-spi (1.29.5-0ubuntu4) lucid; urgency=low

  * Re-set /desktop/gnome/interface/at-spi-corba to true, as it seems at-spi
    needs this to be set to run, even if it has been built for CORBA use
    only. (LP: #491327)
 -- Luke Yelavich <email address hidden> Fri, 22 Jan 2010 09:41:05 +1100

Changed in at-spi (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers