AT SPI Registry Wrapper not responding when I try to shut down

Bug #477978 reported by Matthew Horr on 2009-11-08
228
This bug affects 60 people
Affects Status Importance Assigned to Milestone
at-spi
Expired
Medium
at-spi (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: at-spi

Whenever I shut down my computer, I get an error message stating "AT SPI Registry Wrapper is not responding". I have to then click continue to shut down the computer.

This may be related to mousetweaks. I have Trigger secondary click by holding down the primary button enabled, but this feature rarely works. It started working when I re-installed mousetweaks, but has in a few days started to not work again.

I am using Ubuntu 9.10 Karmic on a MacbookPro1,1 with at-spi 1.28.1-0ubuntu1 installed

Please let me know if I can include any more info to help

DragonDon (dragondon) wrote :

Same problem here. I get this on two vastly different machines (AMD Athlon 850Mhz/768MB DDR, with 9.10 and a Dell Dimension 1100, Intel 2.8GHz, 1GB DDR Ram. 9.10).

Hi
is there anyone with a solution to this problem?

DragonDon schrieb:
> Same problem here. I get this on two vastly different machines (AMD
> Athlon 850Mhz/768MB DDR, with 9.10 and a Dell Dimension 1100, Intel
> 2.8GHz, 1GB DDR Ram. 9.10).
>
>

lunix (hofmann98765) wrote :

Same problem here. I removed both at-spi entries from startup programs without any effects.

selimhanov (selimhanov) wrote :

They recommend to disable Assistive Technologies (System / Preferences / Assistive Technologies), that's what I did... restarted, and it seems the problem's gone away.

David Baucum (maxolasersquad) wrote :

I'm getting the same on both my home computer and my work PC.

zenith (karlcron) wrote :

I'm having the same problem... Disabling assistive technologies doesn't help

I'm running Ubuntu Karmic on a dell laptop (64-bit cpu)

randomubuntuguy (john4lists) wrote :

i'm using netbook-remix on karmic and noticed this registry wrapper fails to shutdown... I did at some point try to get orca working to read things to me, but never got it stable. I also enabled a few of the click features mentioned above and turned them off as they were not very useful for me.
  I haven't tried to systematically deduce the relationship between accessibility features and this program not shutting down.
   It seems a reasonable a place to start.

Bruno Girin (brunogirin) wrote :

I can confirm this bug on Lucid beta 2 (with latest updates as of 20th April 2010).

Changed in at-spi (Ubuntu):
status: New → Confirmed
Charlie Kravetz (charlie-tca) wrote :

Thanks for confirming this report. Also, a big thank you for sending it upstream. This bug has been reported to the developers of the software. You can track it and make comments at: https://bugzilla.gnome.org/show_bug.cgi?id=616261

Changed in at-spi (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in at-spi:
status: Unknown → New
John Doe (gehkacken02) wrote :

same problem in 10.04.

+1 for 10.04

I solved this trouble removing the at-spi package.

tags: added: karmic lucid
Changed in at-spi:
importance: Unknown → Medium
Robert Adams (pillage) on 2010-10-03
Changed in at-spi (Ubuntu):
status: Triaged → Confirmed
Changed in at-spi (Ubuntu):
status: Confirmed → Triaged
tags: added: a11y
Kim Iskov (kimiskov) wrote :

I'm using Ubuntu 10.10. The problem is still there after 2 years. I only get this problem after hibernating.

Leon Vitanos (leon-mellori) wrote :

Also affects me.. Every time i shutdown or restart the computer it says that it still running.. Ubuntu must fix it!

Huubb (huub-van-baal) wrote :

It might be a coincidence. Ënvironment is 11.04, fully updated. Every occasion when I do start indicator-datetime-preference (setting systems time / date) this application hangs (see bug report # 751175). When indicator-datetime-prefence hangs and I try to reboot or shutdown the system I get the error related to this bugreport. Pop-up windows is shown with message that an application is still runnning (I do assume indicator-datetime-preferences) AT SPI REGISTRY.

Whenever I killed the indicator-datetime-preferences process not only the application runs fine when retried to execute, but also the AT SPI REGISTRY error doesn't appear and reboot/shutdown goes fine.

Slava (dbazim) wrote :

Have the same problem. I always use Eclipse and always have to confirm shutdown as SPI-REGISTRY hungs. But if I leave laptop for a 10 min it shutdowns anyway.
One more note. In case I mount removable drive while Save As dialog is active. The application that opened the dialog hungs causing heavy processor load for about 1 min. The at-spi-registry is in top list.
3755 slava 20 0 117m 45m 17m R 78 2.4 1:58.78 gedit
 2145 slava 20 0 16120 5592 4352 S 24 0.3 1:30.53 at-spi-registry
 1495 root 20 0 101m 37m 18m S 9 2.0 5:19.85 Xorg

Changed in at-spi:
status: New → Expired
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/477978

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.