Ubuntu

at-spi-registryd assert failure: ERROR:orbit-object.c:149:do_unref: assertion failed: (robj->refs < ORBIT_REFCOUNT_MAX && robj->refs > 0)

Reported by las on 2009-09-18
210
This bug affects 37 people
Affects Status Importance Assigned to Milestone
at-spi
In Progress
Medium
at-spi (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: at-spi

this happens every time i log on to karmic.

ProblemType: Crash
Architecture: i386
AssertionMessage: ERROR:orbit-object.c:149:do_unref: assertion failed: (robj->refs < ORBIT_REFCOUNT_MAX && robj->refs > 0)
CrashCounter: 1
Date: Fri Sep 18 09:38:08 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/lib/at-spi/at-spi-registryd
NonfreeKernelModules: nvidia
Package: at-spi 1.27.92-0ubuntu2
ProcCmdline: /usr/lib/at-spi/at-spi-registryd
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.34-generic
Signal: 6
SourcePackage: at-spi
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/tls/i686/cmov/libc.so.6
 abort () from /lib/tls/i686/cmov/libc.so.6
 g_assertion_message () from /usr/lib/libglib-2.0.so.0
 g_assertion_message_expr () from /usr/lib/libglib-2.0.so.0
Title: at-spi-registryd assert failure: ERROR:orbit-object.c:149:do_unref: assertion failed: (robj->refs < ORBIT_REFCOUNT_MAX && robj->refs > 0)
Uname: Linux 2.6.31-10-generic i686
UserGroups: adm admin cdrom dialout dip fax fuse lpadmin netdev plugdev sambashare scanner tape vboxusers

Related branches

las (bandara-ls) wrote :

StacktraceTop:__kernel_vsyscall ()
*__GI_raise (sig=6)
*__GI_abort () at abort.c:92
IA__g_assertion_message (domain=0x0,
IA__g_assertion_message_expr (domain=0x0,

Changed in at-spi (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package at-spi - 1.28.1-0ubuntu1

---------------
at-spi (1.28.1-0ubuntu1) karmic; urgency=low

  * New upstream release
    - Bugfixes: #578334. Fixed the crash problem. (LP: #432252)
    - Translation update.

 -- Luke Yelavich <email address hidden> Mon, 19 Oct 2009 16:15:43 +1100

Changed in at-spi (Ubuntu):
status: New → Fix Released
C de-Avillez (hggdh2) on 2009-11-12
visibility: private → public

I hitted this problem today with karmic updated.

Changed in at-spi (Ubuntu):
status: Fix Released → Confirmed
Tim Starling (tstarling) wrote :

I am running at-spi 1.28.1-0ubuntu1 and it still hits this exact assertion.

Steffen Röcker (sroecker) wrote :

Just happened on lucid with at-spi 1.29.6-0ubuntu1.

las (bandara-ls) wrote :

confirm with lucid too.

tgpraveen (tgpraveen89) wrote :

happened on lucid

brauliobh (brauliomc) wrote :

Yeap !

Hi!
I don't know why I got a msg about this bug.

I don't have Nvidia installed. I am now using Lucid and checked to see
if I had
any Nvidia files installed and the only one is:

nvidia-common 02.23.

"Find obsolete NVIDIA drivers

This package will find obsolete NVIDIA drivers in use,
detect the hardware and recommend the most appropriate
driver."

Might it have been a "fix" in Lucid?

I don't know if this helps. No response to this msg necessary.

On 05/05/2010 12:10 AM, brauliobh wrote:
> Yeap !
>
>

Changed in at-spi:
importance: Unknown → Medium
status: Unknown → In Progress
Changed in at-spi (Ubuntu):
status: Confirmed → Triaged
tags: added: a11y
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.