at-spi-registryd crashes in constructor when dpy=0x0 (no DISPLAY set?)

Bug #279170 reported by santeri
14
Affects Status Importance Assigned to Milestone
at-spi
Fix Released
Medium
at-spi (Ubuntu)
Medium
Luke Yelavich

Bug Description

Binary package hint: at-spi

something crashed 8.10 beta livecd

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/lib/at-spi/at-spi-registryd
Package: at-spi 1.24.0-0ubuntu2
ProcAttrCurrent: unconfined
ProcCmdline: /usr/lib/at-spi/at-spi-registryd
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: at-spi
StacktraceTop:
 XQueryExtension () from /usr/lib/libX11.so.6
 XInitExtension () from /usr/lib/libX11.so.6
 XextAddDisplay () from /usr/lib/libXext.so.6
 ?? () from /usr/lib/libXevie.so.1
 XevieStart () from /usr/lib/libXevie.so.1
Title: at-spi-registryd crashed with SIGSEGV in XQueryExtension()
Uname: Linux 2.6.27-4-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Revision history for this message
santeri (santeri) wrote :
Revision history for this message
Apport retracing service (apport) wrote : Symbolic stack trace

StacktraceTop:XReadBitmapFileData (filename=0x0, width=0xb7273e40, height=0x0, data=0xb7f317c4, x_hot=0xbfc30b24,
UCSConvertCase (code=0, lower=0x0, upper=0x0) at ../../src/KeyBind.c:579
XextAddDisplay (extinfo=0xb7ea2e7c, dpy=0x0, ext_name=0xb7ea1cb4 "XEVIE", hooks=0xb7ea2e40, nevents=0,
find_display (dpy=0x0) at ../../src/Xevie.c:71
XevieStart (dpy=0x0) at ../../src/Xevie.c:129

Revision history for this message
Apport retracing service (apport) wrote : Symbolic threaded stack trace
Changed in at-spi:
importance: Undecided → Medium
Revision history for this message
Alexander Sack (asac) wrote :

problem is that dpy=0x0 ... will attach first patch to make registryd to not start when no DISPLAY env is found.

Changed in at-spi:
status: New → Triaged
Revision history for this message
Alexander Sack (asac) wrote :
Revision history for this message
Sebastien Bacher (seb128) wrote :

luke, could you figure if that's an issue and should be sent upstream or if the bug should be closed?

Changed in at-spi (Ubuntu):
assignee: nobody → Luke Yelavich (themuso)
Revision history for this message
Luke Yelavich (themuso) wrote :

Yes, this is still an issue. I can cause at-spi-registryd to segfault when run from a text console, something it should not do. Will take this upstream and propose Alexander's patch, but there is probably a better solution.

Changed in at-spi:
status: Unknown → New
Revision history for this message
Sebastien Bacher (seb128) wrote :

Upstream approved the change, can we get it uploaded?

Revision history for this message
Luke Yelavich (themuso) wrote : Re: [Bug 279170] Re: at-spi-registryd crashes in constructor when dpy=0x0 (no DISPLAY set?)

Right, thought there was going to be another stable release, will take care of that today.

 affects ubuntu/at-spi
 status inprogress

Changed in at-spi (Ubuntu):
status: Triaged → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package at-spi - 1.31.1-0ubuntu2

---------------
at-spi (1.31.1-0ubuntu2) maverick; urgency=low

  * debian/patches/02_lp279170_do_not_start_with_no_DISPLAY.patch: Patch
    against the registry daemon to only start if DISPLAY is set, patch sent
    upstream, thanks to Alexander Sack for the patch (LP: #279170)
 -- Luke Yelavich <email address hidden> Fri, 13 Aug 2010 08:25:40 +1000

Changed in at-spi (Ubuntu):
status: In Progress → Fix Released
Changed in at-spi:
importance: Unknown → Medium
Changed in at-spi:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.