undefined modules in loaded-by-default modules

Bug #541747 reported by James Troup on 2010-03-19
58
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Gemeinschaft (by Amooma)
Invalid
Low
Unassigned
asterisk (Debian)
New
Undecided
Unassigned
asterisk (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: asterisk

On a fresh lucid install, after installing asterisk, I see the following in the 'messages' log:

[Mar 19 08:53:48] WARNING[26597] loader.c: Error loading module 'cdr_adaptive_odbc.so': /usr/lib/asterisk/modules/cdr_adaptive_odbc.so: undefined symbol: ast_odbc_request_obj
[Mar 19 08:53:49] WARNING[26597] loader.c: Error loading module 'chan_gtalk.so': /usr/lib/asterisk/modules/chan_gtalk.so: undefined symbol: ast_aji_get_client
[Mar 19 08:53:49] WARNING[26597] loader.c: Error loading module 'res_agi.so': /usr/lib/asterisk/modules/res_agi.so: undefined symbol: ast_speech_start

Changed in gemeinschaft-amooma:
importance: Undecided → Low
status: New → Invalid
Paul Belanger (pabelanger) wrote :

What version of Asterisk? Distribution?

Changed in asterisk (Ubuntu):
status: New → Incomplete
Frederik Kriewitz (freddy436) wrote :

Occures on Version 1:1.8.3.3-1ubuntu1

[Jul 28 10:39:32] WARNING[4817] loader.c: Error loading module 'app_stack.so': /usr/lib/asterisk/modules/app_stack.so: undefined symbol: ast_agi_unregister
[Jul 28 10:39:32] WARNING[4817] loader.c: Error loading module 'pbx_dundi.so': /usr/lib/asterisk/modules/pbx_dundi.so: undefined symbol: ast_check_signature_bin
[Jul 28 10:39:32] WARNING[4817] loader.c: Error loading module 'app_speech_utils.so': /usr/lib/asterisk/modules/app_speech_utils.so: undefined symbol: ast_speech_start
[Jul 28 10:39:32] WARNING[4817] loader.c: Error loading module 'res_config_odbc.so': /usr/lib/asterisk/modules/res_config_odbc.so: undefined symbol: ast_odbc_clear_cache
[Jul 28 10:39:32] WARNING[4817] loader.c: Error loading module 'res_calendar_icalendar.so': /usr/lib/asterisk/modules/res_calendar_icalendar.so: undefined symbol: ast_calendar_event_container_alloc
[Jul 28 10:39:32] WARNING[4817] loader.c: Error loading module 'res_fax_spandsp.so': /usr/lib/asterisk/modules/res_fax_spandsp.so: undefined symbol: ast_fax_tech_register
[Jul 28 10:39:32] WARNING[4817] loader.c: Error loading module 'cdr_odbc.so': /usr/lib/asterisk/modules/cdr_odbc.so: undefined symbol: SQLRowCount
[Jul 28 10:39:32] WARNING[4817] loader.c: Error loading module 'app_queue.so': /usr/lib/asterisk/modules/app_queue.so: undefined symbol: ast_monitor_start
[Jul 28 10:39:32] WARNING[4817] loader.c: Error loading module 'res_calendar_ews.so': /usr/lib/asterisk/modules/res_calendar_ews.so: undefined symbol: ast_calendar_event_container_alloc
[Jul 28 10:39:32] WARNING[4817] loader.c: Error loading module 'cdr_adaptive_odbc.so': /usr/lib/asterisk/modules/cdr_adaptive_odbc.so: undefined symbol: SQLFetch
[Jul 28 10:39:32] WARNING[4817] loader.c: Error loading module 'func_odbc.so': /usr/lib/asterisk/modules/func_odbc.so: undefined symbol: SQLFetch
[Jul 28 10:39:32] WARNING[4817] loader.c: Error loading module 'res_agi.so': /usr/lib/asterisk/modules/res_agi.so: undefined symbol: ast_speech_start
[Jul 28 10:39:32] WARNING[4817] loader.c: Error loading module 'app_voicemail.so': /usr/lib/asterisk/modules/app_voicemail.so: undefined symbol: ast_smdi_mwi_message_destroy

Fyodor Kupchik (ferimy) wrote :

Ubuntu 11.10
---------------------------------------------------------------------
Package: asterisk
New: yes
State: installed
Automatically installed: no
Version: 1:1.8.4.4~dfsg-2ubuntu1
Priority: optional
Section: universe/comm
--------------------------------------------------------------------

Fresh asterisk installation.

Ali Nebi (anebi) wrote :

I just did a fresh installation of ubuntu server 11.10 and I experience the same problem. I am attached asterisk log from my server.

Please reopen the issue as this is a real problem.

I see that issue is fixed from asterisk side. For reference:

https://issues.asterisk.org/jira/browse/ASTERISK-16425?page=com.atlassian.jira.plugin.system.issuetabpanels%3Achangehistory-tabpanel

https://issues.asterisk.org/view.php?id=17707

Please apply necessary patches so we can get solved this problem.

We need a fix for this ASAP.

Best regards,
Ali

Changed in asterisk (Ubuntu):
status: Incomplete → New
Changed in asterisk (Ubuntu):
importance: Undecided → High
Mohamed Alaa (m-alaa8) on 2012-03-01
Changed in asterisk (Ubuntu):
status: New → Invalid
James Troup (elmo) on 2012-03-02
Changed in asterisk (Ubuntu):
status: Invalid → Confirmed
Paul Belanger (pabelanger) wrote :

This is different then https://issues.asterisk.org/jira/browse/ASTERISK-16425, as the patches from it are already merged into asterisk 1.8.4.4.

Still working on finding the actual problem.

silviop (far5893) wrote :
Download full text (19.1 KiB)

app_stack is necessary to make work asterisk and freepbx but can be loaded using command line after asterisk start

asterisk*CLI> module load app_stack.so
Loaded app_stack.so
asterisk*CLI> module show
Module Description Use Count
res_adsi ADSI Resource 0
pbx_config.so Text Extension Configuration 0
chan_local.so Local Proxy Channel (Note: used internal 0
res_stun_monitor.so STUN Network Monitor 0
res_smdi.so Simplified Message Desk Interface (SMDI) 0
res_srtp.so Secure RTP (SRTP) 0
res_ael_share.so share-able code for AEL 0
res_speech.so Generic Speech Recognition API 0
res_calendar.so Asterisk Calendar integration 1
res_odbc.so ODBC resource 0
res_fax.so Generic FAX Applications 1
res_jabber.so AJI - Asterisk Jabber Interface 0
res_crypto.so Cryptographic Digital Signatures 0
res_monitor.so Call Monitoring Resource 0
format_wav.so Microsoft WAV/WAV16 format (8kHz/16kHz S 0
format_pcm.so Raw/Sun uLaw/ALaw 8KHz (PCM,PCMA,AU), G. 0
format_mp3.so MP3 format [Any rate but 8000hz mono is 0
res_musiconhold.so Music On Hold Resource 0
cdr_manager.so Asterisk Manager Interface CDR Backend 0
bridge_softmix.so Multi-party software based channel mixin 0
pbx_loopback.so Loopback Switch 0
res_config_pgsql.so PostgreSQL RealTime Configuration Driver 0
app_nbscat.so Silly NBS Stream Application 0
codec_ulaw.so mu-Law Coder/Decoder 0
app_waitforsilence.so Wait For Silence 0
func_lock.so Dialplan mutexes 0
res_timing_timerfd.so Timerfd Timing Interface 1
pbx_lua.so Lua PBX Switch 0
app_sendtext.so Send Text Applications 0
func_strings.so String handling dialplan functions 0
app_channelredirect.so Redirects a given channel to a dialplan 0
res_calendar_caldav.so Asterisk CalDAV Calendar Integration 0
res_clioriginate.so Call origination and redirection from th 0
func_iconv.so Charset conversions 0
res_config_ldap.so LDAP realtime interface 0
func_pitch...

uvi (vladimir-umnov) wrote :

Ubuntu 13.10 x64:

[Dec 3 15:48:09] WARNING[3794] loader.c: Error loading module 'res_agi.so': /usr/lib/asterisk/modules/res_agi.so: undefined symbol
: ast_speech_change
[Dec 3 15:48:09] WARNING[3794] loader.c: Error loading module 'res_calendar_exchange.so': /usr/lib/asterisk/modules/res_calendar_e
xchange.so: undefined symbol: ast_calendar_register
[Dec 3 15:48:09] WARNING[3794] loader.c: Error loading module 'res_calendar_icalendar.so': /usr/lib/asterisk/modules/res_calendar_
icalendar.so: undefined symbol: ast_calendar_register
[Dec 3 15:48:09] WARNING[3794] loader.c: Error loading module 'app_voicemail.so': /usr/lib/asterisk/modules/app_voicemail.so: unde
fined symbol: ast_smdi_mwi_set
[Dec 3 15:48:09] WARNING[3794] loader.c: Error loading module 'chan_gtalk.so': /usr/lib/asterisk/modules/chan_gtalk.so: undefined
symbol: ast_aji_buddy_destroy
[Dec 3 15:48:09] WARNING[3794] loader.c: Error loading module 'pbx_ael.so': /usr/lib/asterisk/modules/pbx_ael.so: undefined symbol: ael2_parse
[Dec 3 15:48:09] WARNING[3794] loader.c: Error loading module 'res_calendar_caldav.so': /usr/lib/asterisk/modules/res_calendar_caldav.so: undefined symbol: ast_calendar_event_container_alloc
[Dec 3 15:48:09] WARNING[3794] loader.c: Error loading module 'app_queue.so': /usr/lib/asterisk/modules/app_queue.so: undefined symbol: ast_monitor_start
[Dec 3 15:48:09] WARNING[3794] loader.c: Error loading module 'app_stack.so': /usr/lib/asterisk/modules/app_stack.so: undefined symbol: ast_agi_unregister
[Dec 3 15:48:09] WARNING[3794] loader.c: Error loading module 'chan_jingle.so': /usr/lib/asterisk/modules/chan_jingle.so: undefined symbol: ast_aji_buddy_destroy

Dimitri John Ledkov (xnox) wrote :

On cosmic, after fresh install of asterisk, there are no undefined symbols. Some modules failed to load due to lack of configuration files. But otherwise there are no underlinked modules it seems.

Changed in asterisk (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.