broken DTMF handling in asterisk 1.4

Bug #416762 reported by James Troup on 2009-08-21
This bug affects 1 person
Affects Status Importance Assigned to Milestone
asterisk (Ubuntu)

Bug Description

Binary package hint: asterisk

The DTMF handling in Asterisk 1.4 (<< 1.4.23) is quite badly broken.
Even in normal usage, we're able to reliably reproduce both
duplication and out-of-order problems when using out-of-band DTMF.

This bug is known upstream and has been fixed in two parts, one in
1.4.18 and one in 1.4.23. I've attached a debdiff of the two patches
from upstream backported to hardy's asterisk. We're running with
these patches in a local package in production and it fixes DTMF for


To reproduce: dial a service[1] that will playback DTMF digits to you
and dial strings of DTMF fast, e.g.


Without this patch, you may see duplicated digits or out of order

Regression potential: should be limited; these are upstream fixes that
are already in later versions that have been released since Feb 2008
and Dec 2008 respectively without problems.


[1] e.g. using another asterisk server (with working DTMF!)

| [testing]
| exten => _NXXNXXXXXX,1,Answer()
| exten => _NXXNXXXXXX,n,Wait(1)
| exten => _NXXNXXXXXX,n,Set(TIMEOUT(digit)=30)
| exten => _NXXNXXXXXX,n,Set(TIMEOUT(response)=30)
| exten => _NXXNXXXXXX,n,Playback(beep)
| exten => _NXXNXXXXXX,n,Read(garbage,,255)
| exten => _NXXNXXXXXX,n,SayDigits(${garbage})
| exten => _NXXNXXXXXX,n,Hangup()

James Troup (elmo) wrote :

As you said it's fixed upstream, I guess it's now fixed in 1.6 in lucid and karmic. Let's open a task for hardy.
I'm subscribing ~ubuntu-sru for getting their feed-back.

Changed in asterisk (Ubuntu):
importance: Undecided → Low
status: New → Fix Released
Changed in asterisk (Ubuntu Hardy):
status: New → Confirmed
Rolf Leggewie (r0lf) wrote :

Hardy has seen the end of its life and is no longer receiving any updates. Marking the Hardy task for this ticket as "Won't Fix".

Changed in asterisk (Ubuntu Hardy):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers