Asterisk crashes with default install because of pjsip

Bug #1458323 reported by Hasse Hagen Johansen on 2015-05-24
170
This bug affects 31 people
Affects Status Importance Assigned to Milestone
asterisk (Ubuntu)
High
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
High
Unassigned

Bug Description

Hi

I have just upgraded to Ubuntu 15.04 where I got a new Asterisk. First I thought I neede to convert my sip.conf to pjsip.conf. But troubles persist - even after making af copy of my configuration and reinstalling asterisk,asterisk-modules,asterisk-config etc (making sure /etc/asterisk was empty before reinstalling). So a clean install also fails and asterisk is quite unuseable right now

Is seems after starting asterisk(with systemctl start asterisk) and then doing an "asterisk -r" i get this:

Connected to Asterisk 13.1.0~dfsg-1ubuntu2 currently running on pris (pid = 11110)
SIP channel loading...
[May 24 14:18:14] ERROR[11110]: astobj2.c:116 INTERNAL_OBJ: user_data is NULL
[May 24 14:18:14] ERROR[11110]: astobj2.c:116 INTERNAL_OBJ: user_data is NULL
[May 24 14:18:14] ERROR[11110]: astobj2.c:116 INTERNAL_OBJ: user_data is NULL
[May 24 14:18:14] ERROR[11110]: res_pjsip_sdp_rtp.c:1329 load_module: Unable to register SDP handler for audio stream type
[May 24 14:18:14] ERROR[11110]: astobj2.c:116 INTERNAL_OBJ: user_data is NULL
[May 24 14:18:14] ERROR[11110]: astobj2.c:116 INTERNAL_OBJ: user_data is NULL
pris*CLI>
Disconnected from Asterisk server
Asterisk cleanly ending (0).
Executing last minute cleanups

blacklisting res_pjsip.so in /etc/asterisk/modules.conf makes asterisk not crash

Description: Ubuntu 15.04
Release: 15.04
asterisk:
  Installed: 1:13.1.0~dfsg-1ubuntu2
  Candidate: 1:13.1.0~dfsg-1ubuntu2
  Version table:
 *** 1:13.1.0~dfsg-1ubuntu2 0
        500 http://dk.archive.ubuntu.com/ubuntu/ vivid/universe amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: asterisk 1:13.1.0~dfsg-1ubuntu2
ProcVersionSignature: Ubuntu 3.19.0-18.18-generic 3.19.6
Uname: Linux 3.19.0-18-generic x86_64
ApportVersion: 2.17.2-0ubuntu1.1
Architecture: amd64
Date: Sun May 24 14:23:26 2015
InstallationDate: Installed on 2011-06-24 (1429 days ago)
InstallationMedia: Ubuntu-Server 11.04 "Natty Narwhal" - Release amd64 (20110426)
SourcePackage: asterisk
UpgradeStatus: Upgraded to vivid on 2015-05-23 (0 days ago)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in asterisk (Ubuntu):
status: New → Confirmed
Changed in asterisk (Ubuntu):
importance: Undecided → Medium
hackeron (hackeron) wrote :
Download full text (3.7 KiB)

I noticed after a recent apt-get dist-upgrade asterisk stopped working. Thank you for the workaround, I added noload => res_pjsip.so to /etc/asterisk/modules.conf and now it starts again. There are still a bunch of warnings in the log however, e.g.:

[Jun 24 09:24:06] WARNING[24844] loader.c: Error loading module 'res_pjsip_refer.so': /usr/lib/asterisk/modules/res_pjsip_refer.so: undefined symbol: ast_copy_pj_str
[Jun 24 09:24:06] WARNING[24844] loader.c: Module 'res_pjsip_refer.so' could not be loaded.
[Jun 24 09:24:06] WARNING[24844] loader.c: Error loading module 'res_pjsip_transport_websocket.so': /usr/lib/asterisk/modules/res_pjsip_transport_websocket.so: undefined symbol: ast_sip_create_serializer
[Jun 24 09:24:06] WARNING[24844] loader.c: Module 'res_pjsip_transport_websocket.so' could not be loaded.
[Jun 24 09:24:06] WARNING[24844] loader.c: Error loading module 'res_pjsip_acl.so': /usr/lib/asterisk/modules/res_pjsip_acl.so: undefined symbol: ast_copy_pj_str
[Jun 24 09:24:06] WARNING[24844] loader.c: Module 'res_pjsip_acl.so' could not be loaded.
[Jun 24 09:24:06] WARNING[24844] loader.c: Error loading module 'res_pjsip_pidf_digium_body_supplement.so': /usr/lib/asterisk/modules/res_pjsip_pidf_digium_body_supplement.so: undefined symbol: ast_sip_presence_xml_create_node
[Jun 24 09:24:06] WARNING[24844] loader.c: Module 'res_pjsip_pidf_digium_body_supplement.so' could not be loaded.
[Jun 24 09:24:06] WARNING[24844] loader.c: Error loading module 'res_pjsip_messaging.so': /usr/lib/asterisk/modules/res_pjsip_messaging.so: undefined symbol: ast_sip_default_outbound_endpoint
[Jun 24 09:24:06] WARNING[24844] loader.c: Module 'res_pjsip_messaging.so' could not be loaded.
[Jun 24 09:24:06] WARNING[24844] loader.c: Error loading module 'res_pjsip_authenticator_digest.so': /usr/lib/asterisk/modules/res_pjsip_authenticator_digest.so: undefined symbol: ast_sip_unregister_authenticator
[Jun 24 09:24:06] WARNING[24844] loader.c: Module 'res_pjsip_authenticator_digest.so' could not be loaded.
[Jun 24 09:24:06] WARNING[24844] loader.c: Error loading module 'res_pjsip_registrar.so': /usr/lib/asterisk/modules/res_pjsip_registrar.so: undefined symbol: ast_sip_report_mem_limit
[Jun 24 09:24:06] WARNING[24844] loader.c: Module 'res_pjsip_registrar.so' could not be loaded.
[Jun 24 09:24:06] WARNING[24844] loader.c: Error loading module 'res_pjsip_multihomed.so': /usr/lib/asterisk/modules/res_pjsip_multihomed.so: undefined symbol: ast_sip_get_pjsip_endpoint
[Jun 24 09:24:06] WARNING[24844] loader.c: Module 'res_pjsip_multihomed.so' could not be loaded.
[Jun 24 09:24:06] WARNING[24844] loader.c: Error loading module 'res_pjsip_endpoint_identifier_anonymous.so': /usr/lib/asterisk/modules/res_pjsip_endpoint_identifier_anonymous.so: undefined symbol: ast_copy_pj_str
[Jun 24 09:24:06] WARNING[24844] loader.c: Module 'res_pjsip_endpoint_identifier_anonymous.so' could not be loaded.
[Jun 24 09:24:06] WARNING[24844] loader.c: Error loading module 'res_pjsip_phoneprov_provider.so': /usr/lib/asterisk/modules/res_pjsip_phoneprov_provider.so: undefined symbol: ast_sip_get_pjsip_endpoint
[Jun 24 09:24:06] WARNING[24844] loader.c: Module 'res_pjsip_phoneprov_provider.so' ...

Read more...

This happens to me, too. Blacklisting the module does nothing. Reinstalling with a clean config does nothing.

I have had no choice but to roll back the whole system upgrade to a previous backup.

It is a shame that probably the most important PBX is broken on probably the most important Linux distro.

Robie Basak (racb) wrote :

Setting Importance to High as this seems to be quite important in not breaking this, but I need to spend my time working on packages in main and this package is in universe. Is there anyone who can help with looking after asterisk in Ubuntu?

Changed in asterisk (Ubuntu):
importance: Medium → High
Michael Paddon (micfael) wrote :

This can be trivially fixed by adding

noload => res_pjsip.so

in the modules section of etc/asterisk/modules.conf

god (humper) wrote :

Blacklisting res_pjsip is by no mean "fix" - the chan_sip is legacy stack, the pjsip is the one recommended to use. If asterisk in ubuntu is so broken that pjsip is not working properly than it's good enough reason to switch distro.

I think the importance got to be set to critical.

Robie Basak (racb) wrote :

> I think the importance got to be set to critical.

It makes little difference what the Importance is set to. Please, help fix it.

god (humper) wrote :

A good first step would be upgrading to latest upstream LTS release which is 13.6.0
Chances are - it's already fixed there.

pcouderc (pierre-a) wrote :

Same problem 6 months later on 16.04LTS server.
After 3 days asterisk down, I have switched back to Debian ; install without any problem on jessie.

Early Bird (bugtrackers) wrote :

I have filed a request for a fresh Asterisk LTS import in #1596405 because of an unrelated bug. However I also can confirm this issue.

Sean Sosik-Hamor (sciri) wrote :

Confirmed in 16.04. All my logs are in duplicate Bug #1631101.

Simon Waite (opless) wrote :

How annoying this bug is still here in Xenial ~18 months on.

Confirmed.

David Walters (dwalters) wrote :

This still appears to be an issue. I have installed Asterisk on Ubuntu 16.04.1 on a number of systems, and all but one had the same issue. noload => res_pjsip.so allows me to run Asterisk, unfortunately I would like to work with pjsip.

All the systems that failed are a newer VMWare virtual machines, the one that works is on an older VMware machine. Thoughts?

Kseniya Blashchuk (ksyblast) wrote :

Still no news? Come on... chan_sip is a community supported module and chan_pjsip is a core module, so moving to pjsip is really important I would say...

I fix the problem in this

*ppa:sapian/asterisk*

On Thu, Apr 6, 2017 at 2:31 AM Kseniya Blashchuk <email address hidden>
wrote:

> Still no news? Come on... chan_sip is a community supported module and
> chan_pjsip is a core module, so moving to pjsip is really important I
> would say...
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1458323
>
> Title:
> Asterisk crashes with default install because of pjsip
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/asterisk/+bug/1458323/+subscriptions
>
--

--

[image: --]
Sebastian Rojo
[image: http://]about.me/arpagon
 <http://about.me/arpagon?promo=email_sig>
 CTO
SAPIAN SAS
Digium-Certified Asterisk Professional (#1175) - Pythonista - Linux enthusiast

Tel:+57(4)4444084 ext 217sip:<email address hidden>
skype://pbx.sapian.com.co ext 217
<email address hidden>
http://www.sapian.com.co

DISCLAIMER:
Toda la información y los adjuntos en este mensaje es confidencial y
privilegiada. Solamente los destinatarios están autorizados para usar
esta información. Las transmisiones de correo electrónicos no están
garantizadas y no son seguras o libres de errores y la empresa no
acepta responsabilidad por error u omisiones. La empresa no acepta
ninguna responsabilidad con respecto a cualquier comunicación que haya
sido emitida incumpliendo nuestra política de correo electrónico.
All information in this message and attachments is confidential and
may be legally privileged. Only intended recipients are authorized to
use it. E-mail transmissions are not guaranteed to be secure or error
free and sender does not accept liability for such errors or
omissions. The company will not accept any liability in respect of
such communication that violates our e-mail policy.

Stefan Regnery (llenny) wrote :

Adding these modules:

load => res_pjsip.so
load => res_pjsip_session.so
load => chan_pjsip.so

right after the [module] section in modules.conf is working for me.

François Marier (fmarier) wrote :

This appears to be fixed in Ubuntu 18.04.

marking newer releases Fix Relased per Former comment.

Changed in asterisk (Ubuntu Xenial):
status: New → Confirmed
Changed in asterisk (Ubuntu Bionic):
status: New → Fix Released
Changed in asterisk (Ubuntu Cosmic):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers