upgrade from lucid to precise removes most of my gsm sound files

Bug #1044351 reported by Nick Moffitt on 2012-08-31
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fix Released
asterisk (Ubuntu)

Bug Description

One of our PBXes uses the files in /usr/share/asterisk/*.gsm to provide user feedback. When we upgraded from lucid to precise, many of these files simply vanished!

 -- Executing [s@macro-agentauth:2] BackGround("SIP/gubble-00000242", "please-enter-the&number&astcc-followed-by-the-pound-key") in new stack
[Aug 31 09:59:44] WARNING[25369]: file.c:663 ast_openstream_full: File please-enter-the does not exist in any format
[Aug 31 09:59:44] WARNING[25369]: file.c:958 ast_streamfile: Unable to open please-enter-the (format 0x200008 (alaw|h264)): No such file or directory
[Aug 31 09:59:44] WARNING[25369]: pbx.c:9781 pbx_builtin_background: ast_streamfile failed on SIP/gubble-00000242 for please-enter-the&number&astcc-followed-by-the-pound-key

As a result, the users heard silence and didn't know what to do. I worked around this by grabbing /usr/share/asterisk/sounds/please-enter-the.gsm (and other files) from another system's lucid asterisk install and simply copying them into place on the precise server.

What package owns these files, now? How do I keep using packaged versions of them? I can't seem to find an appropriate package in precise that would hold these.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in asterisk (Ubuntu):
status: New → Confirmed
Paul Belanger (pabelanger) wrote :

$ sudo apt-get install asterisk-core-sounds-en-gsm

Paul Belanger:
> $ sudo apt-get install asterisk-core-sounds-en-gsm

        $ dpkg -L asterisk-core-sounds-en-gsm | grep -c please-enter-the

This bug is *not* about asterisk-core-sounds-en-gsm. There was a
package for a while named asterisk-sounds-extra that had these files,
but that does not appear to be in precise.

Nick Moffitt

Paul Belanger (pabelanger) wrote :

You didn't reference asterisk-sounds-extra within your original post, my mistake for missing it. As for the issue, asterisk-sounds-extra looks to have been removed because an incompatible license. Looks like we are still waiting for Digium to fix it.


Changed in asterisk:
status: Unknown → New
Changed in asterisk:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.