Ubuntu

The mysql add-on module is out of sync with asterisk

Reported by Raimund Sacherer on 2010-04-11
132
This bug affects 23 people
Affects Status Importance Assigned to Milestone
asterisk-addons (Ubuntu)
Undecided
Unassigned

Bug Description

The mysql add-on is version 1.6.2.0-1 versus the asterisk with version 1:1.6.2.2-1ubuntu2.

It tells me that the module is not compiled to the source asterisk was built from and refuses to load the module!

please update the add-on to 1.6.2.2 also!

best
ray

Not fixed in 10.04 release! Still have to dpkg-buildpackage to get working mysql realtime support. Let me know if I can help solving this.

Raimund Sacherer (hatrix) wrote :

*sigh* I resorted to ODBC because I do not like building the package anew on upgrades ...

Peter Halicky (peto-halicky) wrote :

asterisk-mobile (and chan_mobile.so) has the same problem...

homesvr*CLI> module load chan_mobile.so
Unable to load module chan_mobile.so
Command 'module load chan_mobile.so' failed.
[May 4 16:36:05] WARNING[23546]: loader.c:716 inspect_module: Module 'chan_mobile.so' was not compiled with the same compile-time options as this version of Asterisk.
[May 4 16:36:05] WARNING[23546]: loader.c:717 inspect_module: Module 'chan_mobile.so' will not be initialized as it may cause instability.
[May 4 16:36:05] WARNING[23546]: loader.c:800 load_resource: Module 'chan_mobile.so' could not be loaded.

jonaz__ (jonaz-86) wrote :

[May 4 20:03:51] WARNING[4238] loader.c: Module 'res_config_mysql.so' was not compiled with the same compile-time options as this version of Asterisk.
[May 4 20:03:51] WARNING[4238] loader.c: Module 'res_config_mysql.so' will not be initialized as it may cause instability.
[May 4 20:03:51] WARNING[4238] loader.c: Module 'res_config_mysql.so' could not be loaded.
[May 4 20:03:51] WARNING[4238] loader.c: Module 'app_addon_sql_mysql.so' was not compiled with the same compile-time options as this version of Asterisk.
[May 4 20:03:51] WARNING[4238] loader.c: Module 'app_addon_sql_mysql.so' will not be initialized as it may cause instability.
[May 4 20:03:51] WARNING[4238] loader.c: Module 'app_addon_sql_mysql.so' could not be loaded.

This is really a showstopper for me! if i would've known this i would never have upgraded :(

Raimund Sacherer (hatrix) wrote :

Jonaz__ you can configure ODBC, it's not that hard and works, this is what I am doing, or I am sure you can recompile the mysql module as well,

best

jonaz__ (jonaz-86) wrote :

i did build the modules myself now...

sudo aptitude install asterisk-dev subversion
svn co http://svn.digium.com/svn/asterisk-addons/branches/1.6.2/ asterisk-addons
cd asterisk-addons
./configure
make

then just locate the build .so files and move the ones youre having trouble loading to /usr/lib/asterisk/modules/

Hope this helps somebody until its solved!

Dmitry Ljautov (dljautov) wrote :

Hm, more Ubuntu way to recompile addons with asterisk:

1. I did on my book (same Ubuntu Lucid on asterisk server).
apt-get build-dep asterisk-mysql
apt-get -b source asterisk-mysql

2. And then I just copied .deb to asterisk server, and reinstall asterisk-mysql from rebuilded package.
aptitude purge asterisk-mysql
dpkg -i asterisk-mysql_1.6.2.0-1_amd64.deb

Worked for me.

mibus (mibus) wrote :

I can confirm that this also worked for me:

apt-get build-dep asterisk-mysql
apt-get -b source asterisk-mysql
dpkg -i asterisk-mysql_1.6.2.0-1_i386.deb

Allan Jensen (mobimobi) wrote :

I can confirm that the problem is also present with chan_mobile as previously stated.

hp-laptop*CLI> module load chan_mobile
Unable to load module chan_mobile
Command 'module load chan_mobile' failed.
[Jun 14 21:03:34] WARNING[8503]: loader.c:716 inspect_module: Module 'chan_mobile.so' was not compiled with the same compile-time options as this version of Asterisk.
[Jun 14 21:03:34] WARNING[8503]: loader.c:717 inspect_module: Module 'chan_mobile.so' will not be initialized as it may cause instability.
[Jun 14 21:03:34] WARNING[8503]: loader.c:800 load_resource: Module 'chan_mobile' could not be loaded.
hp-laptop*CLI>

It's fine that there is a way to compile asterisk and associated modules, but how does this affect the security updates being offered? I guess it's a recompile every time then?

Recompile the source package does not work for me. The configure script does not recognise my mysql_client installation. Can somebody trigger a new build for the asterisk-mysql package and the asterisk-chan-capi. The bug was first reported 4 months ago.

Changed in asterisk-addons (Ubuntu):
status: New → Confirmed

I had to install additionally libmysqlclient-dev on my Ubuntu 10.04 LTS (Lucid). After that configure recognised the mysql-client and produced the makefiles. The new built cdr_addon_mysql.so loads nicely into asterisk. But still I hope someone can fix all issues around asterisk addon and chan-capi.

Ky6uk (ky6uk) wrote :

[Aug 13 14:13:21] WARNING[3634]: loader.c:716 inspect_module: Module 'cdr_addon_mysql.so' was not compiled with the same compile-time options as this version of Asterisk.
[Aug 13 14:13:21] WARNING[3634]: loader.c:717 inspect_module: Module 'cdr_addon_mysql.so' will not be initialized as it may cause instability.
[Aug 13 14:13:21] WARNING[3634]: loader.c:800 load_resource: Module 'cdr_addon_mysql.so' could not be loaded.

This bug wil be fixed only next Ubuntu release?

Ky6uk (ky6uk) wrote :

And yes,

~# apt-get build-dep asterisk-mysql
~# apt-get -b source asterisk-mysql
~# dpkg -i asterisk-mysql_1.6.2.0-1_i386.deb

working fine.

Ryan Egesdahl (deriamis) wrote :

For those of you who don't want to do the rebuild, I have uploaded the package to my PPA.

Dear maintainers,

It's been 8 months now. Why do you torture us so? This bug isn't even a real bug... it's just that you guys haven't updated the repo with the right package.

Please... fix it.

The recompile worked for me too.

apt-get build-dep asterisk-mysql
apt-get -b source asterisk-mysql
dpkg -i asterisk-mysql_1.6.2.0-1_i386.deb

Note, the Asterisk MySQL module is not the only one with this problem. I also see these errors:

[Dec 9 00:28:33] WARNING[24623] loader.c: Error loading module 'cdr_adaptive_odbc.so': /usr/lib/asterisk/modules/cdr_adaptive_odbc.so: undefined symbol: ast_odbc_request_obj
[Dec 9 00:28:33] WARNING[24623] loader.c: Error loading module 'chan_gtalk.so': /usr/lib/asterisk/modules/chan_gtalk.so: undefined symbol: ast_aji_get_client
[Dec 9 00:28:33] WARNING[24623] loader.c: Error loading module 'app_speech_utils.so': /usr/lib/asterisk/modules/app_speech_utils.so: undefined symbol: ast_speech_start
[Dec 9 00:28:33] WARNING[24623] loader.c: Error loading module 'pbx_ael.so': /usr/lib/asterisk/modules/pbx_ael.so: undefined symbol: ast_compile_ael2

[...]

[Dec 9 00:28:33] WARNING[24623] loader.c: Module 'format_mp3.so' was not compiled with the same compile-time options as this version of Asterisk.

I just did an "apt-get update" and thus found the new asterisk_1.6.2.5-0ubuntu1.1 series of packages.

The "compile-time options as this version of Asterisk" messages are now all gone. (However, there are still some remaining "undefined symbol" errors in the log file. But that seems to be a completely different issue.)

This bug is fixed thanks to the new packages.

Changed in asterisk-addons (Ubuntu):
status: Confirmed → Fix Released

[THIS BUG IS NOT FIXED]

I spoke too soon. A fresh 10.4 VM, with the latest asterisk packages, produces the same errors.

The asterisk-mysql package is still stuck at version asterisk-mysql_1.6.2.0-1_i386.deb so the re-compile is still necessary.

apt-get build-dep asterisk-mysql
apt-get -b source asterisk-mysql
dpkg -i asterisk-mysql_1.6.2.0-1_i386.deb

I also did this to get rid of some other complaints:

apt-get build-dep asterisk-addons
apt-get -b source asterisk-addons
dpkg -i asterisk-mobile_1.6.2.0-1_i386.deb
dpkg -i asterisk-mp3_1.6.2.0-1_i386.deb
dpkg -i asterisk-ooh323c_1.6.2.0-1_i386.deb

So even though there's new asterisk packages, these modules got left behind.

[EDIT: I am unable to put the bug back to "Confirmed" from "Fix released". I did not know that was a one-way operation. A moderator needs to set the status back to "Confirmed".]

Same problem here. Completely updated system and same error.

root@zenon:/usr/lib/asterisk/modules# dpkg -l asterisk*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Nome Versão Descrição
+++-=============================-=============================-==========================================================================
ii asterisk 1:1.6.2.5-0ubuntu1.1 Open Source Private Branch Exchange (PBX)
un asterisk-1.6.2 <nenhuma> (nenhuma descrição disponível)
un asterisk-app-dtmftotext <nenhuma> (nenhuma descrição disponível)
ii asterisk-config 1:1.6.2.5-0ubuntu1.1 Configuration files for Asterisk
un asterisk-config-custom <nenhuma> (nenhuma descrição disponível)
un asterisk-dev <nenhuma> (nenhuma descrição disponível)
un asterisk-doc <nenhuma> (nenhuma descrição disponível)
ii asterisk-h323 1:1.6.2.5-0ubuntu1.1 H.323 protocol support for Asterisk
ii asterisk-mobile 1.6.2.0-1 bluetooth mobile devices support for Asterisk
ii asterisk-mp3 1.6.2.0-1 MP3 format support (format_mp3) for the Asterisk PBX
ii asterisk-mysql 1.6.2.0-1 MySQL support for the Asterisk PBX (cdr mainly)
ii asterisk-sounds-extra 1.4.9-1 Additional sound files for the Asterisk PBX
ii asterisk-sounds-main 1:1.6.2.5-0ubuntu1.1 Core Sound files for Asterisk (English)

Nicholas Lee (emptysands) wrote :

Yeah same problem on 10.04. And same solution - apt-get -b source...

Versions:

ii asterisk 1:1.6.2.5-0ubuntu1.3 Open Source Private Branch Exchange (PBX)
ii asterisk-mysql 1.6.2.0-1 MySQL support for the Asterisk PBX (cdr main <=== Self Build from source deb.

jonaz__ (jonaz-86) wrote :

THIS IS NOT FIXED!

Can somebody change the status or do i have to report a new bug?

Jan Groenewald (jan-aims) wrote :

The asterisk-mysql package is still stuck at version asterisk-mysql_1.6.2.0-1_i386.deb so the re-compile is still necessary.

The apt-get build-dep asterisk-mysql also fails now because of libmysqlclient version clashes.

Why is this marked as fix released?? That seems wrong.

Jan Groenewald (jan-aims) wrote :

I am thinking on moving to Debian, is Ubuntu good to be on a server?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers