Turkish is always listed in GTK apps even when not installed

Bug #379971 reported by Michael Monreal on 2009-05-24
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Low
Unassigned
aspell
Unknown
Unknown
aspell (Ubuntu)
Low
Unassigned

Bug Description

Not sure if this is a bug in aspell, gtkspell or some other package but GTK apps like Evolution and Empathy always show "Turkish" as one of the available languages to spellcheck, even if only other dicts are installed.

I have tested the same on Fedora 11 and I do not see the bug there.

Javier Jardón (jjardon) wrote :

Confirming bug here: Ubuntu 9.04 with latest updates

Changed in aspell (Ubuntu):
status: New → Confirmed
Brian Curtis (bcurtiswx) wrote :

Low importance, due to it being cosmetic. Non-core app.

Changed in aspell (Ubuntu):
importance: Undecided → Low
Brian Curtis (bcurtiswx) wrote :

Marking as triaged as its been pushed upstream. Michael can you give us the package version of aspell you're using and the version of Ubuntu you are using as well.

apt-cache policy aspell
uname -a

post the output of those two commands after being entered in a terminal

Changed in aspell (Ubuntu):
status: Confirmed → Triaged
Javier Jardón (jjardon) wrote :

My data:

$ apt-cache policy aspell
aspell:
  Installed: 0.60.6-1
  Candidate: 0.60.6-1

$ uname -a
Linux torkiano-glaptop 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux

Michael Monreal (mimox) wrote :

Same for me as Javier (Up-to-date jaunty system). A friend told me he also sees the bug on Intrepid btw.

Nikola Yanev (gericom) wrote :

this is the most strange bug ;)
i can confirm it here too
since intrepid, until karmic it's present, the apps i saw it are empathy, evolution, gedit, even i have only BG and EN installed here, and it drives me crazy.

Javier Jardón (jjardon) wrote :

Hello

I think that the importance shoud be high or normal because, as Nikola said, this bugs affects a lot of apps, like empathy (the default IM app for karmic), evo, gedit ...

Brian Curtis (bcurtiswx) wrote :

I appreciate the comments. The reason it's low is because of the following
https://wiki.ubuntu.com/Bugs/Importance

In Low Importance
# A bug that has a moderate impact on a non-core application
# A cosmetic/usability issue that does not limit the functionality of an application

These two fit this bug the best.

David Planella (dpm) on 2009-07-31
tags: added: i18n
jracosta (jracosta) wrote :

Any way i can help fixing the issue? Spell checking is extremely important for me since I am using evolution and pidgin for my corporate and customer communications. Specially since I switch between two different languages

I have this problem in Gentoo and Arch too.

Adi Roiban (adiroiban) on 2009-10-05
Changed in ubuntu-translations:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Adi Roiban (adiroiban)
Adi Roiban (adiroiban) on 2009-10-31
Changed in ubuntu-translations:
assignee: Adi Roiban (adiroiban) → nobody
Javier Jardón (jjardon) wrote :

Seems to be fixed in the latest karmic

Changed in ubuntu-translations:
status: Confirmed → Invalid
Changed in aspell (Ubuntu):
status: Triaged → Invalid
Brian Curtis (bcurtiswx) on 2009-11-18
Changed in aspell (Ubuntu):
status: Invalid → Fix Released
jracosta (jracosta) wrote :

The defect still exist on karmic. I upgraded my laptop to 9.10 and the issue still exists. i tried all the work arounds on the Ubuntu forums and nothing works:

Here it is the information on my system:

evolution:
  Installed: 2.28.1-0ubuntu2
  Candidate: 2.28.1-0ubuntu2
  Version table:
 *** 2.28.1-0ubuntu2 0
        500 http://us.archive.ubuntu.com karmic-updates/main Packages
        100 /var/lib/dpkg/status
     2.28.1-0ubuntu1 0
        500 http://us.archive.ubuntu.com karmic/main Packages

aspell:
  Installed: 0.60.6-2
  Candidate: 0.60.6-2
  Version table:
 *** 0.60.6-2 0
        500 http://us.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

uname -a
Linux juacosta-lnx 2.6.31-17-generic #54-Ubuntu SMP Thu Dec 10 16:20:31 UTC 2009 i686 GNU/Linux

Changed in aspell (Ubuntu):
status: Fix Released → Confirmed
Javier Jardón (jjardon) wrote :

I don't have this problem anymore, but the upstream developer needs more info: see the upstream bug

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.