broken user requires removal before asoundconf will correctly set configuration

Bug #174979 reported by Manuel Carro on 2007-12-08
2
Affects Status Importance Assigned to Milestone
asoundconf-gtk (Ubuntu)
Undecided
Daniel T Chen

Bug Description

Binary package hint: alsamixergui

alsamixer does not find default device:

mcarro@balboa:~$ alsamixer

alsamixer: function snd_ctl_open failed for default: No such device

However, "alsamixer -c 0" does start normally. This bug affects other applications which try to use the "default" sound device -- e.g., gcompris, which fails to deliver sound with the following error messages:

ALSA lib confmisc.c:769:(parse_card) cannot find card '@ 7f0xc001'
ALSA lib conf.c:3510:(_snd_config_evaluate) function snd_func_card_driver returned error: No such device
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3510:(_snd_config_evaluate) function snd_func_concat returned error: No such device
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:3510:(_snd_config_evaluate) function snd_func_refer returned error: No such device
ALSA lib conf.c:3982:(snd_config_expand) Evaluate error: No such device
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM default

No configuration file was manually edited at any moment.

Manuel Carro (mcarro) wrote :

Comment from the same person who reported the bug:

I have sound using the "default" device again. I removed the .asoundrc.asoundconf file and run asoundconf-gtk to select again the default card. The previous .asoundrc.asoundconf file had, as default, a card which was probably corresponding to an USB device which I tried to make the default device and which is not plugged in now. However, asoundconf-gtk did not give me any option to set the default sound card before I removed the .asoundrc.asoundconf files. I think that this counds as a bug: a buggy (or non-current) alsa user conf file prevents asoundconf-gtk from generating a correct configuration.

Daniel T Chen (crimsun) on 2008-11-18
Changed in alsamixergui:
status: New → Confirmed
Changed in alsa-utils:
assignee: nobody → crimsun
Toby Smithe (tsmithe) wrote :

Hi,

I am not able to reproduce the bug on a non-extant sound card configuration here using asoundconf-gtk. Could you post an .asoundrc.asoundconf file that provokes this error?

Also, please clarify the presentation of "did not give me any option to set the default sound card".

Thanks.

Toby Smithe (tsmithe) wrote :

Is this bug still pertinent?

Changed in asoundconf-gtk (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers