thymiovpl and asebastudio are missing from aseba package

Bug #1778362 reported by Mossroy
This bug affects 6 people
Affects Status Importance Assigned to Milestone
aseba (Ubuntu)
Fix Released
Georges Khaznadar

Bug Description

The aseba package distributed by Ubuntu (version 1.6.0-3.1~build1 for 18.04 Bionic, any architecture) is missing a few binaries.
In particular, the thymiovpl and asebastudio binaries are not there, which provide the capability to program a Thymio device.
I noticed that the corresponding desktop and icon files are in the package : only the binaries are missing.

The same issue is in the Debian package (version 1.6.0-4)
If you compare with the package distributed on the thymio website (, version 1.6.0-2 for 17.10 Artful, provided by the PPA, here is the list of missing binaries :
- asebamedulla
- asebastudio
- thymiovpl

Tags: bionic
tags: added: bionic
Revision history for this message
Mossroy (mossroy) wrote :

The PPA package mentioned above can be installed on bionic, and works (some qt4 packages need to be installed). But it has the same name as the package from standard repos, with a slightly lower version. So every apt upgrade replaces it with the one from standard repos, removing thymiovpl and other binaries.
Pinning the package can be a temporary workaround.

Revision history for this message
Stéphane Magnenat (stephane.magnenat) wrote :

I am the original author of Aseba, although currently not active in the project any more. The lack of UI program is likely to be a result of a broken dependency on Qt4 in 18.04.

Revision history for this message
Stéphane Magnenat (stephane.magnenat) wrote :

I was wrong, as since Debian version 1.6.0-3, the Debian package patches Aseba to switch it to Qt5. I guess there is something incomplete with this patch.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aseba (Ubuntu):
status: New → Confirmed
Revision history for this message
Alexis Scheuer (alexis-scheuer) wrote :


I have the same problem. Thanks for the workaround with 1.6.0-2 package (I will try it this afternoon), but could someone do something about apt trying to replace this package by the newer which is incomplete, please?

Revision history for this message
Alexis Scheuer (alexis-scheuer) wrote :

It was difficult to ask apt and Synaptic to install a artful package under bionic, but I managed to succeed. To get as result that it was not able to install this package (aseba_1.6.0-2) on bionic, as the QT4 dependencies cannot be installed - Stéphane mentioned it in #2.

I will probably (but not too soon) reinstall on the 1.6.0-3.1~build1 package (to get QT5 dependencies), and compile (I was hopping to avoid that) the missing binaries... This may help to understand why they are missing. If the development team does not answer until then, I will give you a feedback.

Revision history for this message
Alexis Scheuer (alexis-scheuer) wrote :

OK, it works: I have been able to compile from github repository. Everything needed (the 3 archives = master + dashel + enki, a building script and a read-me) can be downloaded on my web pages: (19.4 Mo, TarBzip file).

Revision history for this message
piscvau (piscvau) wrote :

We tried to install the building script on a Xubuntu Bionics system. It does not work. bleow is the error code :
-- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE)
Using dashel from /home/christian/Documents/thymio/build_Aseba_Debian/aseba-master/dashel
CMake Warning at enki/CMakeLists.txt:10 (find_package):
  By not providing "FindQt5.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "Qt5", but
  CMake did not find one.

  Could not find a package configuration file provided by "Qt5" with any of
  the following names:


  Add the installation prefix of "Qt5" to CMAKE_PREFIX_PATH or set "Qt5_DIR"
  to a directory containing one of the above files. If "Qt5" provides a
  separate development package or SDK, be sure it has been installed.

CMake Error at /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
  Could NOT find OpenGL (missing: OPENGL_opengl_LIBRARY OPENGL_glx_LIBRARY
Call Stack (most recent call first):
/usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake-3.10/Modules/FindOpenGL.cmake:369 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  enki/CMakeLists.txt:11 (find_package)

-- Configuring incomplete, errors occurred!
See also "/home/christian/Documents/thymio/build_Aseba_Debian/aseba-master/build/CMakeFiles/CMakeOutput.log".
make: *** Pas de cible spécifiée et aucun makefile n'a été trouvé. Arrêt.

Revision history for this message
Georges Khaznadar (georgesk) wrote :

The last release fixes this bug.

QT5 issues have been cleared in the Debian patches.

Changed in aseba (Ubuntu):
assignee: nobody → Georges Khaznadar (georgesk)
status: Confirmed → Fix Released
Revision history for this message
Mossroy (mossroy) wrote :

That's good news, thanks!

I suppose you're talking about package version 1.6.0-5 of aseba, and the following debian bug : and github issues : and ?
So this fix should be available in ubuntu 19.04 (disco) when released : ?

I tried to install the package for disco on 18.04 (bionic) but it needs newer qt5 libraries as dependencies.
Will there be a 1.6.0-5 package for bionic?

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.