asciidoc fails because of deprecated python module

Bug #368119 reported by Peter Hansen on 2009-04-27
6
Affects Status Importance Assigned to Milestone
asciidoc (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: asciidoc

The package asciidoc 8.2.7-2ubuntu1 (amd64 binary) in ubuntu jaunty fails to run because, in python, it tries to import the module "popen2", which is deprecated. I think this issue is caused by the move to python 2.6, since this module loads fine on for example debian sid that currently has python 2.5.4 as default.

lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

apt-cache policy asciidoc
asciidoc:
  Installed: 8.2.7-2ubuntu1
  Candidate: 8.2.7-2ubuntu1
  Version table:
 *** 8.2.7-2ubuntu1 0
        500 http://localhost jaunty/main Packages
        100 /var/lib/dpkg/status

Error message:
a2x test.asc
/usr/bin/asciidoc:9: DeprecationWarning: The popen2 module is deprecated. Use the subprocess module.
  import sys, os, re, time, traceback, tempfile, popen2, codecs, locale

Brian Murray (brian-murray) wrote :

I was able to recreate this using asciidoc package version 8.2.7-2ubuntu1.

Changed in asciidoc (Ubuntu):
importance: Undecided → High
status: New → Triaged
komuta (komuta) wrote :

The bug is not present in the last version of asciidoc (8.4.4 from 2009-04-26). The issue has been addressed in version 8.3.0 (see http://www.methods.co.nz/asciidoc/CHANGELOG.html). Jaunty version (8.2.7) is from 2008-07-04. Shouldn't the package be updated ?

Peter Hansen (peterih) wrote :

Version 8.4.4 is already in Debian testing, so I guess we should see it in a near future?

treehead (treehead) wrote :

It has been nearly a year since this bug was filed. Is there any work around for those of us on 9.04?

Jackson Doak (noskcaj) on 2014-02-28
Changed in asciidoc (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers