armagetronad.real crashed with SIGSEGV - Reset screen resolution

Bug #341491 reported by William Wynn on 2009-03-12
Affects Status Importance Assigned to Milestone
Armagetron Advanced
Manuel Moos
armagetronad (Ubuntu)

Bug Description

Binary package hint: armagetronad

Game crashed and closed at the start of a new round (single player) for an unknown reason. The next time I started it up, it went into windowed mode and the screen size and screen resolution had been rest to 320 x 240. Everything thing else seems to have stayed the same.

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/games/armagetronad.real
NonfreeKernelModules: nvidia
Package: armagetronad
ProcCmdline: /usr/games/armagetronad.real --datadir /usr/share/games/armagetronad --configdir /etc/armagetronad --userconfigdir /home/username/.armagetronad --vardir /home/username/.armagetronad/var
 PATH=(custom, user)
Signal: 11
SourcePackage: armagetronad
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: armagetronad.real crashed with SIGSEGV
Uname: Linux 2.6.28-9-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev sambashare video

William Wynn (williamwynn) wrote :
description: updated

StacktraceTop:eSoundPlayer::Mix (this=0x85d2248,
gCycle::SoundMix (this=0x86b7b50,
eCamera::SoundMixGameObject (this=0x867c970,
eCamera::SoundMix (this=0x867c970,
fill_audio (udata=0x0,

Changed in armagetronad:
importance: Undecided → Medium
Manuel Moos (z-man) wrote :


#17 0x08053278 in gCycle::SoundMix (this=0x86b7b50,
    dest=0x841aed0 "\210���\210���ȮA\bȮA\b", len=2048, viewer=-1213222544,
    rvol=0.00388634484, lvol=0.00612877961) at ../../src/tron/gCycle.cpp:3201
No locals.
#18 0x080b830d in eCamera::SoundMixGameObject (this=0x867c970,
    dest=0x841aed0 "\210���\210���ȮA\bȮA\b", len=2048, go=0x86b7b50)
    at ../../src/engine/eCamera.cpp:2021

The viewer argument is out of range. The other thread's stack trace reveals the reason: it has already destroyed the camera. I'll add sound locks in the appropriate places.

<3 apport. Best random crash bug report we ever got.

Manuel Moos (z-man) wrote :

A fix should be available in due in a couple of days.

Changed in armagetronad:
assignee: nobody → z-man
importance: Undecided → High
milestone: none →
status: New → Fix Committed
Manuel Moos (z-man) wrote :

Also, here's a minimal patch for We're not really in a good position to release with it, but it's probably a good idea to add the patch to Ubuntu. In bzr, the fix is here:

William Wynn (williamwynn) wrote :

Wow that's fast. Great job. Hurray open source.

dforsi (daniele-forsi) wrote :

Looking at the attachments in this bug report, I noticed that "armagetronad-" was not flagged as a patch. A patch contains changes to an Ubuntu package that will resolve a bug and this attachment is one! Subsequently, I've checked the patch flag for it. In the future when submitting patches please use the patch checkbox as there are some Launchpad searches that use this feature. You can learn more about the patch workflow at

Brian Murray (brian-murray) wrote :

I've added the patch in an updated version of the package so that we can get this fixed for Jaunty.

Changed in armagetronad (Ubuntu):
status: New → Triaged
Iain Lane (laney) wrote :

Uploaded, thanks for your work. Could you please forward the patch to Debian if the new release is not imminent?

Changed in armagetronad (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package armagetronad -

armagetronad ( jaunty; urgency=low

  * add patch 10_add_sound_locks.diff resolves crash in sound handling
    (LP: #341491) Will be fixed in upstream release

 -- Brian Murray <email address hidden> Fri, 20 Mar 2009 15:05:46 -0700

Changed in armagetronad:
status: Fix Committed → Fix Released
Manuel Moos (z-man) on 2010-04-04
Changed in armagetronad:
status: Fix Committed → Fix Released
Changed in armagetronad:
status: Fix Released → Confirmed
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers