[SRU] Ark no longer opens rar files in 16.10

Bug #1636655 reported by Lutz Wrage on 2016-10-25
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
ark (Ubuntu)
Medium
Simon Quigley
Yakkety
Medium
Simon Quigley
Zesty
Medium
Simon Quigley

Bug Description

After upgrading Kubuntu 16.04 to 16.10, ark can no longer open RAR files. This worked without problems in 16.04, and is therefore considered a regression.

We need this fix in 16.10 because they can reasonably assume that regressions from one release to another will be fixed.

[Test Case]
 1. Install the unrar package on your system.
 2. Make or find a .rar file on your system.
 3. Open this file with ark either by navigating to it in Dolphin (file manager) or opening it via the command line.

[Regression Potential]
This is very unlikely. This came directly from upstream, and if we notice a regression, we'll likely get it fixed there and have another commit backported as well. Since it just adds the RAR file format in a few places, there isn't much of a risk.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ark (Ubuntu):
status: New → Confirmed
The Punisher (melprinsi) wrote :

files structures changed with 16.10 and all kerfuffle plugins are relocated; or lost.
Simple solution until bug fix:
download ark for 16.04 and install over it

shao.lo (shao-lo) wrote :

Was reported broken in OpenSuse too...
  https://forums.opensuse.org/showthread.php/520017-Ark-unable-to-open-rar

Issue with change from "application/x-rar" to "application/vnd.rar"?

Simon Quigley (tsimonq2) wrote :

So this was fixed in a commit backported to the relevant Applications branch. An email sent to the kde-distro-packagers list has a commit that I've backported in the relevant packaging. I'm going to upload this to ppa:tsimonq2/kde-bug-372300 and get it in Zesty, then we can file an SRU and get the fix in 16.10.

Thanks for your help in making Kubuntu better!

Changed in ark (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
status: Confirmed → In Progress
Simon Quigley (tsimonq2) wrote :

Rik Mills on IRC says that the fix looks good, so I'm linking the diff from the PPA and subscribing ubuntu-sponsors. He has NOT tested it for Yakkety yet, so please don't upload that. I'll edit this bug to match the SRU format when it's ready.

https://launchpadlibrarian.net/292981285/ark_4%3A16.04.3a-0ubuntu2_4%3A16.04.3a-0ubuntu3.diff.gz

Rik Mills (rikmills) wrote :

Now tested on Yakkety.

The fix seems to work ok on a selection or rar archives.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ark - 4:16.04.3a-0ubuntu3

---------------
ark (4:16.04.3a-0ubuntu3) zesty; urgency=medium

  * Fix RAR files with shared-mime-info >= 1.7 (LP: #1636655)

 -- Simon Quigley <email address hidden> Thu, 10 Nov 2016 17:54:33 -0600

Changed in ark (Ubuntu):
status: In Progress → Fix Released
Rik Mills (rikmills) wrote :

I would note that opening rar files requires unrar to be install, which is not the default. That has been the case for as long as I can reasonably recall though. That is not a new issue, or the issue that broke Ark's rar handling in this bug.

Simon Quigley (tsimonq2) wrote :
description: updated
summary: - Ark no longer opens rar files in 16.10
+ [SRU] Ark no longer opens rar files in 16.10
description: updated
description: updated
Maia Everett (linneris) wrote :

Works for me and fixes the problem with rar archives on 16.10, even without unrar installed. I would like it SRU'd as well.

Hello Lutz, or anyone else affected,

Accepted ark into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ark/4:16.04.3a-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ark (Ubuntu Yakkety):
status: New → Fix Committed
tags: added: verification-needed
Simon Quigley (tsimonq2) on 2016-11-18
Changed in ark (Ubuntu Yakkety):
assignee: nobody → Simon Quigley (tsimonq2)
Lutz Wrage (lutz-wrage) wrote :

ark 4:16.04.3a-0ubuntu2.1 fixes the problem for me

tags: added: verification-done
removed: verification-needed
Changed in ark (Ubuntu Zesty):
importance: Undecided → Medium
Changed in ark (Ubuntu Yakkety):
importance: Undecided → Medium
Simon Fisher (s-r-fisher) wrote :

ark 4:16.04.3a-0ubuntu2.1 from proposed also fixes the issue for me as well,

thanks, that was getting annoying

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ark - 4:16.04.3a-0ubuntu2.1

---------------
ark (4:16.04.3a-0ubuntu2.1) yakkety; urgency=medium

  * Fix RAR files with shared-mime-info >= 1.7 (LP: #1636655)

 -- Simon Quigley <email address hidden> Thu, 10 Nov 2016 17:54:33 -0600

Changed in ark (Ubuntu Yakkety):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ark has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers