Ark fails to produce zip archive instead making gzip with the zip suffix

Bug #1388532 reported by Sam Rog on 2014-11-02
92
This bug affects 21 people
Affects Status Importance Assigned to Milestone
ark (Ubuntu)
Undecided
Unassigned
dolphin (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 14.10

Package ark (4:4.14.1-0ubuntu1)

Ark: 2.19

Steps to reproduce:

1) Compress a file to the .zip format with the Ark either from the Ark or from the file manager context menu.
2) Unpack the .zip file with the 'unzip'command

There is an error message (Test.zip)

Archive: Test.zip
  End-of-central-directory signature not found. Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive. In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip: cannot find zipfile directory in one of Test.zip or
        Test.zip.zip, and cannot find Test.zip.ZIP, period.

The file command is telling:

file Test.zip
Test.zip: gzip compressed data, last modified: Sun Nov 2 11:54:49 2014, from Unix

The Ubuntu package ark (4:4.14.1-0ubuntu1) has a patch 'use_libarchive_for_zip_files'. When compiling the Ark without the patch the Ark is compressing to the .zip format.

Then the file is identified as:

file Test.zip
Test.zip: Zip archive data, at least v2.0 to extract

and the unzip can unpack it:

unzip Test.zip
Archive: Test.zip
  inflating: Test.txt

Sam Rog (samrog131) wrote :

The 'use_libarchive_for_zip_files' is coming from the Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=748198

The Utopic Ark has been merged with the Debian: http://changelogs.ubuntu.com/changelogs/pool/universe/a/ark/ark_4.14.1-0ubuntu1/changelog :

ark (4:4.13.2-0ubuntu1) utopic; urgency=medium

  [ Rohan Garg ]
  * Merge with debian, no remaining changes

The Trusty Ark has not merged with the Debian: http://changelogs.ubuntu.com/changelogs/pool/universe/a/ark/ark_4.13.3-0ubuntu0.1/changelog

So it doesn't have the patch 'use_libarchive_for_zip_files

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ark (Ubuntu):
status: New → Confirmed
Ferry Toth (ftoth) wrote :

This bug also causes dolphin to produce gzip files with extension zip when right-clicking a folder and selecting <compress><as zip archive>

I think the importance of this bug should be set to high.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dolphin (Ubuntu):
status: New → Confirmed
Ferry Toth (ftoth) wrote :

To work around this problem I did:

download the deb for Trusty
install (I used qapt, but dpkg -i should work)
go to synaptic to pin ark to the downgraded version (otherwise will be upgraded on next upgrades)

amichair (amichai2) wrote :
Ferry Toth (ftoth) wrote :

It looks like this is solved in vivid, but I'm not sure as I have ark_15.04.0-0ubuntu1~ubuntu15.04~ppa1_amd64 from Kubuntu Backport PPA.

ark -v reports:
Qt: 4.8.6
KDE Development Platform: 4.14.7
Ark: 2.19

I tested this by using dolphin to zip a file and then used file filename.zip to verify the type. I did not test the file by f.i. using winzip in windows.

Shaio (sound-anarchist) wrote :

I have the same version as Ferry Toth in Utopic (14.10) with vanilla repos and the bug is present.

ark -v:
Qt: 4.8.6
KDE Development Platform: 4.14.1
Ark: 2.19

ark:
  Installed: 4:4.14.1-0ubuntu1

test.zip: gzip compressed data, last modified: Sun May 10 22:53:40 2015, from Unix

This file is not working on Windows (as expected), but the strange thing is that it's not working on another Ubuntu machine - Trusty (14.04) with vanilla repos. Ark shows just an empty archive and is not extracting anything from it when used with the right click Dolphin menu.

Version of ark:
Qt: 4.8.6
KDE Development Platform: 4.13.3
Ark: 2.19

As far as i can see, the difference in those three cases (with the one presented by Ferry Toth) is the KDE Dev Platform version.

Ferry Toth (ftoth) wrote :

In Utopic I had the bug as well, but worked around it see #6 above.

Just saying, it's solved in Vivid (possibly) or Vivid + Kubuntu Backports PPA (works for me)

Eric Forgeot (eforgeot) wrote :

I have this in linux mint 17.3. I can't believe this annoying yet easy to fix bug hadn't been corrected since then (2 years). And I don't understand why Debian developpers want so much to "patch" upstream software and add new bugs instead of keeping them as they are...

Richard Rasker (rasker-a) wrote :

Almost 2017, and the bug is still not fixed (also Mint 17.3).

Can someone perhaps explain the steps how I can try and contribute to a fix? No, I'm not much of a software developer (I'm an electronics engineer), but this should be fairly easy to solve.

If I understand correctly, it has been fixed for several other distributions, but I have no overview about what versions are included in what Linux distributions.

TIA,

Richard Rasker

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.