Missing Multimedia Plugin "GStreamer element ffdeinterlace"

Bug #571910 reported by schaze on 2010-04-29
64
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Arista Transcoder
Invalid
Undecided
Unassigned
arista (Ubuntu)
Medium
Haseem Narvaez

Bug Description

Binary package hint: arista

When clicking on Add to Queue in Arista Transcoder in my fresh installed Lucid, the "Search for suitable plugin?" Dialog pops up and then searches for "GStreamer element ffdeinterlace". This is however not found "No packages with the requested plugins found" and so Arista complains: "Cannot add item to queue because of missing elements!"
This means a featured application in the Software Center for Lucid is broken.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: arista 0.9.3+repack-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Apr 29 23:34:44 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: arista

schaze (schaze) wrote :
Alessio Treglia (quadrispro) wrote :

Daniel, could you take a deeper look?

Changed in arista (Ubuntu):
status: New → Triaged
importance: Undecided → Medium

I encountered the same problem with Ubuntu 9.10.

I found a workaround: manually install gstreamer-0.1-ffmpeg, then restart Arista.

Similarly, to be able to achieve my transcoding, I add to manually install gstreamer0.10-plugins-bad-multiverse and gstreamer0.10-plugins-ugly-multiverse. Arista detected the missing codecs but the plugin search failed.

So, I think that the problem is in the plugin resolution mechanism.

Once again this is in the list of required packages to be installed that Ubuntu ignores.

Changed in arista:
status: New → Invalid
Marques Johansson (marques) wrote :

I have all of these gst modules and I still get the misssing ffdeinterlace problem. I also get this error when I try to start thoggen. I also removed ~/.gstreamer-0.10 and reran gst-inspect.

gstreamer0.10-alsa
gstreamer0.10-esd
gstreamer0.10-ffmpeg
gstreamer0.10-fluendo-mp3
gstreamer0.10-gnonlin
gstreamer0.10-nice
gstreamer0.10-plugins-bad
gstreamer0.10-plugins-bad-multiverse
gstreamer0.10-plugins-base
gstreamer0.10-plugins-base-apps
gstreamer0.10-plugins-good
gstreamer0.10-plugins-ugly
gstreamer0.10-plugins-ugly-multiverse
gstreamer0.10-pulseaudio
gstreamer0.10-tools
gstreamer0.10-x

Marques, can you please run gst-inspect-0.10 --version and gst-inspect-0.10 | grep deint and paste the output? Here is an example of mine:

$ gst-inspect-0.10 | grep deint
interleave: deinterleave: Audio deinterleaver
deinterlace: deinterlace: Deinterlacer
ffmpeg: ffdeinterlace: FFMPEG Deinterlace element
postproc: postproc_ffmpegdeint: LibPostProc ffmpegdeint filter
postproc: postproc_mediandeint: LibPostProc mediandeint filter
postproc: postproc_cubicipoldeint: LibPostProc cubicipoldeint filter
postproc: postproc_linipoldeint: LibPostProc linipoldeint filter
postproc: postproc_linblenddeint: LibPostProc linblenddeint filter

$ gst-inspect-0.10 --version
gst-inspect-0.10 version 0.10.29
GStreamer 0.10.29
https://launchpad.net/distros/ubuntu/+source/gstreamer0.10

If you don't have 'ffdeinterlace' do you at least have the new 'deinterlace'?

Marques Johansson (marques) wrote :

marques@split:~$ gst-inspect-0.10 | grep ffm
ffmpegcolorspace: ffmpegcolorspace: FFMPEG Colorspace converter
aiff: aiffmux: AIFF audio muxer

marques@split:~$ gst-inspect-0.10 | grep deint
deinterlace: deinterlace: Deinterlacer
interleave: deinterleave: Audio deinterleaver

Marques, it looks like you don't actually have gstreamer0.10-ffmpeg installed at all. grepping for ffm should have returned a *lot* of entries if it was installed. I would try to re-install it and see if any errors are thrown. This is also an upstream issue, so if that doesn't fix it please take it up with the GStreamer people, e.g. via IRC in #gstreamer on irc.freenode.org!

Also, slomo pointed out that gst-ffmpeg is broken in the latest development release (Maverick) - are you using that instead of Lucid (10.04)?

Marques Johansson (marques) wrote :

I'm using Maverick. I'll reinstall a little later today.

Marques Johansson (marques) wrote :
Download full text (4.3 KiB)

marques@split:~$ sudo dpkg --purge --force-depends gstreamer0.10-ffmpeg
dpkg: gstreamer0.10-ffmpeg: dependency problems, but removing anyway as you requested:
 arista depends on gstreamer0.10-ffmpeg.
(Reading database ... 370552 files and directories currently installed.)
Removing gstreamer0.10-ffmpeg ...

marques@split:~$ sudo aptitude install gstreamer0.10-ffmpeg
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
The following NEW packages will be installed:
  gstreamer0.10-ffmpeg
0 packages upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 128kB of archives. After unpacking 352kB will be used.
Writing extended state information... Done
Get:1 http://us.archive.ubuntu.com/ubuntu/ maverick/universe gstreamer0.10-ffmpeg 0.10.10-1 [128kB]
Fetched 128kB in 0s (177kB/s)
Selecting previously deselected package gstreamer0.10-ffmpeg.
(Reading database ... 370542 files and directories currently installed.)
Unpacking gstreamer0.10-ffmpeg (from .../gstreamer0.10-ffmpeg_0.10.10-1_amd64.deb) ...
Setting up gstreamer0.10-ffmpeg (0.10.10-1) ...
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done

Current status: 0 broken [-1].

displague@split:~$ arista-gtk
arista.presets [369]: INFO Attempting to install elements: ffdeinterlace
arista.presets [378]: ERROR Unable to install required elements!
...

displague@split:~$ rm -rf .gstreamer-0.10
displague@split:~$ gst-inspect-0.10
no more csLADSPA plugins

(gst-plugin-scanner:2907): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstpostproc.so': libavutil.so.49: cannot open shared object file: No such file or directory

(gst-plugin-scanner:2907): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstffmpeg.so': libavutil.so.49: cannot open shared object file: No such file or directory
...

I have libavutil49-extra which provides libavutil49, but doesn't provide the so.49 file this is looking for.

displague@split:~$ sudo apt-get install libavutil49
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  libavutil-extra-49
The following NEW packages will be installed:
  libavutil49
0 upgraded, 1 newly installed, 1 to remove and 1 not upgraded.
Need to get 65.1kB of archives.
After this operation, 69.6kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://us.archive.ubuntu.com/ubuntu/ maverick/main libavutil49 4:0.5.1-1ubuntu1 [65.1kB]
Fetched 65.1kB in 1s (60.1kB/s)
dpkg: libavutil-extra-49: dependency problems, but removing anyway as you requested:
 vlc-nox depends on libavutil49 (>= 4:0.5.1-1) | libavutil-extra-49 (>= 4:0.5.1-1); however:
  Package libavutil49 is not installed.
  Package libavutil-extra-49 is to be removed.
 audacious-plugins depends on libavutil49 (>= 4...

Read more...

Marques Johansson (marques) wrote :

Regarding that last problem I mentioned - and in order to test this solution, how are you supposed to transcode from a DVD? The man page and /usr/share/docs don't provide any examples (and Google didn't help either).

marques@split:~$ arista-transcode -v -d psp -p low /dev/sr0 Dora\ -\ Superbabies/file.mp4
arista.presets [450]: DEBUG Loaded device Web Browser (3 presets)
arista.presets [450]: DEBUG Loaded device Apple iPhone / iPod (3 presets)
arista.presets [450]: DEBUG Loaded device Computer (4 presets)
arista.presets [450]: DEBUG Loaded device Apple iPad (2 presets)
arista.presets [450]: DEBUG Loaded device Android Phone (3 presets)
arista.presets [450]: DEBUG Loaded device Sony PSP (2 presets)
arista.presets [450]: DEBUG Loaded device Sony Playstation 3 (2 presets)
arista.presets [450]: DEBUG Loaded device Nokia N Series (3 presets)
arista.presets [450]: DEBUG Loaded device DVD Player (3 presets)
Encoding sr0 for psp (low)
arista.discoverer [204]: DEBUG Discovering /dev/sr0

Alessio Treglia (quadrispro) wrote :

Please try to reproduce this with the latest release available in Maverick.

Changed in arista (Ubuntu):
status: Triaged → Incomplete
Marques Johansson (marques) wrote :
Download full text (4.4 KiB)

As bugs go, I think the initial bug is fixed.

I now get this when arista queues my DVD to PSP-Low transcoding job:

displague@split:~$ arista-gtk
libdvdread: Using libdvdcss version 1.2.10 for DVD access

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VTS_01_0.VOB at 0x000001aa
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x00006daa
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_0.VOB at 0x0012f837
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_1.VOB at 0x0012f870
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_0.VOB at 0x0013755e
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_1.VOB at 0x00137597
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_04_0.VOB at 0x00138259
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_04_1.VOB at 0x00138292
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_05_0.VOB at 0x00138f6a
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_05_1.VOB at 0x00138fa3
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_06_0.VOB at 0x00139604
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_06_1.VOB at 0x0013963d
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_07_0.VOB at 0x0013a495
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_07_1.VOB at 0x0013a4ce
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_08_0.VOB at 0x0013ace7
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_08_1.VOB at 0x0013ad20
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_09_0.VOB at 0x0013b67b
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_09_1.VOB at 0x0013b6b4
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_10_0.VOB at 0x0013c53a
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_10_1.VOB at 0x0013c573
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_11_0.VOB at 0x0013c980
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_11_1.VOB at 0x0013c9b9
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_12_0.VOB at 0x0013d7a1
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_12_1.VOB at 0x0013d7da
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_13_0.VOB at 0x0013e464
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_13_1.VOB at 0x0013e49d
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_14_0.VOB at 0x0013ef96
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_14_1.VOB at 0x0013efcf
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_15_0.VOB at 0x0013f838
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_15_1.VOB at 0x0013f871
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_16_0.VOB at 0x00140385
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_16_1.VOB at 0x001403be
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_17_0.VOB at 0x00140d4b
libdvdre...

Read more...

Launchpad Janitor (janitor) wrote :

[Expired for arista (Ubuntu) because there has been no activity for 60 days.]

Changed in arista (Ubuntu):
status: Incomplete → Expired
José Lou Chang (obake) wrote :

I have the same problem with Arista Transcoder in Ubuntu Gnome 14.04 LTS 64-bit

Changed in arista (Ubuntu):
status: Expired → Confirmed
Lenz Grimmer (lenzgr) wrote :

Another "me too" - this problem still exists in 14.04 LTS

karlrt (karlrt) wrote :

is there any workaround for 14.04 LTS?

Chris Nokes (noki0100) wrote :

I'm still having this issue in 15.04, this feels like it should be simple and easy. Highly annoying.

description: updated
Raubwaldy (raubwaldy) wrote :

is there any workaround yet?

Changed in arista (Ubuntu):
assignee: nobody → Haseem Narvaez (narvaez1701)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers