Problem with GStreamer element ffdeinterlace in Arista

Bug #1306592 reported by Sergio Benjamim on 2014-04-11
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Arista Transcoder
arista (Ubuntu)

Bug Description

Trying to convert a video from .ogv to webm, and i got a message like:

Required plugin could not be found
Python (v2.7) requires to install plugins to support the following multimedia feature: GStreamer element ffdeinterlace

Installed ubuntu-restricted-extras and others gstreamer related, but it does not work.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: arista 0.9.7-5
ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
Uname: Linux 3.13.0-23-generic i686
ApportVersion: 2.14.1-0ubuntu2
Architecture: i386
CasperVersion: 1.340
Date: Fri Apr 11 14:33:57 2014
LiveMediaBuild: Ubuntu 14.04 LTS "Trusty Tahr" - Daily i386 (20140411)
PackageArchitecture: all
 PATH=(custom, no user)
SourcePackage: arista
UpgradeStatus: No upgrade log present (probably fresh install)

Sergio Benjamim (sergio-br2) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in arista (Ubuntu):
status: New → Confirmed
Ibuntu (ibun-do-ubuntu) wrote :

I had the same problem. This was fixed by installing gstreamer0.10-ffmpeg as part of a fix for Ubuntu 14.04 to provide full support for the H.264 codec. Installing gstreamer0.10-ffmpeg provides all of the necessary dependencies that are missing from arista transcoder in 14.04.

sudo apt-get install gstreamer0.10-ffmpeg -y

asala (asala) wrote :

Which repositories do you have? In a clean 14.04 installation, the above command says there is no candidate for installation...
related to I guess.

asala (asala) wrote :

Well, further reading the question, I found
sudo add-apt-repository ppa:mc3man/trusty-media
sudo apt-get update
sudo apt-get install ffmpeg gstreamer0.10-ffmpeg

and that made arista working again (well, restarting arista was needed).

MIKE (firefox599) wrote :

Im a newbie having same problems with arista i keep getting this...... Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

Daniel (pantheist462) wrote :

The repo given here is 404ing. Any other solutions?

Err utopic/main amd64 Packages
  404 Not Found
Err utopic/main i386 Packages
  404 Not Found
Ign utopic/main Translation-en_US
Ign utopic/main Translation-en
Fetched 46.9 kB in 10s (4,616 B/s)
W: Failed to fetch 404 Not Found

W: Failed to fetch 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

YAMCSHA (yamcsha) wrote :

use this ppa to install gstreamer0.10-ffmpeg

sudo add-apt-repository ppa:mc3man/gstffmpeg-keep

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers