Argyll package not maintained

Bug #782584 reported by Andreas Siegert on 2011-05-14
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
argyll (Ubuntu)
High
Till Kamppeter

Bug Description

Binary package hint: argyll

Ubuntu does not maintain Argyll, therefore stone age versions are shipped leading to broken or insufficient calibration device support (For example newer versions contain numerous fixes to make ColorMunki more accurate)
At the time 11.4 was released Argyll 1.3.2 was current, but version 1.1. was shipped.
Current version of Argyll is now 1.3.3

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: argyll 1.1.1-1ubuntu1 [modified: usr/share/color/argyll/ref/strange.cal]
ProcVersionSignature: Ubuntu 2.6.38-9.43-generic 2.6.38.4
Uname: Linux 2.6.38-9-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Sat May 14 12:14:26 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
SourcePackage: argyll
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Andreas Siegert (afx) wrote :
Changed in argyll (Ubuntu):
importance: Undecided → High
Till Kamppeter (till-kamppeter) wrote :

Robert, as you are doing well maintaining gnome-color-manager, could you also keep Argyll up to date and get it into Main? Argyll provides the support for color calibration devices and so it is an important part of operating-system-level color management.

See the Blueprint https://blueprints.launchpad.net/ubuntu/+spec/desktop-o-icc-color-management

Changed in argyll (Ubuntu):
status: New → Confirmed
Changed in argyll (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in argyll (Ubuntu):
assignee: Robert Ancell (robert-ancell) → Till Kamppeter (till-kamppeter)
Changed in argyll (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package argyll - 1.3.3-0ubuntu1

---------------
argyll (1.3.3-0ubuntu1) oneiric; urgency=low

  * Updated Argyll by using the package from Pascal de Bruijn's PPA
    (LP: #782584).
  * argyll-correct-link-command-lines.patch: Correct the linker command lines
    to have the "-l..." arguments for linking with the system's libraries at
    the end. From Oneiric on this is needed.

argyll (1.3.3-0pmjdebruijn2~natty) natty; urgency=low

  * Added Replaces for libicc2 to prevent problems with iccdump/icclu.

argyll (1.3.3-0pmjdebruijn1~natty) natty; urgency=low

  * New upstream release.

argyll (1.3.0-3) experimental; urgency=low

  * Minor future-proofing in debian/rules.
  * Also removed redundant shipping of the firmware-package-builder
    tarball, thanks to Pascal de Bruijn for noticing.

argyll (1.3.0-2) experimental; urgency=low

  * Fixed packaging bugs introduced when un-splitting the source package.

argyll (1.3.0-1) experimental; urgency=low

  * New upstream release.

argyll (1.2.1-1) experimental; urgency=low

  * New upstream bugfix release.
  * Please welcome Xavier Oswald as uploader.

argyll (1.2.0-0) UNRELEASED; urgency=low

  * New upstream release.
  * Unsplit libicc2, built from the same source package again (since
    upstream only ships it as part of Argyll anyway).
  * Bumped Standards-Version to 3.9.1 (no changes).
  * argyll-firmware-spyder2: Moved firmware to /usr/share/color, which is
    freedesktop.org-compliant and (more to the point) where Argyll 1.2.0
    looks for it.
 -- Till Kamppeter <email address hidden> Fri, 05 Aug 2011 09:38:41 +0200

Changed in argyll (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.