Ubuntu

[SRU] Ethernet library: read from Socket broken

Reported by Christian Lins on 2011-10-03
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Arduino
Undecided
Unassigned
arduino (Debian)
Fix Released
Unknown
arduino (Ubuntu)
Medium
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

SRU proposal for Arduino in 11.10 (oneiric)

[Impact] When using the ethernet library and the version of gcc-avr in oneiric, the ethernet shield (i.e. ethernet port on an arduino) doesn't work. This is a very heavily used package in Ubuntu, and many of the users have the ethernet shield

[Development fix] Fixed in Debian Experimental, requestsync for precise. They use the same patch as posted here. Upstream has this bug report and pull request, but hasn't applied it yet.

[Stable fix] See below debdiff

[Test case]: requires specific hardware, but just try compiling the sample webserver for arduino and use it, it won't work. I (showard314) don't have the ethernet shield, but this has been reported in the forums for arduino and the proposed fix in PPA form has been confirmed by two users below.

[Regression potential] Patch only affects ethernet library, and it doesn't work now - so it can't get any worse.

original report below:

Using the Ubuntu version of arduino-core and avr-gcc makes it impossible to get the example Arduino Webserver working.

Reading from the Socket returns garbled output.

The Arduino forum has found as solution, which works for me:
http://arduino.cc/forum/index.php/topic,68624.msg523739.html#msg523739

I've attached a patch for /usr/share/arduino/libraries/Ethernet/utility/w5100.h
---
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
DistroRelease: Ubuntu 11.10
InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
Package: arduino 0022+dfsg-4
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=de_DE
 LANG=de_DE.UTF-8
 LC_MESSAGES=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Tags: oneiric
Uname: Linux 3.0.0-12-generic x86_64
UpgradeStatus: Upgraded to oneiric on 2011-09-01 (31 days ago)
UserGroups: adm admin cdrom dialout fuse lpadmin plugdev sambashare

Christian Lins (cli) wrote :
tags: added: apport-collected oneiric
description: updated

apport information

The attachment "Patch for w5100.h" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

Thanks, I'll through up a PPA for you to test this fix too (I don't have an ethernet shield) and also push this up to Debian.

Changed in arduino (Ubuntu):
assignee: nobody → Scott Howard (showard314)
importance: Undecided → Medium
status: New → In Progress
Changed in arduino (Debian):
status: Unknown → New
Scott Howard (showard314) wrote :

Here's a ppa that you can test it out. It's for the new beta release and there are bugs related to the beta, but if you can try out the ethernet library (I don't have that shield)

https://launchpad.net/~showard314/+archive/ppa

It's committed to the debian repo. When Arduino releases version 1.0, we'll upload the new version and fix.

Changed in arduino (Ubuntu):
status: In Progress → Triaged
assignee: Scott Howard (showard314) → nobody
Christian Lins (cli) wrote :

I've tested your arduino-* packages, Scott. Works fine for me, thanks.

Additionally, I've created a pull request for the patch at the upstream arduino project, see https://github.com/arduino/Arduino/pull/42
Perhaps they pull it eventually...

Changed in arduino (Debian):
status: New → Confirmed
Heath Naylor (arduinology) wrote :

I would like to verify that this in fact works on Ubuntu 11.10, easy enough fix for a very frustrating problem.

Scott Howard (showard314) wrote :

debdiff for SRU

description: updated
summary: - Ethernet library: read from Socket broken
+ [SRU] Ethernet library: read from Socket broken
Scott Howard (showard314) wrote :

Thanks for your comments!

I just filed for this to get fixed in an update to Oneiric. This will be updated to oneiric-proposed and will require your verification. The package won't be able to be updated in oneiric unless we get two users confirming that the fix works. Since I don't have an ethernet shield, we'll be relying on your feedback to get this fixed for everyone else.

Thank you again!

Stéphane Graber (stgraber) wrote :

Uploaded to Oneiric.

Precise will be fixed once the new arduino packages hits experimental and someone asks for a sync.

Changed in arduino (Ubuntu Oneiric):
status: New → Fix Committed
Changed in arduino (Debian):
status: Confirmed → Fix Released

Hello Christian, or anyone else affected,

Accepted arduino into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Christian Lins (cli) wrote :

I've tested the patched version from oneric-proposed and can confirm that it works fine with the Arduino Ethernet board. Thanks! :)

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package arduino - 0022+dfsg-4ubuntu0.1

---------------
arduino (0022+dfsg-4ubuntu0.1) oneiric-proposed; urgency=low

  * Fixed a bug in arduino-core that prevented the ethernet shield from
    working with gcc-avr 4.5.3 (LP: #865266)
 -- Scott Howard <email address hidden> Wed, 19 Oct 2011 10:22:58 -0400

Changed in arduino (Ubuntu):
status: Triaged → Fix Released
Changed in arduino (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.