wrong arguments for jackd

Bug #214256 reported by Vassilis Pandis on 2008-04-08
14
Affects Status Importance Assigned to Milestone
ardour (Ubuntu)
Undecided
Unassigned
jack-audio-connection-kit (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ardour

I'm not sure whether this is an ardour problem or a jackd problem but after installing it it ran jackd with /usr/bin/jackd -T -ndefault -p 128 -T -d alsa -n 2 -r . This is an unusable configuration (a lot of audio skipping) - jackd has to be started with -n 3 (yes this took a while to track down :-).

ardour 1:2.3.1-1
jackd 0.109.2-1ubuntu1
hardy

Vassilis Pandis (pandisv) wrote :
C.Kontros (coryisatm) wrote :

What soundcard are you using? This is most likely a HW and or ALSA issue.

ttoine (ttoine) wrote :

Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02) is the mother board integrated sound chipset, it is in the lspci txt file.

Vassilis, can you try to configure your sound card with qjackctl instead of terminal, and tell what it does ?

Toine

ttoine (ttoine) wrote :

Please include any error message.

It seems that the jackd package is not listed in Launchpad, so it is not possible to report the bug for it.

Toine

Vassilis Pandis (pandisv) wrote :

I will include the output of jack when I get back to my computer. jackd is in the jack-audio-connection-kit source package.

ttoine (ttoine) wrote :

Ardour can not be the problem, it is a jack audio connection kit configuration problem.

Think that your integrated intel sound chipset is not ready for low latency configuration. So first of all, try with something getting a latency around 60ms, and try again to launch ardour. You can try real time kernell if you have the real time kernell and the audio package of ubuntustudio or if you have manually set up pam.

Toine

Changed in ardour:
status: New → Invalid
Vassilis Pandis (pandisv) wrote :

It appears that you are right - ardour is not just running jackd on its own. The offending line is found in ~/.jackdrc :

/usr/bin/jackd -p 128 -T -d alsa -n 2 -r 48000 -p 1024 -d hw:0,0

Running this gives :

pandis@pandis-laptop:~/backup/pandis/music$ /usr/bin/jackd -p 128 -T -d alsa -n 2 -r 48000 -p 1024 -d hw:0,0
jackd 0.109.2
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with System V SHM support.
loading driver ..
apparent rate = 48000
creating alsa driver ... hw:0,0|hw:0,0|1024|2|48000|0|0|nomon|swmeter|-|32bit
control device hw:0
configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 32bit little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 32bit little-endian
ALSA: use 2 periods for playback

**** alsa_pcm: xrun of at least 0.027 msecs

**** alsa_pcm: xrun of at least 0.029 msecs

<gazillions of xrums>

Running with -n 3 fixes the xruns and no audio skips.

ttoine (ttoine) wrote :

Vassilis,

Depending on the mother board chipset, and the sound card chipset, the period (n) should be 2 or 3, most of the time. For exemple, RME hdsp and Echo Audio need 2, Presonus need 3, and for Intel integrated sound chipset, it depends and it is sometine 2, sometime 3.

So I can close the bug.

Toine

ttoine (ttoine) wrote :

Please close the bug

Changed in jack-audio-connection-kit:
status: New → Invalid
Vassilis Pandis (pandisv) wrote :

Hi again. I know that this is a configuration issue and that this depends on my sound card. This is why I changed it to -n 3 . I reported this because things are supposed to work out of the box, without having an average user spend hours digging documentation to find out what alsa, jackd and nperiods are and what values are good for his sound card. This ought to work out of the box. I'm reopening the bug.

Changed in jack-audio-connection-kit:
status: Invalid → New
C.Kontros (coryisatm) wrote :

Please get on a forum or mailing list about this issue. This is a personal configuration issue.

Changed in jack-audio-connection-kit:
status: New → Invalid
Vassilis Pandis (pandisv) wrote :

I'm sorry but I cannot see why I'm being misunderstood. In the summary I state that if it is started with -n 3 IT WORKS. Right now, jackd WORKS for me. The default configuration does NOT work.

Please explain to me how a bad default configuration for software that is able to work on my machine is not a bug.

ttoine (ttoine) wrote :

Vassilis,

First of all, mind that Jack is a professional sound server, such as Asio for Windows and CoreAudio for MacosX. It is not a default configuration. You can see it because when you run it for the first time, there is no .jackdrc file in your home folder. If you run jack in a terminal with options, it will just save the options, so the next time you can run it with the same one.

With your integrated sound card, you don't have anything to set up if you want to use a professional sound software on another system, such as Macos or Windows. It is the same on Linux if you use some soft like Hydrogen, ZynaddsubFX, etc... direct on Alsa, without using Jack.

It is not the same if you would have a professional sound card, like a RME Multiface II, a Motu Traveler, etc... Those cards need a configuration time on all operating systems, depending of the power of the workstation/laptop, the operating system, and the weight of the project you will work on (number of tracks, power needed by the effects and processes, etc...)

First of all, wether you are using MacOsX/CoreAudio, Win/Asio or Linux/Jack, you have to choose at wich latency and definition you want to work. Second, you have to check that your hardware can support it. It means on one hand that the sound card you have can run the latency, the sample rate and bit defintion you want, and on the other hand that the workstation or laptop is able to handle it : cpu, hard drive, chipset and bus frequency, ram, etc... If the hardware can't handle what you want, you need to find the best compromise, and it means configuration time and test again. Untill it works well for what you need, and then you just have to run the good preset. I repeat it, it is the same on every operating system if you want to work with professional audio software

Don't forget that by design, jack is a server. And a server has to be configured. Just try to install a php/apache/mysql on your linux box through Synaptic and see if all will work out of the box like you want : it won't. That' why there have some GUI, a lot of text files, etc... to manage and configure Linux web servers. When all works well, you don't need to configure anymore, just run it. It is the same for Jack. And thanks to the community, there is the good Qjackctl GUI to make it easy to configure and test everything.

So, for me, it is not a bug. Just a miss of knowledge and hardware. I took the time to explain all that stuff because everybody has to begin, and all is not really easy to find and understand about Linux and Ubuntu. And of course, I was not better than you at my own begining.

Toine

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments