[SRU] ardour crashes when saving lv2 plugin preset - bug discovered in lilv

Bug #1877806 reported by Don Himelrick on 2020-05-10
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ardour (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
lilv (Ubuntu)
Status tracked in Groovy
Focal
High
Unassigned
Groovy
Undecided
Unassigned

Bug Description

[Impact]

 * Users of Ardour who wish to use LV2 audio plugins and make settings
   presets are running into an issue where they are unable to save changes
   to their presets. Attempts simply crash the application.

 * This has been only been observed in Ubuntu 20.04 LTS. Attempts to
   reproduce the behavior on 18.04, 19.10, and Groovy Gorilla proved
   fruitless.

 * Upon investigation, the bug was a regression in lilv 0.24.6 which was
   corrected in 0.24.8 per https://github.com/lv2/lilv/issues/32 and its
   attached commit. This commit, and commits from the same day, have been
   cherry-picked into patches for this upload. This upload is versioned as
   0.24.6-1ubuntu0.1.

[Test Case]

 * In Ardour, start a new project, go to the Mixer view.

 * Add a track to the project

 * Add any LV2 plugin to the track

 * Open the LV2 plugin interface via a double-click on the plugin

 * Save a "New" preset, use any name.

 * Make a change to the plugin state (any parameter), click "Save".
   Ardour will crash.

[Regression Potential]

 * This library (lilv) affects LV2 plugins and only LV2 plugins. Version
   0.24.8 contains a number of bugfixes to enhance the stability of LV2
   plugins, including the bugfix mentioned. Many of those bugfixes were
   cherry-picked into patches.

 * Even though these patches contain a number of bug fixes, there is always
   potential for some regression in LV2 plugins to occur, such as
   misbehavior or other regressions similar to this particular bug.

[Other Info]

 * The diff in this case may be quite large due to the number of bugs
   fixed.

 * None of the included patches contain new features as far as I can tell.

Original bug report follows:

The few lv2 plugins I have tried all crash ardour when I click on "save" to save the preset. Clicking Add to create a new plugin doesn't crash, but it also does not save the preset. If you load a plugin preset already created and then click save, you end up wiping out the contents of the preset direcoty in ~/.lv2. The .ttl files are deleted and you end up with an empty directoy. The only thing printed on the console when this happens is this:

CALF DEBUG: instance 0x55c00d102860 data 0x55c01ca1cf10
CALF DEBUG: calf 0x7f8d31f7b0f0 cpi 0x7f8d31783ca0
Segmentation fault (core dumped)

AFAIK, teh preset add and save functions work for ladspa plugins.

-Don

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: ardour 1:5.12.0-3ubuntu4
ProcVersionSignature: Ubuntu 5.4.0-29.33-lowlatency 5.4.30
Uname: Linux 5.4.0-29-lowlatency x86_64
ApportVersion: 2.20.11-0ubuntu27
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: XFCE
Date: Sat May 9 21:39:09 2020
InstallationDate: Installed on 2020-04-26 (13 days ago)
InstallationMedia: Ubuntu-Studio 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
SourcePackage: ardour
UpgradeStatus: No upgrade log present (probably fresh install)

Don Himelrick (astrodon2001) wrote :
Don Himelrick (astrodon2001) wrote :

FYI, this is reproducible on a fresh install on a completely different system. Also, this affects ALL lv2 plugins that I have tried. The ladspa plugin presets seem to work.

Erich Eickmeyer (eeickmeyer) wrote :

I was able to reproduce this with a plugin from LSP Plugins. That said, the Ardour team is on the verge of releasing Ardour 6.0, and is not interested in fixing bugs in 5.12. This means this bug probably will see no response, but I will check with the team and report back.

no longer affects: calf (Ubuntu)
Changed in ardour (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Erich Eickmeyer (eeickmeyer) wrote :

This appears to be a bug in lilv. Per https://github.com/lv2/lilv/issues/32, this is fixed in the version of lilv in Groovy Gorilla (future 20.10) and we'll have to do a Stable Release Update to get this fixed in Ubuntu 20.04.

Changed in ardour (Ubuntu):
status: Confirmed → Triaged
Changed in lilv (Ubuntu Groovy):
status: New → Fix Released
Changed in lilv (Ubuntu Focal):
status: New → Confirmed
Changed in ardour (Ubuntu Focal):
status: New → Triaged
Changed in ardour (Ubuntu Groovy):
importance: Medium → Undecided
Changed in lilv (Ubuntu Focal):
importance: Undecided → High
Changed in ardour (Ubuntu Groovy):
status: Triaged → Fix Released
no longer affects: ardour (Ubuntu Groovy)
Changed in lilv (Ubuntu Focal):
assignee: nobody → Erich Eickmeyer (eeickmeyer)
Changed in lilv (Ubuntu Focal):
status: Confirmed → In Progress
Changed in ardour (Ubuntu):
status: Fix Released → Triaged
Erich Eickmeyer (eeickmeyer) wrote :

Attached is the debdiff for update of package from 0.24.6 to 0.24.8.

description: updated
summary: - ardour crashes when saving lv2 plugin preset
+ [SRU] ardour crashes when saving lv2 plugin preset - bug discovered in
+ lilv
Changed in lilv (Ubuntu Focal):
assignee: Erich Eickmeyer (eeickmeyer) → nobody
status: In Progress → Confirmed
Don Himelrick (astrodon2001) wrote :

Ok, thanks! Let me know if you would like me to do some testing of the new package. If so, also please let me know where to find it.

Erich Eickmeyer (eeickmeyer) wrote :

Unsubscribed sponsors, upload is in queue. Awaiting SRU team response.

Erich Eickmeyer (eeickmeyer) wrote :

Unsubscribing SRU team. The package is going to have to be redone, sadly.

description: updated
Erich Eickmeyer (eeickmeyer) wrote :

SRU team resubscribed, upload in queue. Awaiting SRU review.

Don: In the meantime, you can feel free to test using my ppa at https://launchpad.net/~eeickmeyer/+archive/ubuntu/lilv.

description: updated
Changed in ardour (Ubuntu Focal):
status: Triaged → Invalid
Changed in ardour (Ubuntu):
status: Triaged → Invalid

Hello Don, or anyone else affected,

Accepted lilv into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lilv/0.24.6-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in lilv (Ubuntu Focal):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-focal
Erich Eickmeyer (eeickmeyer) wrote :

As one who was affected by this bug, I have verified that the fix does indeed work. I have followed the steps in [Test Case] outlined above and was unable to reproduce the issue using the fixed package.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Don Himelrick (astrodon2001) wrote :

Hi Erich, I was able to test this today. I completed the test case outlined above with no problems. It does fix the issue I reported.

Thanks!
Don

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lilv - 0.24.6-1ubuntu0.1

---------------
lilv (0.24.6-1ubuntu0.1) focal; urgency=medium

  * Fixes for ardour crashes when saving plugin state (LP: #1877806)

 -- Erich Eickmeyer <email address hidden> Wed, 20 May 2020 11:04:07 -0700

Changed in lilv (Ubuntu Focal):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for lilv has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.