Rebuild for libmpcdec3 → libmpcdec6 transition

Bug #611024 reported by Anders Kaseorg
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
aqualung (Ubuntu)
Undecided
Unassigned
cmus (Ubuntu)
Undecided
Unassigned
cynthiune.app (Ubuntu)
Undecided
Unassigned
gst-plugins-bad0.10 (Ubuntu)
Undecided
Unassigned
k3b (Ubuntu)
Undecided
Unassigned
libtunepimp (Ubuntu)
Medium
Unassigned
moc (Ubuntu)
Undecided
Unassigned
mpc123 (Ubuntu)
Undecided
Unassigned
mpd (Ubuntu)
Undecided
Unassigned
mplayer (Ubuntu)
Undecided
Unassigned
qmmp (Ubuntu)
Undecided
Unassigned
vlc (Ubuntu)
Undecided
Unassigned
xine-lib (Ubuntu)
Undecided
Unassigned
xmms2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: aqualung

The libmpcdec3 binary package was incorrectly deleted from the maverick archive before libmpcdec6 was added (bug 598874, bug 610856), so now the following rdeps are uninstallable and need to be rebuilt:

libmpcdec3
  Reverse Depends: aqualung (0.9~beta11-1ubuntu3)
  Reverse Depends: cmus (2.3.3-1)
  Reverse Depends: cynthiune.app (0.9.5-7.1ubuntu2)
  Reverse Depends: gstreamer0.10-plugins-bad (0.10.19-1ubuntu2)
  Reverse Depends: libk3b6 (2.0.0-0ubuntu3)
  Reverse Depends: libqmmp-misc (0.4.1-1build1)
  Reverse Depends: libtunepimp5 (0.5.3-7.3ubuntu1)
  Reverse Depends: libtunepimp5-mp3 (0.5.3-7.3ubuntu1)
  Reverse Depends: libxine1-misc-plugins (1.1.18.1-4ubuntu2)
  Reverse Depends: mencoder (2:1.0~rc3++final-0ubuntu3)
  Reverse Depends: moc (1:2.5.0~alpha4+svn20091009-1build2)
  Reverse Depends: mpc123 (0.2.4-1)
  Reverse Depends: mpd (0.15.10-1ubuntu2)
  Reverse Depends: mplayer (2:1.0~rc3++final-0ubuntu3)
  Reverse Depends: mplayer-gui (2:1.0~rc3++final-0ubuntu3)
  Reverse Depends: vlc-nox (1.1.1-1+exp1ubuntu1)
  Reverse Depends: xmms2-plugin-musepack (0.7DrNo-7.1)

Revision history for this message
Anders Kaseorg (andersk) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

 affects ubuntu/aqualung
 affects ubuntu/cmus
 affects ubuntu/cynthiune.app
 affects ubuntu/gst-plugins-bad0.10
 affects ubuntu/k3b
 affects ubuntu/libtunepimp
 affects ubuntu/moc
 affects ubuntu/mpc123
 affects ubuntu/mpd
 affects ubuntu/mplayer
 affects ubuntu/qmmp
 affects ubuntu/vlc
 affects ubuntu/xine-lib
 affects ubuntu/xmms2
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.14 (GNU/Linux)

iQGcBAEBCAAGBQJMUIq7AAoJEN/zqzdPFvc6L9gL/2Y0YgOQUTOJi6WdJhUu0jh2
knleXX6UsPMv1/pNls2OkmIkoYEI1ra+J+4B2NtzkCRxFmhs+MdKqsnpZeNuHdY3
sZLrtOHsC80Roa3JHzBRQtkAIyuTN0EPmd9YFonLQhaQIC9C9bN2ZWCKiSfmYFyp
Gatk/M9a4VdzMtu3BtpsEOXnu02eUkdzXnYH2gIqYdBtb+Nj/4y0F88e7tphXbQb
ZNTETXQiaYwY9kRKcLeF3XQTLF1tBEjfj1+M84TgtiMYMep+Eed6qCb/NDh8oLEt
NAnASHOgX+AY0PpSaNyjHEa1AenG9tFsL/9waGXJoVP82vX8xAJveAEagqWdLGG2
2vrE0eP6/BC2N1nXumtBe3GwXjGpmWUh6mFEz1LdY4ao+c7Haag2L599a+dKuIPx
hQ7/jJvRXFBZoNmQLD3c3k6pG6aMgu8wuEcNEiGIcIAcRH/Ip0QdzHtgLf+h2r1e
/cjUAS4mU3RbRMQbVKxoCu7pqVIWTPt1pH+wnPIoeQ==
=h86X
-----END PGP SIGNATURE-----

Revision history for this message
Jonathan Thomas (echidnaman) wrote :

Xine's already fixed. ;)

Changed in xine-lib (Ubuntu):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package k3b - 2.0.0-0ubuntu4

---------------
k3b (2.0.0-0ubuntu4) maverick; urgency=low

  * No-change rebuild to pick up new libmpdec (LP: #611024)
 -- Jonathan Thomas <email address hidden> Wed, 28 Jul 2010 16:53:45 -0400

Changed in k3b (Ubuntu):
status: New → Fix Released
Revision history for this message
Alessio Treglia (quadrispro) wrote :

cmus (2.3.3-1build1) maverick; urgency=low

 * No-change rebuild to pick up new libmpdec (LP: #611024).

Changed in cmus (Ubuntu):
status: New → Fix Released
Revision history for this message
Alessio Treglia (quadrispro) wrote :

aqualung aqualung 0.9~beta11-1ubuntu4 fixes this.

Changed in aqualung (Ubuntu):
status: New → Fix Released
Revision history for this message
Alessio Treglia (quadrispro) wrote :

qmmp 0.4.1-1build2 fixes this.

Changed in qmmp (Ubuntu):
status: New → Fix Released
Revision history for this message
Alessio Treglia (quadrispro) wrote :

xmms2 0.7DrNo-7.1build1 fixes this

Changed in xmms2 (Ubuntu):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mpd - 0.15.10-1ubuntu3

---------------
mpd (0.15.10-1ubuntu3) maverick; urgency=low

  * No-change rebuild to pick up new libmpdec (LP: #611024)
 -- Alessio Treglia <email address hidden> Thu, 29 Jul 2010 14:57:57 +0200

Changed in mpd (Ubuntu):
status: New → Fix Released
Revision history for this message
Alessio Treglia (quadrispro) wrote :
Revision history for this message
Alessio Treglia (quadrispro) wrote :

libtunepimp is part of the main component, please upload libtunepimp_0.5.3-7.3ubuntu2.debdiff for me.

Changed in libtunepimp (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Alessio Treglia (quadrispro) wrote :

2:1.0~rc4~try1-1ubuntu1 should fix this for mplayer

Changed in mplayer (Ubuntu):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mpc123 - 0.2.4-1.1build1

---------------
mpc123 (0.2.4-1.1build1) maverick; urgency=low

  * No-change rebuild to pick up new libmpdec (LP: #611024)
 -- Alessio Treglia <email address hidden> Thu, 29 Jul 2010 15:04:41 +0200

Changed in mpc123 (Ubuntu):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package moc - 1:2.5.0~alpha4+svn20091009-1build3

---------------
moc (1:2.5.0~alpha4+svn20091009-1build3) maverick; urgency=low

  * No-change rebuild to pick up new libmpdec (LP: #611024)
 -- Alessio Treglia <email address hidden> Thu, 29 Jul 2010 15:06:12 +0200

Changed in moc (Ubuntu):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libtunepimp - 0.5.3-7.3ubuntu2

---------------
libtunepimp (0.5.3-7.3ubuntu2) maverick; urgency=low

  * No-change rebuild to pick up new libmpdec (LP: #611024)
 -- Alessio Treglia <email address hidden> Thu, 29 Jul 2010 15:00:41 +0200

Changed in libtunepimp (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Harry (harry33) wrote :

When vlc is rebuilt against libmpcdec6, the new vlc version should be used too (1.1.2).

Benjamin Drung (bdrung)
Changed in vlc (Ubuntu):
assignee: nobody → Benjamin Drung (bdrung)
tags: added: patch
Revision history for this message
dummy9010 (aperto1973) wrote :

I have the same problem with Totem (default media player).

Revision history for this message
Anders Kaseorg (andersk) wrote :

dummy9010: I assure you that you don’t. This bug manifests as an inability to install certain packages, but totem is not one of them. If you are having problems with Totem, please file a different bug, or a question at https://answers.launchpad.net/ .

Revision history for this message
Harry (harry33) wrote :

The vlc update (vlc 1.1.1-1+exp1ubuntu2) solves the libmpcdec6 issue in maverick (fix released).
However, the new release of vlc (1.1.2) could have been used already.

Revision history for this message
Micah Gersten (micahg) wrote : Re: [Bug 611024] Re: Rebuild for libmpcdec3→ libmpcdec6 transition

I don't think the new version was upgraded because we're in freeze for
Alpha 3 and vlc is seeded for Mythbuntu. Don't worry, 1.1.2 will be coming.

On 08/05/2010 01:57 AM, Harry wrote:
> The vlc update (vlc 1.1.1-1+exp1ubuntu2) solves the libmpcdec6 issue in maverick (fix released).
> However, the new release of vlc (1.1.2) could have been used already.
>
>

Changed in vlc (Ubuntu):
status: New → Fix Released
Revision history for this message
Benjamin Drung (bdrung) wrote :

I have uploaded 1.1.2-1+exp1ubuntu1. It took longer than I thought.

Changed in vlc (Ubuntu):
assignee: Benjamin Drung (bdrung) → nobody
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gst-plugins-bad0.10 - 0.10.19-1ubuntu3

---------------
gst-plugins-bad0.10 (0.10.19-1ubuntu3) maverick; urgency=low

  * No-change rebuild to pick up new libmpdec (LP: #611024).
 -- Benjamin Drung <email address hidden> Tue, 10 Aug 2010 15:10:09 +0200

Changed in gst-plugins-bad0.10 (Ubuntu):
status: New → Fix Released
Revision history for this message
Fabrice Coutadeur (fabricesp) wrote :

Fixed with latest upload

Changed in cynthiune.app (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers