aqsis: Cannot install: unmet dependencies

Bug #234414 reported by Fabio Zottele
22
Affects Status Importance Assigned to Milestone
aqsis (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

Binary package hint: aqsis

Description: Ubuntu 8.04
Release: 8.04

I can'y install aqsis.
error in dependencies: aqsis-libsc2a, libopenexr2c2a

Emmet Hikory (persia)
Changed in aqsis:
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Mike Roberts (m.roberts) wrote :

Confirmation here. same error.

Revision history for this message
tonioLeRital - Antoine Schellenberger (schellenberger) wrote :

aqsis-libsc2a can't resolve libopenexr2c2a because it has been replaced by libopenexr2ldbl.
So, while waiting the package maintainer make a new DEB release, you can make your own aqsis-libsc2 DEB working by modifying the deb dependencies located in the control file of the deb archive:

1. First, Install libopenexr2ldbl:
      sudo apt-get install libopenexr2ldbl

2. Download the corrupted aqsis-libsc2 : aqsis-libsc2a_1.2.0-2_i386.deb

3. Extract the .deb:
      dpkg-deb -x ./aqsis-libsc2a_1.2.0-2_i386.deb aqsis-libsc2

4. Extract the DEBIAN files(control, postinst,...):
      dpkg-deb -e ./aqsis-libsc2a_1.2.0-2_i386.deb aqsis-libsc2/DEBIAN

5. Replace the "libopenexr2c2a" occurency by "libopenexr2ldbl" in aqsis-libsc2/DEBIAN/control (or download the attached file)
      (the libopenexr2ldbl seems to be the substitute of libopenexr2c2a in hardy H.)

6. Make your new DEB:
      fakeroot dpkg-deb -b aqsis-libsc2/ aqsis-libsc2a_1.2.0-2_i386.deb

7. Install your new DEB (eventually resolves the dependencies before):
      sudo dpkg -i ./aqsis-libsc2a_1.2.0-2_i386.deb

8. Install aqsis
      sudo apt-get install aqsis

Enjoy!

Revision history for this message
Luca Falavigna (dktrkranz) wrote :

This is fixed in Intrepid.
In order for this to be fixed in Hardy, both aqsis and scons need to be SRUed. If you want, I can manage this task.

Changed in aqsis:
status: Confirmed → Fix Released
Revision history for this message
David Miller (david3d) wrote :

You know more about the full scope of the problem than I do so I'll leave it up to your judgment. But I think it would be nice to get Aqsis working properly in the LTS version of Ubuntu without the hoops. The SRU in this case shouldn't effect any aqsis users since it's currently not installable. Unless upgrading from Gusty to Hardy with Aqsis installed worked. Would any patches be required in scons that may effect other packages? If not then I don't see much to hold up getting approval for SRU.

Revision history for this message
Cray Zee (bugs-jemjie) wrote :

I can confirm this. It would be nice if it was fixed before Intrepid. :)

Revision history for this message
Jens Albrecht (jsalbrec-linux) wrote :

I'm newbie to Linux. I can't install aqsis on Ubuntu 8.04 64-bit version as well. Need advice for workaround on 64-bit platform. Thanks.

Revision history for this message
lestermano (lestermano) wrote :

Hope this helps, I found this on the Ubuntu French site.
They have a fixed aqsis-libsc2a deb package.

Worked great for me.

http://doc.ubuntu-fr.org/makehuman

Revision history for this message
KeithCu (keithcu) wrote :

This bug should just be fixed.

If you add up all the people who have wasted time on this bug, like me, it dwarfs the amount of time it would take to make this problem go away!

Revision history for this message
Fabio Zottele (fabio-zottele-gmail) wrote : Re: [Bug 234414] Re: aqsis: Cannot install: unmet dependencies

Sorry, I really don't understand the meaning of what you're saying.

2008/7/28 keithCu <email address hidden>

> This bug should just be fixed.
>
> If you add up all the people who have wasted time on this bug, like me,
> it dwarfs the amount of time it would take to make this problem go away!
>
> --
> aqsis: Cannot install: unmet dependencies
> https://bugs.launchpad.net/bugs/234414
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "aqsis" source package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: aqsis
>
> Description: Ubuntu 8.04
> Release: 8.04
>
> I can'y install aqsis.
> error in dependencies: aqsis-libsc2a, libopenexr2c2a
>

--

dott.ing. Fabio Zottele
Ing. civile ed ambientale, industriale e dell'informazione
ISCR. ALBO N° 2912 - Sezione A degli Ingegneri -Provincia di Trento
via R. Guardini, 63 - 38100 Trento

Revision history for this message
jd (hoakoduo) wrote :

Fabio Zottele wrote:
> Sorry, I really don't understand the meaning of what you're saying.
I think he means: Why isn't this bug just fixed?

>
> 2008/7/28 keithCu <email address hidden>
>
>> This bug should just be fixed.
>>
>> If you add up all the people who have wasted time on this bug, like me,
>> it dwarfs the amount of time it would take to make this problem go away!
>>
I did make a script to automate this task and an alternative package.
http://www.k-3d.org/wiki/User:JoaquinDuo/Fix_aqsis-libsc2a

Cheers!
Joaquín

Revision history for this message
Fabio Zottele (fabio-zottele-gmail) wrote :

Thankyou for your effort!

--

dott.ing. Fabio Zottele
Ing. civile ed ambientale, industriale e dell'informazione
ISCR. ALBO N° 2912 - Sezione A degli Ingegneri -Provincia di Trento
via R. Guardini, 63 - 38100 Trento

Revision history for this message
Michael Gefen (gefenm11) wrote :

using the above manual, attached amd64 version of the fixed package

Revision history for this message
akpraha (jay-a-key) wrote :

It's now 2009. Should we expect a fix for this seemingly trivial problem sometime this year?

no longer affects: aqsis (Ubuntu Hardy)
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers