Firefox asks which application it must use for apt links

Bug #576944 reported by Mohamed Amine Ilidrissi on 2010-05-07
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
Ubufox Extension
Undecided
Unassigned
apturl (Ubuntu)
Medium
collinp

Bug Description

Binary package hint: firefox

Firefox is asking for the application it must use to open apt links. The behavior expected is to open it automatically using apturl.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: firefox 3.6.3+nobinonly-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Fri May 7 12:46:52 2010
FirefoxPackages:
 firefox 3.6.3+nobinonly-0ubuntu4
 firefox-gnome-support 3.6.3+nobinonly-0ubuntu4
 firefox-branding 3.6.3+nobinonly-0ubuntu4
 abroswer N/A
 abrowser-branding N/A
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100318)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: firefox

Scott Ritchie (scottritchie) wrote :

Confirmed regression in Lucid over previous releases

Changed in firefox (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Vish (vish) on 2010-07-18
Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Triaged
Changed in hundredpapercuts:
importance: Low → Medium
collinp (collinp) on 2010-07-26
Changed in firefox (Ubuntu):
assignee: nobody → Collin Pruitt (hellow)
status: Triaged → In Progress
Changed in hundredpapercuts:
assignee: nobody → Collin Pruitt (hellow)
status: Triaged → In Progress
collinp (collinp) on 2010-07-26
Changed in ubufox:
assignee: nobody → Collin Pruitt (hellow)
status: New → In Progress
tags: added: firefox ubufox
collinp (collinp) on 2010-07-26
Changed in ubufox:
assignee: Collin Pruitt (hellow) → nobody
status: In Progress → Invalid
Ivanka Majic (ivanka) on 2010-07-27
tags: added: rhubarb
Chris Coulson (chrisccoulson) wrote :

This is an apturl bug (it should ship the appropriate preferences if it want's to be a protocol handler for apt URL's)

affects: firefox (Ubuntu) → apturl (Ubuntu)
Chris Coulson (chrisccoulson) wrote :

apturl used to ship a preferences file, but doesn't any more. That should be resurrected (I've already confirmed the old preferences file still works)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apturl - 0.4.1ubuntu5

---------------
apturl (0.4.1ubuntu5) maverick; urgency=low

  * Fix LP: #576944 - Move the Firefox preferences to /etc/firefox
    - update setup.py
    - add debian/apturl-common.postinst
    - add debian/apturl-common.preinst
  * Don't install apturl.js in /usr/share/firerox - Firefox doesn't see this
    - update debian/apturl-common.install
    - update setup.py
  * Add a couple of extra preferences for Firefox
    - update data/apturl.js
 -- Chris Coulson <email address hidden> Tue, 27 Jul 2010 13:46:22 +0100

Changed in apturl (Ubuntu):
status: In Progress → Fix Released
Vish (vish) wrote :

@Collin Pruitt, looks like Chris got to this one. :-)
Have a look at the other papercuts<https://bugs.launchpad.net/hundredpapercuts/+bugs?field.status%3Alist=TRIAGED> instead ;-)

Changed in hundredpapercuts:
assignee: Collin Pruitt (hellow) → nobody
status: In Progress → Fix Released

Hello Customer

We found a way out for you - now you can pay for as many watches as a lot of style changes you have.
Now you can afford expensive - and classy-looking watch to impress people with, just purchase top quality replica watch or some watches for different occasions. We don't offer cheap imitations. Our watches make you look rich and feel rich. Great selection of most popular brands and models!

****************************
EXCELLENT TRANSACTION.....Pleasure to do business with....Prompt and courteous. Buy with confidence from this company...Beautiful timepiece!!
Thank
                     Ella Levine
****************************

Click here ---> http://neang.ru

henlem (burnalot) wrote : Bracelet

Hello Customer

Fast, knowledgeable and responsive response to customer service requests regarding all product and order matters.
You can prefer any watch for her that matches her taste and your resources.

--------------------------------
Today I have received the watch, it is really very beautiful!
Thanks!
                     Tracy Garrison
--------------------------------

Click here ---> http://phoem.ru

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers