Ubuntu

adobe-flashplugin is virtual error when installing flash from Adobe site.

Reported by Neil Wilson on 2010-04-03
104
This bug affects 18 people
Affects Status Importance Assigned to Milestone
apturl
New
Undecided
Unassigned
apturl (Ubuntu)
Undecided
Atcr678
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher

Bug Description

Binary package hint: apturl

The apt link on the Adobe Flash download site doesn't work with Lucid and Maverick. You get and 'adobe-flashplugin' is virtual error message.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: apturl 0.4.1ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
Architecture: amd64
Date: Sat Apr 3 08:16:58 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100224.1)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: apturl

Neil Wilson (neil-aldur) wrote :
Neil Wilson (neil-aldur) wrote :

http://get.adobe.com/flashplayer/

Select 'Apt for Ubuntu 9.04+' from the menu and click download.

aphixe (aphixe) wrote :

I tried that, it didn't work

Neil Wilson (neil-aldur) wrote :

Yeah that's the problem. So that makes this bug confirmed.

Changed in apturl (Ubuntu):
status: New → Confirmed
Casey Reed (casey20) wrote :

Yes, I have the same problem. So is there a solution to get flash?

Atcr678 (adamtudor) on 2010-04-07
Changed in apturl (Ubuntu):
assignee: nobody → Atcr678 (adamtudor)
Tigra Nator (tigrawap) wrote :

also have same bug...

10.04 x64

Elly (elaineci37) wrote :

I have this bug too.... (Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)

Nick Johannes (njohannes) wrote :

http://www.myscienceisbetter.info/install-native-64bit-flash-player-10-on-linux.html

Worked for me in the end.

I attempted to force the dpkg with 'dpkg --force-architecture -i install_flash_player_10_linux.deb' with no success.

I'm running Ubuntu Server 10.04 64bit Release Candidate with the desktop installed:
sudo apt-get install ubuntu-desktop

I went to http://get.adobe.com/flashplayer/ and then tried to download and install using the "APT for Ubuntu 9.04+"

I was then prompted to add a partner software channel up which I accepted by clicking the "Yes" button.

An installation began, but ended with the following message:

"Package 'adobe-flashplugin' is virtual" with "Close" being the only option.

I then tried to play a youtube video, and it didn't work.

Elly (elaineci37) wrote :

Lonnie, try this method https://help.ubuntu.com/community/RestrictedFormats/Flash

Let me know if it works for you.....I'm sure it will because I had a similar problem as you....

Daniel Ellis (danellisuk) wrote :

I think we can see from above that this is only effecting 64bit. I have tried this on Ubuntu 10.04 Netbook Remix and it was fine. And it failed on Ubuntu 10.04 Desktop x64.

I had the same issue and Elly's link worked for me. Thanks!

rkolb86 (rkolb86) wrote :

yeah...It works fine on the 32bit version without issues. Doesn't work on 64bit

Thanks Elly, it worked for me too. I guess it is only a problem for 64 bit pc, because adobe has not released a final version of flash.

MSA Operations (info-marksoft) wrote :

Hi All. The error message about the plugin being "virtual" is very misleading, particularly for those trying out Ubuntu in a virtual environment (VirtualBox, VMware, etc).

This error is directly related to Adobe not recognising the 64-bit environment, even though they do provide a 64-bit version of the Flash plug-in for Linux. Go figure.

Simplest solution I've found (Yes, it works!)
http://mattrudge.wordpress.com/2010/05/03/installing-flash-player-on-ubuntu-10-04-64-bit/

Tim Booth (tbooth) wrote :

Hi,

The standard solution for this is to enable the 'multiverse' repo and then install flashplugin-installer. This basically does the same as the scripts linked above but in a neater way, and doesn't trample on the 'alternatives' system.

To see what Ubuntu thinks it is using as the current Flash plugin:

update-alternatives --display firefox-flashplugin

To install the above along with various other non-free multimedia stuffs:

sudo apt-get install ubuntu-restricted-extras

Adobe do have an alpha version of the 64-bit player:

http://labs.adobe.com/technologies/flashplayer10/64bit.html

But if you want reliable Flash then the best current solution is to use the 32-bit Flash with npwrapper, which is what the flashplugin-installer currently does for you.

I've just tried all the above on a fairly fresh installation of 10.04 RC1, so I hope it all works for you too.

Cheers,

TIM

Tim Booth (tbooth) wrote :

An addendum:

It appears that the plugin used for flash in Firefox is actually controlled by the 'mozilla-flashplugin' alternative, contrary to what I said above.
So - if you want to try out the native pre-release 64-bit plugin from Adobe in Firefox without first uninstalling any alternative Flash plugins, then you have to do this:

sudo update-alternatives --install /usr/lib/mozilla/plugins/flashplugin-alternative.so mozilla-flashplugin /var/lib/flashplugin/libflashplayer.so 55

Before this will work you'll need to download the tarball from Adobe labs and unpack the libflashplayer.so file somewhere - I used /var/lib/flashplugin as it seemed sensible. If the file isn't there then the above command will complain.

The last argument, 55, makes this option a higher priority alternative so it should then be used automatically. You can do this to inspect or switch the setting:

sudo update-alternatives --config mozilla-flashplugin

So now my question to Ubuntu developers is: why is the flash plugin for Firefox controlled by the mozilla-flashplugin alternative and not the firefox-flashplugin alternative (or any of the other related alternatives)? Is this documented anywhere or is it just something that needs tidying up and fixing?

Cheers,

TIM

Scott Ritchie (scottritchie) wrote :

A simple fix for this is to tell Adobe to link to flashplugin-installer instead of adobe-flashplugin

Alternatively we could modify the flashplugin-installer package to ship a dummy adobe-flashplugin package that depended on flashplugin-installer.

description: updated
demosthenesk (demosthenesk) wrote :

There is a solution from

Source: http://www.justin.my/2010/08/solvedpackage-adobe-flashplugin-is-virtual-on-64bit-ubuntu-10-04/

you can try

sudo add-apt-repository ppa:sevenmachines/flash && sudo apt-get update && sudo apt-get install flashplugin64-installer

Joseph Sausa (josephsausa) wrote :

Package 'adobe-flashplugin' is virtual.

MoneyTrail (judgeday) wrote :

Hi , i got the same problem
i uninstall the flas plugin first over the USC and then i try to install it over the adobe website
it always tells me adobe-flashplugin' is virtual error message.

so i use ubuntu tweak to install it and this time it still works i test the version of flash plugin at the adobe test website and it is the newest version ,

but i think the is just an other way to do , at the apt url over the adobe website and try to install the plugin over the " USC " Ubuntu Software Center

after this check your version at www.adobe.com/software/flash/about/

now it should be done !!!

P.S.:
sorry about my Chaos english ;-)

MoneyTrail (judgeday) wrote :

So i forgot to tell you about , I using Ubuntu 10.04.3 64 Bit

terakin (terakinizers) wrote :

Today, as Adobe released Flash 11 (officially 64 bit compatible), I tried to download it from Adobe site, and encountered same problem. By selecting "Linux (64-bit)" and "Ubuntu (apt)", Firefox urged me to use apturl to process the download. Then, popup window said that I need to add new repository "lucid-partner", and after processing repositories, another popup told "adobe-flashplugin is virtual package". I am using Lucid 64bit (10.04 LTS) and already installed beta version of 11 from tarball (so, not urgent).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions