apturl doesn't work with Firefox

Bug #476853 reported by Romain Henriet
256
This bug affects 54 people
Affects Status Importance Assigned to Milestone
apturl (Ubuntu)
Low
Rus Robert Mirel
Nominated for Karmic by Heimen Stoffels
Nominated for Lucid by Emilio
Nominated for Maverick by RussianNeuroMancer

Bug Description

Binary package hint: apturl-kde

It works with konqueror but not with firefox, even after copying /usr/share/firefox/plugin/apturl.js into user's profile.
Firefox says apt protocol is not associated to any program.

ProblemType: Bug
Architecture: amd64
Date: Fri Nov 6 20:55:59 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Kubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: fglrx
Package: apturl-kde 0.4.1ubuntu2
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: apturl
Uname: Linux 2.6.31-14-generic x86_64

Revision history for this message
Romain Henriet (romain-henriet) wrote :
Revision history for this message
Micah Gersten (micahg) wrote :

Moving to Ubufox for triage.
Thank you for reporting this to Ubuntu. Do you have ubufox installed?

affects: apturl (Ubuntu) → ubufox (Ubuntu)
Changed in ubufox (Ubuntu):
status: New → Incomplete
Revision history for this message
Romain Henriet (romain-henriet) wrote :

Yes Ubufox is installed

Revision history for this message
Jonathan Thomas (echidnaman) wrote :

Confirming. (ubufox is installed here too)

Changed in ubufox (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
mrtymek (dizzasta) wrote :

Ubufox and apturl-kde installed, both dpkg reconfigured, and nothing seems to work...
Kubuntu 9.10 x86

Revision history for this message
João Pinto (joaopinto) wrote :

As a workaround you can install the firefox-gnome-support package .

Revision history for this message
lengoanhcat (lengoanhcat) wrote :

Hi everyone, I have the same problem stated above. I try to install firefox-gnome-support package but it does not work as well.

Revision history for this message
Micah Gersten (micahg) wrote :

Can someone who's having this issue check to see if there are any entries in /var/log/kern.log about apparmor blocking Firefox access to apturl?

Changed in ubufox (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
lippol94 (lippol94) wrote :

That's a problem that has already resolved in Ubuntu Wiki.
This is the page translated from italian wiki
http://bit.ly/5XjhfC

Byee!!

Revision history for this message
Jonathan Richards (jnorichards) wrote :

lippol94 alleged: "That's a problem that has already resolved in Ubuntu Wiki."

The problem is NOT resolved.

The suggested changes do not allow Firefox to recognise an apt:// url, but it issues a dialog box
'Firefox doesn't know how to open this address, because the protocol (apt) isn't associated with any program.'

This is Firefox version 3.5.6 Mozilla Firefox for Ubuntu canonical - 1.0 running on Kubuntu 9.10 fully updated.

AptURL is installed:

jonathan@odin:~$ file $(which apturl)
/usr/bin/apturl: POSIX shell script text executable

jonathan@odin:~$ file $(which apturl-kde)
/usr/bin/apturl-kde: python script text executable

about:config settings are exactly as described for Firefox 3 at https://help.ubuntu.com/community/AptURL

Micah Gersten asked about kern.log entries: there is nothing in my /var/log/kern.log relevant to this issue.

Revision history for this message
dmanhog (dmanhog-yahoo) wrote :

I couldn't get getdeb to work with konqueror or firefox but after installing the getdeb repository it does work with chromium at least for me. This does not fix the problem but is a way around it and ended my frustration. Hope this helps.

Revision history for this message
YannUbuntu (yannubuntu) wrote :

Hey! the bug https://bugs.launchpad.net/ubuntu/+source/ubufox/+bug/480514 is NOT a duplicate as Kubuntu is NOT the only one concerned !

Revision history for this message
Heimen Stoffels (vistaus) wrote :

I can confirm that it doesn't wok on Firefox. It sure isn't a AppArmor bug blocking acces, because the bug is not present when you try to install a package with apt:// from Chromium.

Changed in ubufox (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
BP_CH (bp-ch) wrote :

I confirm the with firefox 3.5.7 and despite reinstall of all mentionned packages (apturl, ubufox , firefox-gnome-support) it does not work.

Revision history for this message
Shaved Wookie (shavedwookie) wrote :

It also works if you install a package with an apt url in konqueror

Revision history for this message
Danté (dante-ashton) wrote :

I can confirm it fails with Firefox and Konq.

Revision history for this message
YannUbuntu (yannubuntu) wrote :

I think the title of this bug should be changed as kubuntu is not the only browser concerned.
Apturl links is a feature very appreciated in the ubuntu-fr community, but APTURL links should work out-of-the-box for all browsers !

Revision history for this message
Christoph Korn (c-korn) wrote :

Is this bug still present in lucid ?

Revision history for this message
RussianNeuroMancer (russianneuromancer) wrote :

I test it with Kubuntu 10.04 and Firefox 3.6.3. Looks like this bug is still present in Kubuntu, but maybe fixed in Ubuntu - I not test it in Ubuntu.

Revision history for this message
slibuntu (stuohy1) wrote :

Can confirm that bug is still present in Ubuntu Lucid running Firefox 3.6.3

Revision history for this message
YannUbuntu (yannubuntu) wrote :

Updated the title (removed the reference to Kubuntu as Gnome other environments are also affected).

summary: - apturl doesn't work with firefox on kubuntu
+ apturl doesn't work with Firefox
Revision history for this message
Heimen Stoffels (vistaus) wrote :

This bug is still present. Will it ever get fixed?

Revision history for this message
Andrew Gunnerson (cxl) wrote :

This does not apply in Ubuntu 10.04 with Firefox 3.6.3. apt:// urls for GetDeb and the Ubuntu repository work fine.

Revision history for this message
YannUbuntu (yannubuntu) wrote :

What about Kubuntu, Xubuntu , Lubuntu ... ?

Revision history for this message
Rafeeq (firech) wrote :

Xubuntu 10.04 + Google Chrome = doesn't work.

Revision history for this message
RussianNeuroMancer (russianneuromancer) wrote :

What version of Google Chrome you are using?
In my case for Chromium 5.0 and 6.0 in Kubuntu I can't confirm this bug.
You can try in Gnome and KDE?

Revision history for this message
Jogai (jogai) wrote :
Revision history for this message
Laurent Simon (stratic) wrote :

I confirm that apt:// urls did not work under KUbuntu 10.04 (amd64) with Firefox 3.6.3.

And jogai trick for resolving AptURL did not work for me.

AHMAD ANAS (a7x-live)
Changed in ubufox (Ubuntu):
assignee: nobody → AHMAD ANAS (a7x-live)
status: Confirmed → New
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Please don't change the bug status without any explanation.

This issue is fixed already in Maverick anyway

affects: ubufox (Ubuntu) → apturl (Ubuntu)
Changed in apturl (Ubuntu):
assignee: AHMAD ANAS (a7x-live) → nobody
status: New → Fix Released
Revision history for this message
Alexander (cimerman-alexander) wrote :
Revision history for this message
grahamt (grahamtooley) wrote :

>http://www.getdeb.net/updates/Ubuntu/10.10/?q=Handbrake
>this realy woorks

Not for me it doesn't. :-(

It still says:

"Firefox doesn't know how to open this address, because the protocol (apt) isn't associated with any program."

Firefox 3.6.15 on Kubuntu Maverick KDE Platform Version 4.6.1

Revision history for this message
Flames_in_Paradise (ellisistfroh-deactivatedaccount) wrote :

Still an issue with Natty & FF 4.0.1. Does not work 4 me :-_(

Ubufox installed + activated - no change
Gnome Firefox support installed - no change

Even Changes like recommended for FF3 via about don't help. How to get apturl to work in FF?

Revision history for this message
Patrick (mail-elliott-brennan) wrote :

KDE 4.4.5
Ubuntu 10.04
Fresh install
Not working in Firefox
Works with Chrome 11.0.696.68

Revision history for this message
Rafael Belmonte (eaglescreen) wrote :

Not working in precise.
Why can't I change the status?

Revision history for this message
Christiansen (happylinux) wrote :

No luck in Kubuntu Precise Beta (with all updates as of 2012-04-20 applied) either - using Firefox 11.0+build1-0ubuntu4.

Revision history for this message
James Cain (ronnoc) wrote :

Not working here either. Maybe we should open a new bug?

Revision history for this message
George (geoaraujo) wrote :

Not working.

Kubuntu 12.04 64-bit.

Revision history for this message
acar burak (acarbura) wrote :

Not working here either (Kubuntu 12.04 64 bit).

Revision history for this message
Micah Gersten (micahg) wrote :

Please file a new bug, this issue was fixed 2 years ago.

Revision history for this message
Adam Lendas (otheim) wrote :

Installation from site www.getdeb.net works well with Opera 12.02 (Kubuntu 12.04 x84_64)

Revision history for this message
ok (undefineddecoder) wrote :

Confirmed Still an issue with firefox 16.0.2 Kubuntu 12.04 64-bit. Konqueror doesn't do it either.

Revision history for this message
Kebap (leckerkebap) wrote :

Still happening. Freshly installed Kubuntu 12.04 64bit. Firefox 18.0.2.

Tried adding to about:config a new entry "network.protocol-handler.app.apt" with string "/usr/bin/apturl"

Still receive error message: "Firefox doesn't know how to open this address, because the protocol (apt) isn't associated with any program."

Changed in apturl (Ubuntu):
assignee: nobody → Rus Robert Mirel (bob89forever)
description: updated
Revision history for this message
Patrick (ikke-den-tricky) wrote :

Kebap (leckerkebap)
after adding the lines i recieved"open with" browsed to " /usr/bin/apturl" checked "Always use the selected program to open this kind of file"
it works now for me

Revision history for this message
Marlin (lytefm) wrote :

Worked for me on Kubuntu 13.04 after I changed the Application Settings for apturl in Firefox to
/usr/bin/apturl-kde

Revision history for this message
Friedhelm (friedhelm-feinbein) wrote :

Couldn't get Firefox (31.0) to work, but used this with Rekonq as a workaround:

Add this line:
application/x-deb=AptURL.desktop;

to:
~/.local/share/applications/mimeapps.list

Works with Kubuntu 14.04 LTS and using Rekonq to access PlayDeb for me.

Thanks to:
http://askubuntu.com/questions/279161/how-to-open-deb-from-nautilus-with-apturl

Revision history for this message
fathi733@gmail.com (fathi733-gmail) wrote :

thanx to Friedhelm (friedhelm-feinbein

it works for me

kubuntu14.4

Mathew Hodson (mhodson)
Changed in apturl (Ubuntu):
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers