Upgrading of apturl to 0.4.0ubuntu3 fails

Bug #422825 reported by mvandeg on 2009-09-01
This bug affects 240 people
Affects Status Importance Assigned to Milestone
apturl (Ubuntu)
High
Michael Vogt

Bug Description

Binary package hint: apturl

When trying to upgrade apturl to 0.4.0ubuntu2, the installation fails with the message:

E: /var/cache/apt/archives/apturl_0.4.0ubuntu2_all.deb: error creating directory `./usr/lib/python2.6/dist-packages/AptUrl/gtk'

Probably the dot at the start of the directory name is incorrect.

Bug is confirmed, so we don't need more "me, too" reports. For a workaround, see Comment #8 (https://bugs.launchpad.net/ubuntu/+source/apturl/+bug/422825/comments/8) (corrects a typo in comment #7).

DKcross (dkcross) wrote :

Yo también tengo este problema, reportado, saludos.

DKcross (dkcross) wrote :

Preparando para reemplazar apturl 0.3.6ubuntu1 (usando .../apturl_0.4.0ubuntu2_all.deb) ...
Desempaquetando el reemplazo de apturl ...
Reemplazado por ficheros en el paquete instalado apturl-common ...
dpkg: error al procesar /var/cache/apt/archives/apturl_0.4.0ubuntu2_all.deb (--unpack):
 error al crear el directorio `./usr/lib/python2.6/dist-packages/AptUrl/gtk': No existe el fichero ó directorio
Se encontraron errores al procesar:
 /var/cache/apt/archives/apturl_0.4.0ubuntu2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
dk@freehost:~$

Christopher (soft-kristal) wrote :

Also tried via synaptic.

komputes (komputes) wrote :

I can confirm this as well. It happened today when upgrading packages in Karmic Alpha.

I get the following error:

E: /var/cache/apt/archives/apturl_0.4.0ubuntu2_all.deb: error creating directory `./usr/lib/python2.6/dist-packages/AptUrl/gtk'

(Reading database ... 294733 files and directories currently installed.)
Preparing to replace apturl 0.3.6ubuntu1 (using .../apturl_0.4.0ubuntu2_all.deb) ...
Unpacking replacement apturl ...
Replaced by files in installed package apturl-common ...
dpkg: error processing /var/cache/apt/archives/apturl_0.4.0ubuntu2_all.deb (--unpack):
 error creating directory `./usr/lib/python2.6/dist-packages/AptUrl/gtk': No such file or directory
Errors were encountered while processing:
 /var/cache/apt/archives/apturl_0.4.0ubuntu2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up apturl-common (0.4.0ubuntu2) ...

Setting up libempathy-common (2.27.91.1-2ubuntu2) ...
Setting up libempathy-gtk-common (2.27.91.1-2ubuntu2) ...

Changed in apturl (Ubuntu):
status: New → Confirmed

andy@fileserver:/$ file /usr/lib/python2.6/dist-packages/AptUrl/gtk
/usr/lib/python2.6/dist-packages/AptUrl/gtk: directory
andy@fileserver:/$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
  apturl
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
25 not fully installed or removed.
Need to get 0B/12.3kB of archives.
After this operation, 102kB disk space will be freed.
Do you want to continue [Y/n]? Y
(Reading database ... 107558 files and directories currently installed.)
Preparing to replace apturl 0.3.6ubuntu1 (using .../apturl_0.4.0ubuntu2_all.deb) ...
Unpacking replacement apturl ...
Replaced by files in installed package apturl-common ...
dpkg: error processing /var/cache/apt/archives/apturl_0.4.0ubuntu2_all.deb (--unpack):
 error creating directory `./usr/lib/python2.6/dist-packages/AptUrl/gtk': No such file or directory
Errors were encountered while processing:
 /var/cache/apt/archives/apturl_0.4.0ubuntu2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

andy@fileserver:/$ ls -l /usr/lib/python2.6/dist-packages/AptUrl/gtk
total 16
lrwxrwxrwx 1 root root 39 2009-09-01 21:45 GtkUI.py -> /usr/share/pyshared/AptUrl/gtk/GtkUI.py
-rw-r--r-- 1 root root 8245 2009-09-01 21:45 GtkUI.pyc
lrwxrwxrwx 1 root root 42 2009-09-01 21:45 __init__.py -> /usr/share/pyshared/AptUrl/gtk/__init__.py
-rw-r--r-- 1 root root 142 2009-09-01 21:45 __init__.pyc

andy@fileserver:/$ uname -a
Linux fileserver 2.6.31-9-generic #29-Ubuntu SMP Sun Aug 30 17:39:26 UTC 2009 x86_64 GNU/Linux

andy@fileserver:/$ apt-cache policy apturl
apturl:
  Installed: 0.3.6ubuntu1
  Candidate: 0.4.0ubuntu2
  Version table:
     0.4.0ubuntu2 0
        500 http://gb.archive.ubuntu.com karmic/main Packages
 *** 0.3.6ubuntu1 0
        100 /var/lib/dpkg/status

Fabián Rodríguez (magicfab) wrote :

Seetting importance to High:
1. Has a severe impact on a small portion of Ubuntu users (estimated)
2. Makes a default Ubuntu installation generally unusable for some users
    * For example, if the system fails to boot, or X fails to start, on a certain make and model of computer
3. Has a moderate impact on a large portion of Ubuntu users (estimated)

I believe #2 breaks further updates/synaptic too.

Changed in apturl (Ubuntu):
importance: Undecided → High

if you run:

sudo apt-get clean; sudo apt-get --purge remove apturl-common apturl; sudo apt-get --purge autoremove; sudo apt-get update; sudo apt-get install apt-url

its fine

Noel J. Bergman (noeljb) wrote :

Typo in comment $7. Use:

sudo apt-get clean; sudo apt-get --purge remove apturl-common apturl; sudo apt-get --purge autoremove;
sudo apt-get update; sudo apt-get install apturl

and you will probably want to add ubufox as well, since the apt-get remove will have gotten rid of it.

zoomy942 (zoomy942) wrote :

affects me as well

Nicolas Valcarcel (nvalcarcel) wrote :

still present in 0.4.0ubuntu3:
Preparing to replace apturl 0.3.6ubuntu1 (using .../apturl_0.4.0ubuntu3_all.deb) ...
Unpacking replacement apturl ...
Replaced by files in installed package apturl-common ...
dpkg: error processing /var/cache/apt/archives/apturl_0.4.0ubuntu3_all.deb (--unpack):
 error creating directory `./usr/lib/python2.6/dist-packages/AptUrl/gtk': No such file or directory
Errors were encountered while processing:
 /var/cache/apt/archives/apturl_0.4.0ubuntu3_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Noel J. Bergman (noeljb) on 2009-09-01
description: updated
summary: - Upgrading of apturl to 0.4.0ubuntu2 fails
+ Upgrading of apturl to 0.4.0ubuntu3 fails
Nicolas Valcarcel (nvalcarcel) wrote :

Still getting the problem after following steps in comment #8

Noel J. Bergman (noeljb) wrote :

Really? They worked for me:

Reading state information... Done
The following extra packages will be installed:
  apturl-common
The following NEW packages will be installed:
  apturl apturl-common
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 26.9kB of archives.
After this operation, 348kB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://archive.ubuntu.com karmic/main apturl-common 0.4.0ubuntu3 [14.4kB]
Get:2 http://archive.ubuntu.com karmic/main apturl 0.4.0ubuntu3 [12.4kB]
Fetched 26.9kB in 0s (42.2kB/s)
Selecting previously deselected package apturl-common.
(Reading database ... 152437 files and directories currently installed.)
Unpacking apturl-common (from .../apturl-common_0.4.0ubuntu3_all.deb) ...
Selecting previously deselected package apturl.
Unpacking apturl (from .../apturl_0.4.0ubuntu3_all.deb) ...
Processing triggers for man-db ...
Setting up apturl-common (0.4.0ubuntu3) ...
INFO: using unknown version '/usr/bin/python3.0' (debian_defaults not up-to-date?)

Setting up apturl (0.4.0ubuntu3) ...
INFO: using unknown version '/usr/bin/python3.0' (debian_defaults not up-to-date?)

comment #8 worked for me.

In comment #8 misses the removal of ubufox, this worked for me:

sudo apt-get clean; sudo apt-get --purge remove apturl-common apturl ubufox; sudo apt-get --purge autoremove; sudo apt-get update; sudo apt-get install apt-url ubufox

Andrea Caminiti (nrayever) wrote :

it worked great! thanks!

works for my too

picobird (picobird) wrote :

Unpacking replacement apturl ...
Replaced by files in installed package apturl-common ...
dpkg: error processing /var/cache/apt/archives/apturl_0.4.0ubuntu3_all.deb (--unpack):
 error creating directory `./usr/lib/python2.6/dist-packages/AptUrl/gtk': No such file or directory

thanks ... work for me too :)

zee (wqzandrew) wrote :

work for me too

hi guys,

I got the same:

E: /var/cache/apt/archives/apturl_0.4.0ubuntu3_all.deb: error creating
directory `./usr/lib/python2.6/dist-packages/AptUrl/gtk'

best,

On Wed, Sep 2, 2009 at 12:31 AM, zee <email address hidden> wrote:

> work for me too
>
> --
> Upgrading of apturl to 0.4.0ubuntu3 fails
> https://bugs.launchpad.net/bugs/422825
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “apturl” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: apturl
>
> When trying to upgrade apturl to 0.4.0ubuntu2, the installation fails with
> the message:
>
> E: /var/cache/apt/archives/apturl_0.4.0ubuntu2_all.deb: error creating
> directory `./usr/lib/python2.6/dist-packages/AptUrl/gtk'
>
> Probably the dot at the start of the directory name is incorrect.
>
> Bug is confirmed, so we don't need more "me, too" reports. For a
> workaround, see Comment #8 (
> https://bugs.launchpad.net/ubuntu/+source/apturl/+bug/422825/comments/8)
> (corrects a typo in comment #7).
>

--

Felipe Andrés Besoaín Pino
Ing. En Bioinformática
Universidad de Talca- Chile
Universidad Politecnica de Madrid

@Felipe,

Open a terminal window and type the commands shown in comment #8 on this bug to fix.

-ss.

Silvercircle (piechura) wrote :

Mh, i renamed the directory gtk and installed again... but now my links looks a bit differend as in post #5.

$ ls -l /usr/lib/python2.6/dist-packages/AptUrl/gtk
insgesamt 16
lrwxrwxrwx 1 root root 49 2009-09-02 09:19 GtkUI.py -> ../../../../../share/pyshared/AptUrl/gtk/GtkUI.py
-rw-r--r-- 1 root root 8245 2009-09-02 09:19 GtkUI.pyc
lrwxrwxrwx 1 root root 52 2009-09-02 09:19 __init__.py -> ../../../../../share/pyshared/AptUrl/gtk/__init__.py
-rw-r--r-- 1 root root 142 2009-09-02 09:19 __init__.pyc

is this a problem ?

Silvercircle: check comment #8, fixes all (Its a de-typoed version of mine which is #7 *wink*)

Works like a charm. The upgrade issue still should be graceful and not require these extra steps.

Silvercircle (piechura) wrote :

actionparsnip: i renamed the folder before reading the bugreport... ;)

for testing i run the commands from post 8 and the links haven't changed, so, i think it's no problem.

Nandan Vaidya (gotunandan) wrote :

Yes, comment #8 works perfectly.

Shouldnt this be rather trivial to fox ?

I would think it's just a small packaging issue, no code involved.

David Favor (davidfavor) wrote :

Did the steps in #8 and I the problem remains:

Calculating upgrade... Done
The following NEW packages will be installed:
  apturl-common
The following packages will be upgraded:
  apturl
1 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/26.9kB of archives.
After this operation, 111kB of additional disk space will be used.
Do you want to continue [Y/n]?
Selecting previously deselected package apturl-common.
(Reading database ... 208143 files and directories currently installed.)
Unpacking apturl-common (from .../apturl-common_0.4.0ubuntu3_all.deb) ...
Preparing to replace apturl 0.3.6ubuntu1 (using .../apturl_0.4.0ubuntu3_all.deb) ...
Unpacking replacement apturl ...
Replaced by files in installed package apturl-common ...
dpkg: error processing /var/cache/apt/archives/apturl_0.4.0ubuntu3_all.deb (--unpack):
 error creating directory `./usr/lib/python2.6/dist-packages/AptUrl/gtk': No such file or directory
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/apturl_0.4.0ubuntu3_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

inode77 (simon-gerber) wrote :

For me instructions under #8 resolved the issue.

David Favor: did you use it as is, including the --purge bits? Did you also --purge remove alturl as well as apurl-common
Then reinstall it.
apturl is not essential so can simply be uninstalled to make life smoother.

Greg Monahan (greg-monahan) wrote :

Comment #14 has a typo at end - "apt-url" vice "apturl"

Should be:
sudo apt-get clean; sudo apt-get --purge remove apturl-common apturl ubufox; sudo apt-get --purge autoremove; sudo apt-get update; sudo apt-get install apturl ubufox

David Favor (davidfavor) wrote :

Redid commands in #8 again and it worked this time.

Thanks!

Michael Vogt (mvo) on 2009-09-02
Changed in apturl (Ubuntu):
milestone: none → karmic-alpha-5
chinakr (chinakr) wrote :

$ sudo apt-get --purge remove apturl-common apturl ubufox
$ sudo apt-get --purge autoremove
$ sudo aptitude install apturl ubufox

Then it fixed!

Michael Vogt (mvo) wrote :

I uploaded a new version (0.4.0ubuntu4) that should fix the bug.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apturl - 0.4.0ubuntu4

---------------
apturl (0.4.0ubuntu4) karmic; urgency=low

  * build without "DH_PYCENTRAL=include-links" for now,
    to work around breakage when upgrading from the previous
    version that was build without the include-links option
    (LP: #422825)

 -- Michael Vogt <email address hidden> Wed, 02 Sep 2009 17:44:54 +0200

Changed in apturl (Ubuntu):
status: Confirmed → Fix Released
Michael Vogt (mvo) on 2009-09-02
Changed in apturl (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
status: Fix Released → Confirmed
Michael Vogt (mvo) wrote :

This should be fixed with 0.4.0ubuntu4 (setting it back to confirmed was a unintended side-effect of assigning it to me)

Changed in apturl (Ubuntu):
status: Confirmed → Fix Released
Felipe Besoain (fbesoain) wrote :

hi,

I fixed for me as well.

fbesoain@mythos:~$ sudo apt-get install apturl
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  apturl-common
The following NEW packages will be installed:
  apturl apturl-common
0 upgraded, 2 newly installed, 0 to remove and 1 not upgraded.
Need to get 26.5kB of archives.
After this operation, 311kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://us.archive.ubuntu.com karmic/main apturl-common 0.4.0ubuntu4 [14.2kB]
Get:2 http://us.archive.ubuntu.com karmic/main apturl 0.4.0ubuntu4 [12.3kB]
Fetched 26.5kB in 1s (14.6kB/s)
Selecting previously deselected package apturl-common.
(Reading database ... 138258 files and directories currently installed.)
Unpacking apturl-common (from .../apturl-common_0.4.0ubuntu4_all.deb) ...
Selecting previously deselected package apturl.
Unpacking apturl (from .../apturl_0.4.0ubuntu4_all.deb) ...
Processing triggers for man-db ...
Setting up apturl-common (0.4.0ubuntu4) ...

Setting up apturl (0.4.0ubuntu4) ...
Done.

I fixed it using the follow commands:

# mkdir /usr/lib/python2.6/dist-packages/AptUrl
# apt-get install apturl --reinstall

Fixed after updating to 0.4.0ubuntu.

Confirmed. Fixed by 0.4.0ubuntu4. Thank you and keep up the good work.

Changed in apturl (Ubuntu):
status: Fix Released → Confirmed
Max Bowsher (maxb) on 2009-10-17
Changed in apturl (Ubuntu):
status: Confirmed → Fix Released
Felipe Besoain (fbesoain) wrote :

Thanks for fixing the bug

enviado via htc dream g1, android (escrito con mis pulgares )

On Oct 16, 2009 11:30 PM, "Max Bowsher" <email address hidden> wrote:

** Changed in: apturl (Ubuntu)
      Status: Confirmed => Fix Released

-- Upgrading of apturl to 0.4.0ubuntu3 fails
https://bugs.launchpad.net/bugs/422825 You received t...
Status in “apturl” package in Ubuntu: Fix Released

Bug description: Binary package hint: apturl When trying to upgrade apturl
to 0.4.0ubuntu2, the in...

To post a comment you must log in.