Should use GtkBuilder rather than libglade

Bug #403533 reported by Sebastien Bacher on 2009-07-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apturl (Ubuntu)
Wishlist
Michael Terry

Bug Description

Binary package hint: apturl

" Since version 2.12, GTK+ provides GtkBuilder to construct user interfaces from XML descriptions, similar to the functionality provided by GladeXML in the libglade library. "

GNOME is migrating to GtkBuilder for GNOME3 and it would be nice if the default install for the coming LTS would stop using libglade too which means this software should be updated in the next cycle.

You can find details on what changes are required on http://library.gnome.org/devel/gtk/stable/gtk-migrating-GtkBuilder.html

Related branches

Changed in apturl (Ubuntu):
importance: Undecided → Wishlist
Michael Terry (mterry) on 2010-10-05
Changed in apturl (Ubuntu):
assignee: nobody → Michael Terry (mterry)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apturl - 0.4.2ubuntu1

---------------
apturl (0.4.2ubuntu1) natty; urgency=low

  * Switch from glade to GtkBuilder (LP: #403533)
 -- Michael Terry <email address hidden> Tue, 05 Oct 2010 11:06:24 -0400

Changed in apturl (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers