ubufox can't install adobe flash plugin on 64-bit jaunty live-cd

Bug #363798 reported by Przemek K. on 2009-04-19
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
apturl (Ubuntu)
Low
Michael Vogt
Jaunty
Low
Michael Vogt
ubufox (Ubuntu)
Medium
Unassigned
Jaunty
Medium
Unassigned

Bug Description

Binary package hint: ubufox

Ubufox can't install adobe flash plugin on 64-bit jaunty livecd.
Ubufox asks to enable multiverse repository to install flashplugin-installer package, but it doesn't enable universe, which is required by flashplugin's dependencies: ia32-libs and nspluginwrapper, so the installation fails.
Tested using Ubuntu 9.04 RC 64-bit live cd.

John Vivirito (gnomefreak) wrote :

We don't enable universe repos intentionally.
You have to enable it to use it. multiverse and universe are not the same the dialog is correct you need to enable multiverse.

Changed in ubufox (Ubuntu):
status: New → Won't Fix
Przemek K. (azrael) wrote :

Sure they are not the same, but they are both required to install adobe flash plugin on 64-bit ubuntu.
So you are wrong, and ubufox should be patched to install flash plugin correctly on 64-bit systems.

Changed in ubufox (Ubuntu):
status: Won't Fix → New
John Vivirito (gnomefreak) wrote :

You are correct that ubufox should install it properly and it does once the repos are enabled, ubufox AFAICR is not designed to enable repos. You being on 64bit need to install nspluginwrapper as well.

Please give me more details on what and how you would like ubufox handle plugins (nspluginwrapper) is not a plugin.
Oh and please dont set bugs back to new please use incomplete instead

Changed in ubufox (Ubuntu):
status: New → Incomplete
Alexander Sack (asac) wrote :

usually universe is enabled by default; anyway, seems to be an apturl bug ... though not sure how smart apturl can get for this; however, considering universe a prerequisites for multiverse section should make sense and we should probably add a special fix for this at least.

affects: ubufox (Ubuntu) → apturl (Ubuntu)
Changed in apturl (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
status: Incomplete → New
importance: Undecided → Low
Przemek K. (azrael) wrote :

If a plugin depends on a component from another repo (here: universe) then Ubufox should enable it too.
I know that dependency checking is not Ubufox' job, so maybe we could just make a special case for Adobe Flash plugin on 64-bit Ubuntu? (At least until a stable 64-bit version is released)

"ubufox AFAICR is not designed to enable repos"
But it still does ask if you want to enable multiverse when you want to install Flash. Maybe this is an issue with some backend then? Packagekit? Apt? I don't know which one is called by Ubufox.

Alexander Sack (asac) wrote :

well. ubufox has no business with enabling repos. it uses apturl which does the job. hence i moved this bug there.

Alexander Sack (asac) wrote :

a dupe: https://bugs.edge.launchpad.net/bugs/361430

seems universe is not enabled on livecd? shouldnt be a problem on real installs as that has universe enabled by default. Michael, what do you think?

Michael Vogt (mvo) wrote :

I will add code that special cases "multiverse" and auto enable both multiverse and universe when its requested.

Changed in apturl (Ubuntu):
status: New → Triaged
Michael Vogt (mvo) wrote :
Michael Vogt (mvo) on 2009-04-23
summary: - ubufox can't install adobe flash plugin on 64-bit jaunty
+ ubufox can't install adobe flash plugin on 64-bit jaunty live-cd
Alexander Sack (asac) wrote :

if fixed this on the ubufox webservice side and rolled this to production webservice; should work now. Thanks!

bzr commit -m "* append ?section=universe for multiverse apturls to reflect that multiverse
> depends on universe; this fixes ubufox flashplugin-installer install on live-cd (LP: #363798)
> - update pfs/web/plugin-finder.py" --fixes lp:363798
Committing to: bzr+ssh://<email address hidden>/~asac/ubufox/main/
modified pfs/web/plugin-finder.py
Committed revision 164.

Changed in apturl (Ubuntu Jaunty):
milestone: none → jaunty-updates
Changed in ubufox (Ubuntu Jaunty):
importance: Undecided → Medium
milestone: none → ubuntu-9.04
status: New → Fix Released
Alexander Sack (asac) wrote :

fixing apturl/synpatic is karmic stuff.

Changed in apturl (Ubuntu Jaunty):
status: Triaged → Won't Fix
Changed in apturl (Ubuntu):
milestone: jaunty-updates → none
T (myts33) on 2009-11-22
Changed in ubufox (Ubuntu):
status: Fix Released → Fix Committed
Changed in ubufox (Ubuntu):
status: Fix Committed → Fix Released
Changed in apturl (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers