[Firefox 3.0] apt://-urls don't launch packet-manager

Bug #257301 reported by Lars Noodén on 2008-08-12
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Invalid
Undecided
Unassigned
apturl (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox-3.0

URL's starting with apt:// don't launch packet-manager, even though /usr/bin/apturl exists, is executable and works correctly if invoked directly from command-line.

$ ls -la /usr/bin/apturl
-rwxr-xr-x 1 root root 12023 2008-04-16 00:40 /usr/bin/apturl

The settings in about:config are correct:

network.protocol-handler.app.apt;/usr/bin/apturl
network.protocol-handler.app.apt+http;/usr/bin/apturl

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 8.04
Package: firefox-3.0 3.0.1+build1+nobinonly-0ubuntu0.8.04.3
Uname: Linux 2.6.24-19-generic x86_64

Lars Noodén (larsnooden) wrote :
Andreas Moog (ampelbein) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

If you enter "about:config" as url, please look for an option called:

network.protocol-handler.app.apt with the value: /usr/bin/apturl

Is this existing? If so, what does

'ls -la /usr/bin/apturl'

say?

Changed in firefox-3.0:
status: New → Incomplete
Lars Noodén (larsnooden) wrote :

$ ls -la /usr/bin/apturl
-rwxr-xr-x 1 root root 12023 2008-04-16 00:40 /usr/bin/apturl

$ lsb_release -rc
Release: 8.04
Codename: hardy

$ apt-cache showpkg firefox
Package: firefox
Versions:
3.0.1+build1+nobinonly-0ubuntu0.8.04.3 (/var/lib/apt/lists/fi.archive.ubuntu.com_ubuntu_dists_hardy-updates_main_binary-amd64_Packages) (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_hardy-security_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language:
                 File: /var/lib/apt/lists/fi.archive.ubuntu.com_ubuntu_dists_hardy-updates_main_binary-amd64_Packages
                  MD5: 8178b112e411f81e8551cba3d8b48859

3.0~b5+nobinonly-0ubuntu3 (/var/lib/apt/lists/fi.archive.ubuntu.com_ubuntu_dists_hardy_main_binary-amd64_Packages)
 Description Language:
                 File: /var/lib/apt/lists/fi.archive.ubuntu.com_ubuntu_dists_hardy_main_binary-amd64_Packages
                  MD5: 8178b112e411f81e8551cba3d8b48859

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Have you had a look at

about:config?

What happens if you open a terminal and start apturl manually?
(e.g.: '/usr/bin/apturl firefox')
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkij67EACgkQ06FgkPZwicSc/QCeJ64GCtHdQe9CiZM97go9Eq5a
OisAoIg4RjPQdxHcl4sQXyd5G0CF1/ji
=Cv+D
-----END PGP SIGNATURE-----

Here is the current settings for about:config

apturl is present on the system:

$ apturl
/usr/lib/python2.5/site-packages/apt/__init__.py:18: FutureWarning: apt API not stable yet
  warnings.warn("apt API not stable yet", FutureWarning)
QSettings: failed to open file '/etc/qt3/qt_plugins_3.3rc'

Andreas Moog (ampelbein) wrote :

Ok, please try this command

apturl firefox

What does it say onscreen?

And please verify that in about:config the option network.protocol-handler.app.apt is set to apturl. I can't read your attachment to the previous comment.

Lars Noodén (larsnooden) wrote :

$ apturl firefox
/usr/lib/python2.5/site-packages/apt/__init__.py:18: FutureWarning: apt API not stable yet
  warnings.warn("apt API not stable yet", FutureWarning)
QSettings: failed to open file '/etc/qt3/qt_plugins_3.3rc'

about:config the option network.protocol-handler.app.apt says:

network.protocol-handler.app.apt;/usr/bin/apturl
network.protocol-handler.app.apt+http;/usr/bin/apturl

Lars Noodén wrote:
> $ apturl firefox
> /usr/lib/python2.5/site-packages/apt/__init__.py:18: FutureWarning: apt API not stable yet
> warnings.warn("apt API not stable yet", FutureWarning)
> QSettings: failed to open file '/etc/qt3/qt_plugins_3.3rc'

And do you see a window popping up after this messages?

Yes, I see a window popping up after those messages. A warning dialog pops up with the message:

"Invalid url: 'firefox' given, exiting"

If I give 'apturl' a real URL / package, then it responds well with other dialogs:

e.g.
apturl apt://tidy

"Package 'tidy' is already installed"

e.g.
apturl apt://bind9

"Install package

Do you want to install the package 'bind9'?

Description

No Yes"

Andreas Moog (ampelbein) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in firefox-3.0:
status: Incomplete → Confirmed
description: updated
Andreas Moog (ampelbein) wrote :

One thing I forgot to ask:

If you invoke firefox from a terminal, is there any message displayed?

Lars Noodén (larsnooden) wrote :

$ firefox
QSettings: failed to open file '/etc/qt3/qt_plugins_3.3rc'

That's it.

Andreas Moog (ampelbein) wrote :

Just filed the bug upstream.

Changed in firefox:
status: Unknown → New
Mackenzie Morgan (maco.m) wrote :

Changing status to triaged, since there's enough information to be worked on.

Changed in firefox-3.0:
status: Confirmed → Triaged
ironstorm (ironstorm-gmail) wrote :

This is still a problem in the latest Jaunty alpha...

Micah Gersten (micahg) wrote :

This seems to work fine in the latest Jaunty + Firefox combo. Can the reporter or someone else who previously had the issue confirm?

Changed in firefox-3.0 (Ubuntu):
status: Triaged → Incomplete
John Vivirito (gnomefreak) wrote :

Moved to apturl package since the reporters comment does not mention that it is stricly a firefox apturl link.

Changed in firefox:
importance: Unknown → Undecided
status: New → Invalid
affects: firefox-3.0 (Ubuntu) → apturl (Ubuntu)
John Vivirito (gnomefreak) wrote :

Can the reporter of the upstream bug mark it invalid or such, this is not a bug direct to firefox

Lars Noodén (larsnooden) wrote :

It appears to still be present in Jaunty. However, 8.04, the Long Term Support version, would be more useful to fix.

Changed in firefox:
status: Invalid → New
John Vivirito (gnomefreak) wrote :

This bug is not releated to firefox nor is this bug task for firefox it is for upstream bugs, please leave it closed.

Changed in firefox:
status: New → Invalid
siafok (wlar-siafok-wp) wrote :

I have same issue on KK

Denis Walrave (deniswalrave) wrote :

Same issue on Karmic Koala.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.