Ubuntu

Don't work with Firefox3 beta5

Reported by Patrice Vetsel on 2008-03-18
24
Affects Status Importance Assigned to Milestone
apturl (Ubuntu)
Medium
Michael Vogt

Bug Description

Binary package hint: apturl

Hardy uptodate 20080406.

1/ open firefox3 beta5
2/ as link put "apt://inkscape"
3/ validate and confirm that apt protocol is not handled by firefox

Changed in apturl:
importance: Undecided → Medium
milestone: none → ubuntu-8.04
Bardur Simonsen (bard-simonsen) wrote :

confirmed, handler for apt:// needs to be preconfigured

Changed in apturl:
status: New → Confirmed
Michael Vogt (mvo) wrote :

firefox now uses: /usr/lib/firefox-3.0b4/defaults/syspref -> /etc/firefox-3.0/pref

Alexander Sack (asac) on 2008-03-26
Changed in apturl:
assignee: nobody → asac
André Gondim (andregondim) wrote :

I always put apturl in my blog like this: http://andregondim.eti.br/?p=283 but in AptURL at ff 3 beta 4 does not work...

Michael Vogt (mvo) on 2008-04-02
Changed in apturl:
assignee: asac → mvo
status: Confirmed → Fix Committed
Michael Vogt (mvo) wrote :

Hm, I put the following file:

/etc/firefox-3.0/pref/apturl.js

with:
pref("network.protocol-handler.app.apt","/usr/bin/apturl");
pref("network.protocol-handler.warn-external.apt",false);
pref("network.protocol-handler.app.apt+http","/usr/bin/apturl");
pref("network.protocol-handler.warn-external.apt+http",false);

into the package but this dosn't seem to work. I tried "../etc/firefox-3.0/defaults/pref/" too without success.

Changed in apturl:
status: Fix Committed → In Progress
description: updated

I really hope this will be fixed before release. Adding a link to apt://package is _much_ better than telling people to copy and paste sudo commands. It's easier, but it's also alot safer.

Michael Vogt (mvo) wrote :

This is fixed with the latest apturl and firefox in hardy.

Changed in apturl:
status: In Progress → Fix Released
RuiP (ruipais) wrote :

This seems to be solved only for the case of user had already a working profile on ~/.mozilla/firefox/
Recent versions of FF3b5 still have this problem if a profile it's made from fresh (even if apturl.js its correctly set).

Problem seems to be file mimeTypes.rdf created from template don't update correctly on 1st run for dealing with deb mimetype.

It's easy to reproduce by closing all FF, move .mozilla/firefox to some temporarily place and start FF3.
After run the new mimeTypes.rdf don't any reference to deb/apturl and debs are not open with apturl.
A simple copy of old mimeTypes.rdf make it work again.

Changed in apturl:
status: Fix Released → Incomplete
Steve Langasek (vorlon) wrote :

I've tested by moving my .mozilla directory aside and starting firefox, and can't reproduce the problem you're describing. I think this bug is fixed as indicated; please open a new bug report for the issue you're seeing.

Changed in apturl:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers