apturl should depend on gir1.2-unity-5.0

Bug #1337799 reported by Vlad Orlov on 2014-07-04
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
High
Unassigned
apturl (Ubuntu)
High
Unassigned

Bug Description

System: Xubuntu 14.10

When launched without Unity introspection package installed, apturl shows this warning:

WARNING:root:can not import unity GI cannot import name Unity, introspection typelib not found

Installing gir1.2-unity-5.0 package makes the warning go away. So I guess apturl should depend on it.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apturl (Ubuntu):
status: New → Confirmed
Vlad Orlov (monsta) wrote :

Same in 15.10 and 16.04.

tags: added: wily xenial
Vlad Orlov (monsta) wrote :

Not sure how I missed it, but I see it in Xubuntu 14.04 as well, only the import is a bit different (but the solution is the same):

WARNING:root:can not import unity GI cannot import name Dbusmenu, introspection typelib not found

tags: added: trusty
Changed in apturl (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → High
Vlad Orlov (monsta) on 2017-07-20
tags: added: zesty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers